diff options
author | Khem Raj <raj.khem@gmail.com> | 2013-07-01 07:23:21 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-07-08 10:35:57 +0200 |
commit | 830baf380ea86782a5a52fbe8762904840e05691 (patch) | |
tree | 3a6da23c5ef6f80540874e53478f5da3c3df297e /meta-oe/recipes-connectivity | |
parent | 8d0528448b9b79437cf04cd12b7a0dc282df3c48 (diff) | |
download | meta-openembedded-830baf380ea86782a5a52fbe8762904840e05691.tar.gz |
uhd: Fix compile errors
uhd would fail with wrong scope for uint8_t type
errors.
Signed-off-by: Khem Raj <raj.khem@gmail.com>
CC: Philip Balister <philip@balister.org>
Acked-by: Philip Balister <philip@balister.org>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r-- | meta-oe/recipes-connectivity/uhd/uhd/0001-use-uint8_t-from-boost-namespace.patch | 29 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/uhd/uhd_git.bb | 3 |
2 files changed, 31 insertions, 1 deletions
diff --git a/meta-oe/recipes-connectivity/uhd/uhd/0001-use-uint8_t-from-boost-namespace.patch b/meta-oe/recipes-connectivity/uhd/uhd/0001-use-uint8_t-from-boost-namespace.patch new file mode 100644 index 000000000..8978ddcc4 --- /dev/null +++ b/meta-oe/recipes-connectivity/uhd/uhd/0001-use-uint8_t-from-boost-namespace.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From 317f6f08cedf005ce1f2d6f0d04cfb2659863423 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sun, 30 Jun 2013 22:10:50 -0700 | ||
4 | Subject: [PATCH] use uint8_t from boost namespace | ||
5 | |||
6 | Fixes errors like | ||
7 | codec_ctrl.cpp:113:10: error: 'uint8_t' was not declared in this scope | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | host/lib/usrp/e100/codec_ctrl.cpp | 2 +- | ||
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/host/lib/usrp/e100/codec_ctrl.cpp b/host/lib/usrp/e100/codec_ctrl.cpp | ||
15 | index 13b3bc9..2c13176 100644 | ||
16 | --- a/host/lib/usrp/e100/codec_ctrl.cpp | ||
17 | +++ b/host/lib/usrp/e100/codec_ctrl.cpp | ||
18 | @@ -110,7 +110,7 @@ e100_codec_ctrl_impl::e100_codec_ctrl_impl(spi_iface::sptr iface){ | ||
19 | //_ad9862_regs.dis2 = ad9862_regs_t::DIS2_DIS; needed for transmit | ||
20 | |||
21 | //write the register settings to the codec | ||
22 | - for (uint8_t addr = 0; addr <= 25; addr++){ | ||
23 | + for (boost::uint8_t addr = 0; addr <= 25; addr++){ | ||
24 | this->send_reg(addr); | ||
25 | } | ||
26 | |||
27 | -- | ||
28 | 1.7.9.5 | ||
29 | |||
diff --git a/meta-oe/recipes-connectivity/uhd/uhd_git.bb b/meta-oe/recipes-connectivity/uhd/uhd_git.bb index 06d5effbd..180fd27c7 100644 --- a/meta-oe/recipes-connectivity/uhd/uhd_git.bb +++ b/meta-oe/recipes-connectivity/uhd/uhd_git.bb | |||
@@ -4,7 +4,8 @@ PV = "3.5.3" | |||
4 | PR = "${INC_PR}.0" | 4 | PR = "${INC_PR}.0" |
5 | 5 | ||
6 | SRC_URI = "git://ettus.sourcerepo.com/ettus/uhd.git;branch=maint;protocol=git \ | 6 | SRC_URI = "git://ettus.sourcerepo.com/ettus/uhd.git;branch=maint;protocol=git \ |
7 | " | 7 | file://0001-use-uint8_t-from-boost-namespace.patch;striplevel=2 \ |
8 | " | ||
8 | S = "${WORKDIR}/git/host" | 9 | S = "${WORKDIR}/git/host" |
9 | 10 | ||
10 | SRCREV = "f4c58120dc1e3674ee0228213f0f0011a0f80dcf" | 11 | SRCREV = "f4c58120dc1e3674ee0228213f0f0011a0f80dcf" |