diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-04-21 17:00:15 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-04-26 20:13:29 +0200 |
commit | 6723757dc4c2989482875ed6c93a997ecaefd600 (patch) | |
tree | 0eeaad58948386899d4fa8035887d3d3985f0424 /meta-oe/recipes-connectivity | |
parent | 1d7d2dbfc808270c963090b77253d96c0129a5a3 (diff) | |
download | meta-openembedded-6723757dc4c2989482875ed6c93a997ecaefd600.tar.gz |
lirc: update to 0.9.4d
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r-- | meta-oe/recipes-connectivity/lirc/lirc.inc | 13 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/lirc/lirc/0001-lircrcd-Mark-local-inline-funtions-as-static.patch | 49 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/lirc/lirc/pollfd.patch | 101 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/lirc/lirc_0.9.4d.bb (renamed from meta-oe/recipes-connectivity/lirc/lirc_0.9.2.bb) | 35 |
4 files changed, 126 insertions, 72 deletions
diff --git a/meta-oe/recipes-connectivity/lirc/lirc.inc b/meta-oe/recipes-connectivity/lirc/lirc.inc deleted file mode 100644 index 6ff8e0160..000000000 --- a/meta-oe/recipes-connectivity/lirc/lirc.inc +++ /dev/null | |||
@@ -1,13 +0,0 @@ | |||
1 | DESCRIPTION = "LIRC is a package that allows you to decode and send infra-red signals of many commonly used remote controls." | ||
2 | DESCRIPTION_append_lirc = " This package contains the lirc daemon, libraries and tools." | ||
3 | DESCRIPTION_append_lirc-exec = " This package contains a daemon that runs programs on IR signals." | ||
4 | DESCRIPTION_append_lirc-remotes = " This package contains some config files for remotes." | ||
5 | DESCRIPTION_append_lirc-nslu2example = " This package contains a working config for RC5 remotes and a modified NSLU2." | ||
6 | HOMEPAGE = "http://www.lirc.org" | ||
7 | SECTION = "console/network" | ||
8 | LICENSE = "GPLv2" | ||
9 | DEPENDS = "alsa-lib libftdi libusb1 libusb-compat jack portaudio-v19" | ||
10 | |||
11 | SRC_URI = "http://prdownloads.sourceforge.net/lirc/lirc-${PV}.tar.bz2" | ||
12 | |||
13 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | ||
diff --git a/meta-oe/recipes-connectivity/lirc/lirc/0001-lircrcd-Mark-local-inline-funtions-as-static.patch b/meta-oe/recipes-connectivity/lirc/lirc/0001-lircrcd-Mark-local-inline-funtions-as-static.patch deleted file mode 100644 index e19d27671..000000000 --- a/meta-oe/recipes-connectivity/lirc/lirc/0001-lircrcd-Mark-local-inline-funtions-as-static.patch +++ /dev/null | |||
@@ -1,49 +0,0 @@ | |||
1 | From c2be4543e4777c9e3d74b30326ba37b01917b0a9 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 25 Aug 2016 03:02:37 +0000 | ||
4 | Subject: [PATCH] lircrcd: Mark local inline funtions as static | ||
5 | |||
6 | These functions are not used anywhere outside | ||
7 | this file, so they should be converted into static | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | Upstream-Status: Pending | ||
12 | |||
13 | daemons/lircrcd.c | 6 +++--- | ||
14 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
15 | |||
16 | diff --git a/daemons/lircrcd.c b/daemons/lircrcd.c | ||
17 | index 55777cd..5ddc94d 100644 | ||
18 | --- a/daemons/lircrcd.c | ||
19 | +++ b/daemons/lircrcd.c | ||
20 | @@ -153,7 +153,7 @@ char *s; | ||
21 | /* A safer write(), since sockets might not write all but only some of the | ||
22 | bytes requested */ | ||
23 | |||
24 | -inline int write_socket(int fd, char *buf, int len) | ||
25 | +static inline int write_socket(int fd, char *buf, int len) | ||
26 | { | ||
27 | int done, todo = len; | ||
28 | |||
29 | @@ -167,7 +167,7 @@ inline int write_socket(int fd, char *buf, int len) | ||
30 | return (len); | ||
31 | } | ||
32 | |||
33 | -inline int write_socket_len(int fd, char *buf) | ||
34 | +static inline int write_socket_len(int fd, char *buf) | ||
35 | { | ||
36 | int len; | ||
37 | |||
38 | @@ -177,7 +177,7 @@ inline int write_socket_len(int fd, char *buf) | ||
39 | return (1); | ||
40 | } | ||
41 | |||
42 | -inline int read_timeout(int fd, char *buf, int len, int timeout) | ||
43 | +static inline int read_timeout(int fd, char *buf, int len, int timeout) | ||
44 | { | ||
45 | fd_set fds; | ||
46 | struct timeval tv; | ||
47 | -- | ||
48 | 1.9.1 | ||
49 | |||
diff --git a/meta-oe/recipes-connectivity/lirc/lirc/pollfd.patch b/meta-oe/recipes-connectivity/lirc/lirc/pollfd.patch new file mode 100644 index 000000000..4feea8034 --- /dev/null +++ b/meta-oe/recipes-connectivity/lirc/lirc/pollfd.patch | |||
@@ -0,0 +1,101 @@ | |||
1 | Index: lirc-0.9.4d/daemons/lircrcd.cpp | ||
2 | =================================================================== | ||
3 | --- lirc-0.9.4d.orig/daemons/lircrcd.cpp | ||
4 | +++ lirc-0.9.4d/daemons/lircrcd.cpp | ||
5 | @@ -29,10 +29,12 @@ | ||
6 | #include <sys/un.h> | ||
7 | #include <sys/stat.h> | ||
8 | #include <sys/types.h> | ||
9 | +#include <poll.h> | ||
10 | #include <syslog.h> | ||
11 | |||
12 | #include "lirc_client.h" | ||
13 | #include "lirc/lirc_log.h" | ||
14 | +#include "lirc/curl_poll.h" | ||
15 | |||
16 | #define MAX_CLIENTS 100 | ||
17 | #define WHITE_SPACE " \t" | ||
18 | Index: lirc-0.9.4d/lib/curl_poll.c | ||
19 | =================================================================== | ||
20 | --- lirc-0.9.4d.orig/lib/curl_poll.c | ||
21 | +++ lirc-0.9.4d/lib/curl_poll.c | ||
22 | @@ -36,6 +36,7 @@ | ||
23 | #include <stdlib.h> | ||
24 | #include <sys/time.h> | ||
25 | #include <sys/types.h> | ||
26 | +#include <sys/poll.h> | ||
27 | |||
28 | #include "lirc_log.h" | ||
29 | #include "curl_poll.h" | ||
30 | @@ -67,7 +68,7 @@ static const logchannel_t logchannel = L | ||
31 | |||
32 | #ifdef HAVE_POLL_FINE | ||
33 | |||
34 | -int curl_poll(struct pollfd ufds[], unsigned int nfds, int timeout_ms) | ||
35 | +int curl_poll(struct pollfd *ufds, unsigned int nfds, int timeout_ms) | ||
36 | { | ||
37 | return poll(ufds, nfds, timeout_ms); | ||
38 | } | ||
39 | @@ -112,7 +113,7 @@ static int verify_sock(int s) | ||
40 | } | ||
41 | |||
42 | |||
43 | -int curl_poll(struct pollfd ufds[], unsigned int nfds, int timeout_ms) | ||
44 | +int curl_poll(struct pollfd *ufds, unsigned int nfds, int timeout_ms) | ||
45 | { | ||
46 | struct timeval pending_tv; | ||
47 | struct timeval* ptimeout; | ||
48 | Index: lirc-0.9.4d/lib/curl_poll.h | ||
49 | =================================================================== | ||
50 | --- lirc-0.9.4d.orig/lib/curl_poll.h | ||
51 | +++ lirc-0.9.4d/lib/curl_poll.h | ||
52 | @@ -1,5 +1,5 @@ | ||
53 | -#ifndef _POLL_H | ||
54 | -#define _POLL_H | ||
55 | +#ifndef _LIB_CURL_POLL_H | ||
56 | +#define _LIB_CURL_POLL_H | ||
57 | /*************************************************************************** | ||
58 | * _ _ ____ _ | ||
59 | * Project ___| | | | _ \| | | ||
60 | @@ -29,13 +29,9 @@ | ||
61 | extern "C" { | ||
62 | #endif | ||
63 | |||
64 | -#ifdef HAVE_SYS_POLL_H | ||
65 | -#include <sys/poll.h> | ||
66 | -#else | ||
67 | #include <poll.h> | ||
68 | -#endif | ||
69 | |||
70 | -int curl_poll(struct pollfd ufds[], unsigned int nfds, int timeout_ms); | ||
71 | +int curl_poll(struct pollfd *ufds, unsigned int nfds, int timeout_ms); | ||
72 | |||
73 | #ifdef __cplusplus | ||
74 | } | ||
75 | Index: lirc-0.9.4d/lib/lirc/curl_poll.h | ||
76 | =================================================================== | ||
77 | --- lirc-0.9.4d.orig/lib/lirc/curl_poll.h | ||
78 | +++ lirc-0.9.4d/lib/lirc/curl_poll.h | ||
79 | @@ -1,5 +1,5 @@ | ||
80 | -#ifndef _POLL_H | ||
81 | -#define _POLL_H | ||
82 | +#ifndef _LIRC_CURL_POLL_H | ||
83 | +#define _LIRC_CURL_POLL_H | ||
84 | /*************************************************************************** | ||
85 | * _ _ ____ _ | ||
86 | * Project ___| | | | _ \| | | ||
87 | @@ -29,13 +29,9 @@ | ||
88 | extern "C" { | ||
89 | #endif | ||
90 | |||
91 | -#ifdef HAVE_SYS_POLL_H | ||
92 | -#include <sys/poll.h> | ||
93 | -#else | ||
94 | #include <poll.h> | ||
95 | -#endif | ||
96 | |||
97 | -int curl_poll(struct pollfd ufds[], unsigned int nfds, int timeout_ms); | ||
98 | +int curl_poll(struct pollfd *ufds, unsigned int nfds, int timeout_ms); | ||
99 | |||
100 | #ifdef __cplusplus | ||
101 | } | ||
diff --git a/meta-oe/recipes-connectivity/lirc/lirc_0.9.2.bb b/meta-oe/recipes-connectivity/lirc/lirc_0.9.4d.bb index 17261921f..b13163deb 100644 --- a/meta-oe/recipes-connectivity/lirc/lirc_0.9.2.bb +++ b/meta-oe/recipes-connectivity/lirc/lirc_0.9.4d.bb | |||
@@ -1,7 +1,18 @@ | |||
1 | require lirc.inc | 1 | DESCRIPTION = "LIRC is a package that allows you to decode and send infra-red signals of many commonly used remote controls." |
2 | DESCRIPTION_append_lirc = " This package contains the lirc daemon, libraries and tools." | ||
3 | DESCRIPTION_append_lirc-exec = " This package contains a daemon that runs programs on IR signals." | ||
4 | DESCRIPTION_append_lirc-remotes = " This package contains some config files for remotes." | ||
5 | DESCRIPTION_append_lirc-nslu2example = " This package contains a working config for RC5 remotes and a modified NSLU2." | ||
6 | HOMEPAGE = "http://www.lirc.org" | ||
7 | SECTION = "console/network" | ||
8 | LICENSE = "GPLv2" | ||
9 | DEPENDS = "libxslt-native alsa-lib libftdi libusb1 libusb-compat jack portaudio-v19" | ||
2 | 10 | ||
3 | SRC_URI += " \ | 11 | |
4 | file://0001-lircrcd-Mark-local-inline-funtions-as-static.patch \ | 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
13 | |||
14 | SRC_URI = "http://prdownloads.sourceforge.net/lirc/lirc-${PV}.tar.bz2 \ | ||
15 | file://pollfd.patch \ | ||
5 | file://lircd.service \ | 16 | file://lircd.service \ |
6 | file://lircd.init \ | 17 | file://lircd.init \ |
7 | file://lircexec.init \ | 18 | file://lircexec.init \ |
@@ -9,14 +20,14 @@ SRC_URI += " \ | |||
9 | file://lirc_options.conf \ | 20 | file://lirc_options.conf \ |
10 | file://lirc.tmpfiles \ | 21 | file://lirc.tmpfiles \ |
11 | " | 22 | " |
12 | #file://0001-Adaptation-for-STM-configuration.patch \ | 23 | SRC_URI[md5sum] = "0d11679cbdd94a5a6da00a8e7231b4bf" |
13 | # | 24 | SRC_URI[sha256sum] = "c68f18c35b489b865c0a741d119b136e8702191538cd3551b977a7af6c4e41ab" |
14 | SRC_URI[md5sum] = "3afc84e79c0839823cc20e7a710dd06d" | ||
15 | SRC_URI[sha256sum] = "4e3f948fcdee6dce009171143f0cb7cd7be48593dd58138db4101a41f651a1dd" | ||
16 | 25 | ||
17 | SYSTEMD_PACKAGES = "lirc" | 26 | SYSTEMD_PACKAGES = "lirc lirc-exec" |
18 | SYSTEMD_SERVICE_${PN} = "lircd.service lircmd.service" | 27 | SYSTEMD_SERVICE_${PN} = "lircd.service lircmd.service lircd-setup.service lircd-uinput.service" |
28 | SYSTEMD_SERVICE_${PN}-exec = "irexec.service" | ||
19 | SYSTEMD_AUTO_ENABLE_lirc = "enable" | 29 | SYSTEMD_AUTO_ENABLE_lirc = "enable" |
30 | SYSTEMD_AUTO_ENABLE_lirc-exec = "enable" | ||
20 | 31 | ||
21 | inherit autotools pkgconfig systemd python3native | 32 | inherit autotools pkgconfig systemd python3native |
22 | 33 | ||
@@ -27,6 +38,7 @@ PACKAGECONFIG ?= " \ | |||
27 | ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)} \ | 38 | ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)} \ |
28 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' x11', '', d)} \ | 39 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' x11', '', d)} \ |
29 | " | 40 | " |
41 | CACHED_CONFIGUREVARS = "HAVE_WORKING_POLL=yes" | ||
30 | 42 | ||
31 | #EXTRA_OEMAKE = 'SUBDIRS="lib daemons tools"' | 43 | #EXTRA_OEMAKE = 'SUBDIRS="lib daemons tools"' |
32 | do_install_append() { | 44 | do_install_append() { |
@@ -41,6 +53,7 @@ do_install_append() { | |||
41 | install -m 0644 ${WORKDIR}/lirc.tmpfiles ${D}${libdir}/tmpfiles.d/lirc.conf | 53 | install -m 0644 ${WORKDIR}/lirc.tmpfiles ${D}${libdir}/tmpfiles.d/lirc.conf |
42 | rm -rf ${D}${libdir}/lirc/plugins/*.la | 54 | rm -rf ${D}${libdir}/lirc/plugins/*.la |
43 | rmdir ${D}/var/run/lirc ${D}/var/run | 55 | rmdir ${D}/var/run/lirc ${D}/var/run |
56 | chown -R root:root ${D}${datadir}/lirc/contrib | ||
44 | } | 57 | } |
45 | 58 | ||
46 | PACKAGES =+ "${PN}-contrib ${PN}-exec ${PN}-plugins ${PN}-python" | 59 | PACKAGES =+ "${PN}-contrib ${PN}-exec ${PN}-plugins ${PN}-python" |
@@ -53,7 +66,7 @@ RRECOMMENDS_lirc = "${PN}-exec ${PN}-plugins" | |||
53 | 66 | ||
54 | FILES_${PN}-plugins = "${libdir}/lirc/plugins/*.so ${datadir}/lirc/configs" | 67 | FILES_${PN}-plugins = "${libdir}/lirc/plugins/*.so ${datadir}/lirc/configs" |
55 | FILES_${PN}-contrib = "${datadir}/lirc/contrib" | 68 | FILES_${PN}-contrib = "${datadir}/lirc/contrib" |
56 | FILES_${PN}-exec = "${bindir}/irexec ${sysconfdir}/lircexec" | 69 | FILES_${PN}-exec = "${bindir}/irexec ${sysconfdir}/lircexec ${systemd_unitdir}/system/irexec.service" |
57 | FILES_${PN} += "${systemd_unitdir}/system/lircexec.init" | 70 | FILES_${PN} += "${systemd_unitdir}/system/lircexec.init" |
58 | FILES_${PN} += "${systemd_unitdir}/system/lircd.service" | 71 | FILES_${PN} += "${systemd_unitdir}/system/lircd.service" |
59 | FILES_${PN} += "${systemd_unitdir}/system/lircd.socket" | 72 | FILES_${PN} += "${systemd_unitdir}/system/lircd.socket" |
@@ -70,3 +83,5 @@ INITSCRIPT_PARAMS_lirc-exec = "defaults 21" | |||
70 | pkg_postinst_${PN}_append() { | 83 | pkg_postinst_${PN}_append() { |
71 | if [ ! -c $D/dev/lirc -a ! -f /sbin/udevd ]; then mknod $D/dev/lirc c 61 0; fi | 84 | if [ ! -c $D/dev/lirc -a ! -f /sbin/udevd ]; then mknod $D/dev/lirc c 61 0; fi |
72 | } | 85 | } |
86 | |||
87 | SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}" | ||