diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-06-27 19:08:10 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-07-01 09:59:26 +0200 |
commit | 2bd65aacdfa2634f20dfbc7cacf6e418f8cc2ae7 (patch) | |
tree | 9c1b8800a54516067adbef87f0e43d105a883011 /meta-oe/recipes-connectivity | |
parent | 9d7a49a58b7dd1004c6095a9bcff04d7e4e4b56f (diff) | |
download | meta-openembedded-2bd65aacdfa2634f20dfbc7cacf6e418f8cc2ae7.tar.gz |
umip: Fix buid with hardening
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r-- | meta-oe/recipes-connectivity/umip/files/0001-Add-format-string-to-fprintf-call.patch | 26 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/umip/umip_1.0.bb | 9 |
2 files changed, 31 insertions, 4 deletions
diff --git a/meta-oe/recipes-connectivity/umip/files/0001-Add-format-string-to-fprintf-call.patch b/meta-oe/recipes-connectivity/umip/files/0001-Add-format-string-to-fprintf-call.patch new file mode 100644 index 000000000..8e5f4da36 --- /dev/null +++ b/meta-oe/recipes-connectivity/umip/files/0001-Add-format-string-to-fprintf-call.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | From a0ad5128d14b022239445e251cf4a9826e86aa96 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 27 Jun 2017 07:48:31 -0700 | ||
4 | Subject: [PATCH] Add format string to fprintf() call | ||
5 | |||
6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
7 | --- | ||
8 | src/vt.c | 2 +- | ||
9 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
10 | |||
11 | diff --git a/src/vt.c b/src/vt.c | ||
12 | index 795d393..a533d3d 100644 | ||
13 | --- a/src/vt.c | ||
14 | +++ b/src/vt.c | ||
15 | @@ -499,7 +499,7 @@ static int vt_cmd_dump_candidates(const struct vt_handle *vh, | ||
16 | } | ||
17 | llen += cmdlen; | ||
18 | |||
19 | - ret = fprintf(vh->vh_stream, e->cmd); | ||
20 | + ret = fprintf(vh->vh_stream, "%s", e->cmd); | ||
21 | if (ret < 0) | ||
22 | return ret; | ||
23 | |||
24 | -- | ||
25 | 2.13.2 | ||
26 | |||
diff --git a/meta-oe/recipes-connectivity/umip/umip_1.0.bb b/meta-oe/recipes-connectivity/umip/umip_1.0.bb index a25056645..cbf306144 100644 --- a/meta-oe/recipes-connectivity/umip/umip_1.0.bb +++ b/meta-oe/recipes-connectivity/umip/umip_1.0.bb | |||
@@ -10,10 +10,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=073dc31ccb2ebed70db54f1e8aeb4c33" | |||
10 | DEPENDS = "rpm indent-native" | 10 | DEPENDS = "rpm indent-native" |
11 | 11 | ||
12 | SRC_URI = "git://git.umip.org/umip.git \ | 12 | SRC_URI = "git://git.umip.org/umip.git \ |
13 | file://add-dependency-to-support-parallel-compilation.patch \ | 13 | file://add-dependency-to-support-parallel-compilation.patch \ |
14 | file://mip6d \ | 14 | file://mip6d \ |
15 | file://mip6d.service \ | 15 | file://mip6d.service \ |
16 | " | 16 | file://0001-Add-format-string-to-fprintf-call.patch \ |
17 | " | ||
17 | SRCREV = "428974c2d0d8e75a2750a3ab0488708c5dfdd8e3" | 18 | SRCREV = "428974c2d0d8e75a2750a3ab0488708c5dfdd8e3" |
18 | 19 | ||
19 | S = "${WORKDIR}/git" | 20 | S = "${WORKDIR}/git" |