diff options
author | Wang Mingyu <wangmy@cn.fujitsu.com> | 2020-02-27 04:43:18 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-02-27 08:25:49 -0800 |
commit | d4874942d8d1a40fd84bbdb9528a58fd6289ca95 (patch) | |
tree | 254d4fd4607086231c6d28f1464ad8e572bead2a /meta-oe/recipes-connectivity | |
parent | 9825d4cf3e66519200bc7aa613c2c59cda9c0ab4 (diff) | |
download | meta-openembedded-d4874942d8d1a40fd84bbdb9528a58fd6289ca95.tar.gz |
libmbim: upgrade 1.20.4 -> 1.22.0
clang.patch
Revemod since the file of this patch is non-existent.
Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r-- | meta-oe/recipes-connectivity/libmbim/libmbim/clang.patch | 73 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/libmbim/libmbim_1.22.0.bb (renamed from meta-oe/recipes-connectivity/libmbim/libmbim_1.20.4.bb) | 9 |
2 files changed, 4 insertions, 78 deletions
diff --git a/meta-oe/recipes-connectivity/libmbim/libmbim/clang.patch b/meta-oe/recipes-connectivity/libmbim/libmbim/clang.patch deleted file mode 100644 index d88578418..000000000 --- a/meta-oe/recipes-connectivity/libmbim/libmbim/clang.patch +++ /dev/null | |||
@@ -1,73 +0,0 @@ | |||
1 | Check for clang compiler since we need to disable | ||
2 | unused-function warning for clang, at same time | ||
3 | pass werror when checking for compiler options if | ||
4 | werror is enabled so spurious options do not get | ||
5 | enabled. Only the ones that are supported by given | ||
6 | compiler are accepted. | ||
7 | |||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
9 | Upstream-Status: Pending | ||
10 | |||
11 | Index: libmbim-1.14.0/m4/compiler-warnings.m4 | ||
12 | =================================================================== | ||
13 | --- libmbim-1.14.0.orig/m4/compiler-warnings.m4 | ||
14 | +++ libmbim-1.14.0/m4/compiler-warnings.m4 | ||
15 | @@ -2,10 +2,30 @@ AC_DEFUN([LIBMBIM_COMPILER_WARNINGS], | ||
16 | [AC_ARG_ENABLE(more-warnings, | ||
17 | AS_HELP_STRING([--enable-more-warnings], [Possible values: no/yes/error]), | ||
18 | set_more_warnings="$enableval",set_more_warnings=error) | ||
19 | + | ||
20 | +# Clang throws a lot of warnings when it does not understand a flag. Disable | ||
21 | +# this warning for now so other warnings are visible. | ||
22 | +AC_MSG_CHECKING([if compiling with clang]) | ||
23 | +AC_COMPILE_IFELSE([AC_LANG_PROGRAM([], [[ | ||
24 | +#ifndef __clang__ | ||
25 | + not clang | ||
26 | +#endif | ||
27 | + ]])], | ||
28 | + [CLANG=yes], | ||
29 | + [CLANG=no] | ||
30 | +) | ||
31 | +AC_MSG_RESULT([$CLANG]) | ||
32 | +AS_IF([test "x$CLANG" = "xyes"], [CLANG_FLAGS=-Wno-error=unused-function]) | ||
33 | +CFLAGS="$CFLAGS $CLANG_FLAGS" | ||
34 | +LDFLAGS="$LDFLAGS $CLANG_FLAGS" | ||
35 | + | ||
36 | AC_MSG_CHECKING(for more warnings) | ||
37 | if test "$GCC" = "yes" -a "$set_more_warnings" != "no"; then | ||
38 | AC_MSG_RESULT(yes) | ||
39 | CFLAGS="-Wall -std=gnu89 $CFLAGS" | ||
40 | + if test "x$set_more_warnings" = xerror; then | ||
41 | + WERROR="-Werror" | ||
42 | + fi | ||
43 | |||
44 | for option in -Wmissing-declarations -Wmissing-prototypes \ | ||
45 | -Wdeclaration-after-statement -Wstrict-prototypes \ | ||
46 | @@ -17,22 +37,23 @@ if test "$GCC" = "yes" -a "$set_more_war | ||
47 | -Wmissing-include-dirs -Waggregate-return \ | ||
48 | -Wformat-security -Wtype-limits; do | ||
49 | SAVE_CFLAGS="$CFLAGS" | ||
50 | - CFLAGS="$CFLAGS $option" | ||
51 | + CFLAGS="$CFLAGS $option $WERROR" | ||
52 | AC_MSG_CHECKING([whether gcc understands $option]) | ||
53 | AC_TRY_COMPILE([], [], | ||
54 | has_option=yes, | ||
55 | has_option=no,) | ||
56 | if test $has_option = no; then | ||
57 | CFLAGS="$SAVE_CFLAGS" | ||
58 | + else | ||
59 | + CFLAGS="$SAVE_CFLAGS $option" | ||
60 | fi | ||
61 | AC_MSG_RESULT($has_option) | ||
62 | unset has_option | ||
63 | unset SAVE_CFLAGS | ||
64 | done | ||
65 | + CFLAGS="$CFLAGS $WERROR" | ||
66 | unset option | ||
67 | - if test "x$set_more_warnings" = xerror; then | ||
68 | - CFLAGS="$CFLAGS -Werror" | ||
69 | - fi | ||
70 | + unset WERROR | ||
71 | else | ||
72 | AC_MSG_RESULT(no) | ||
73 | fi | ||
diff --git a/meta-oe/recipes-connectivity/libmbim/libmbim_1.20.4.bb b/meta-oe/recipes-connectivity/libmbim/libmbim_1.22.0.bb index a3ef80c1b..61e314f1f 100644 --- a/meta-oe/recipes-connectivity/libmbim/libmbim_1.20.4.bb +++ b/meta-oe/recipes-connectivity/libmbim/libmbim_1.22.0.bb | |||
@@ -11,8 +11,7 @@ DEPENDS = "glib-2.0 glib-2.0-native libgudev" | |||
11 | 11 | ||
12 | inherit autotools pkgconfig bash-completion | 12 | inherit autotools pkgconfig bash-completion |
13 | 13 | ||
14 | SRC_URI = "http://www.freedesktop.org/software/${BPN}/${BPN}-${PV}.tar.xz \ | 14 | SRC_URI = "http://www.freedesktop.org/software/${BPN}/${BPN}-${PV}.tar.xz" |
15 | file://clang.patch \ | 15 | |
16 | " | 16 | SRC_URI[md5sum] = "87060e8957013177e4140edc6f64f5bd" |
17 | SRC_URI[md5sum] = "d38d637e33cde8a91484f53a9f6c4d49" | 17 | SRC_URI[sha256sum] = "5c0778eb1cd12c3604523134e55183f5147b0cae71150e875b583768f7aa1f38" |
18 | SRC_URI[sha256sum] = "ac2708a409b09f1f6f1786a8a9e39c36619aa8d6f285ea943daa7a48ea36d3e8" | ||