summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2014-07-01 17:48:33 -0300
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-15 15:02:28 +0200
commitf52c0d42f4b87cb3cf925bed09bf116c0e4fbaaf (patch)
tree26a73212756e464e09bbe19970787199a6885fee /meta-oe/recipes-connectivity
parent31f6f1aa6c6a9a762213435121408a2303b9ce63 (diff)
downloadmeta-openembedded-f52c0d42f4b87cb3cf925bed09bf116c0e4fbaaf.tar.gz
linuxptp: Use environment compiler settings
If the machine uses hard floating point, the build fails as below: arm-oel-linux-gnueabi-gcc -Wall ... In file included from .../build/tmp/sysroots/imx6qsabresd/usr/include/features.h:402:0, from .../build/tmp/sysroots/imx6qsabresd/usr/include/errno.h:28, from clock.c:19: .../build/tmp/sysroots/imx6qsabresd/usr/include/gnu/stubs.h:7:29: fatal error: gnu/stubs-soft.h: No such file or directory # include <gnu/stubs-soft.h> This patch fixes the build system to reuse the CC variable and also passes over the defined CFLAGS so the choosen optimization and build options are respected. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r--meta-oe/recipes-connectivity/linuxptp/linuxptp/build-Allow-CC-and-prefix-to-be-overriden.patch37
-rw-r--r--meta-oe/recipes-connectivity/linuxptp/linuxptp_1.4.bb7
2 files changed, 41 insertions, 3 deletions
diff --git a/meta-oe/recipes-connectivity/linuxptp/linuxptp/build-Allow-CC-and-prefix-to-be-overriden.patch b/meta-oe/recipes-connectivity/linuxptp/linuxptp/build-Allow-CC-and-prefix-to-be-overriden.patch
new file mode 100644
index 000000000..b1d96ae5a
--- /dev/null
+++ b/meta-oe/recipes-connectivity/linuxptp/linuxptp/build-Allow-CC-and-prefix-to-be-overriden.patch
@@ -0,0 +1,37 @@
1From af485c638c61fa883212ea424e676fbf90bee594 Mon Sep 17 00:00:00 2001
2From: Otavio Salvador <otavio@ossystems.com.br>
3Date: Tue, 1 Jul 2014 17:37:31 -0300
4Subject: [PATCH] build: Allow CC and prefix to be overriden
5
6Upstream-Status: Pending
7
8Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
9---
10 makefile | 4 ++--
11 1 file changed, 2 insertions(+), 2 deletions(-)
12
13diff --git a/makefile b/makefile
14index 22e7d0d..809cc8f 100644
15--- a/makefile
16+++ b/makefile
17@@ -18,7 +18,7 @@
18 KBUILD_OUTPUT =
19
20 DEBUG =
21-CC = $(CROSS_COMPILE)gcc
22+CC ?= $(CROSS_COMPILE)gcc
23 VER = -DVER=$(version)
24 CFLAGS = -Wall $(VER) $(incdefs) $(DEBUG) $(EXTRA_CFLAGS)
25 LDLIBS = -lm -lrt $(EXTRA_LDFLAGS)
26@@ -35,7 +35,7 @@ incdefs := $(shell $(srcdir)/incdefs.sh)
27 version := $(shell $(srcdir)/version.sh $(srcdir))
28 VPATH = $(srcdir)
29
30-prefix = /usr/local
31+prefix ?= /usr/local
32 sbindir = $(prefix)/sbin
33 mandir = $(prefix)/man
34 man8dir = $(mandir)/man8
35--
361.7.10.4
37
diff --git a/meta-oe/recipes-connectivity/linuxptp/linuxptp_1.4.bb b/meta-oe/recipes-connectivity/linuxptp/linuxptp_1.4.bb
index 10d674405..4ee0c8873 100644
--- a/meta-oe/recipes-connectivity/linuxptp/linuxptp_1.4.bb
+++ b/meta-oe/recipes-connectivity/linuxptp/linuxptp_1.4.bb
@@ -2,13 +2,14 @@ DESCRIPTION = "Precision Time Protocol (PTP) according to IEEE standard 1588 for
2LICENSE = "GPLv2" 2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" 3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4 4
5SRC_URI = "http://sourceforge.net/projects/linuxptp/files/v${PV}/linuxptp-${PV}.tgz" 5SRC_URI = "http://sourceforge.net/projects/linuxptp/files/v${PV}/linuxptp-${PV}.tgz \
6 file://build-Allow-CC-and-prefix-to-be-overriden.patch"
6 7
7SRC_URI[md5sum] = "a37ad2b2ef7d1ebc4d64a66d3fe55cdf" 8SRC_URI[md5sum] = "a37ad2b2ef7d1ebc4d64a66d3fe55cdf"
8SRC_URI[sha256sum] = "6cfd5291fb7394cc9f25458927874a203971b66b76d1c9d6568e007d0cbd81f2" 9SRC_URI[sha256sum] = "6cfd5291fb7394cc9f25458927874a203971b66b76d1c9d6568e007d0cbd81f2"
9 10
10EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} ARCH=${TARGET_ARCH} \ 11EXTRA_OEMAKE = "ARCH=${TARGET_ARCH} \
11 EXTRA_CFLAGS='-D_GNU_SOURCE -DHAVE_CLOCK_ADJTIME -DHAVE_ONESTEP_SYNC'" 12 EXTRA_CFLAGS='-D_GNU_SOURCE -DHAVE_CLOCK_ADJTIME -DHAVE_ONESTEP_SYNC ${CFLAGS}'"
12 13
13do_install () { 14do_install () {
14 install -d ${D}/${bindir} 15 install -d ${D}/${bindir}