summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity
diff options
context:
space:
mode:
authorChong.Lu@windriver.com <Chong.Lu@windriver.com>2014-06-13 14:12:57 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-06-21 19:22:25 +0200
commit69e765c4645f018506325312a42a53f984dbb6e8 (patch)
tree0e7f3371f5f27dd73c5c99f5b79d5c7f5ac69f37 /meta-oe/recipes-connectivity
parentfe32c95ab0e60d6c9a5289a7550d1d832ff75aae (diff)
downloadmeta-openembedded-69e765c4645f018506325312a42a53f984dbb6e8.tar.gz
samba: Security Advisory - CVE-2013-4124
Integer overflow in the read_nttrans_ea_list function in nttrans.c in smbd in Samba 3.x before 3.5.22, 3.6.x before 3.6.17, and 4.x before 4.0.8 allows remote attackers to cause a denial of service (memory consumption) via a malformed packet. http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2013-4124 Signed-off-by: Yue Tao <Yue.Tao@windriver.com> Signed-off-by: Chong Lu <Chong.Lu@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r--meta-oe/recipes-connectivity/samba/samba/samba-3.6.16-CVE-2013-4124.patch43
-rw-r--r--meta-oe/recipes-connectivity/samba/samba_3.6.8.bb1
2 files changed, 44 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/samba/samba/samba-3.6.16-CVE-2013-4124.patch b/meta-oe/recipes-connectivity/samba/samba/samba-3.6.16-CVE-2013-4124.patch
new file mode 100644
index 000000000..54b8edfbe
--- /dev/null
+++ b/meta-oe/recipes-connectivity/samba/samba/samba-3.6.16-CVE-2013-4124.patch
@@ -0,0 +1,43 @@
1Upstream-Status: Backport
2
3From efdbcabbe97a594572d71d714d258a5854c5d8ce Mon Sep 17 00:00:00 2001
4From: Jeremy Allison <jra@samba.org>
5Date: Wed, 10 Jul 2013 17:10:17 -0700
6Subject: [PATCH] Fix bug #10010 - Missing integer wrap protection in EA list
7 reading can cause server to loop with DOS.
8
9Ensure we never wrap whilst adding client provided input.
10CVE-2013-4124
11
12Signed-off-by: Jeremy Allison <jra@samba.org>
13---
14 source3/smbd/nttrans.c | 12 ++++++++++++
15 1 file changed, 12 insertions(+)
16
17diff --git a/source3/smbd/nttrans.c b/source3/smbd/nttrans.c
18index ea9d417..5fc3a09 100644
19--- a/source3/smbd/nttrans.c
20+++ b/source3/smbd/nttrans.c
21@@ -989,7 +989,19 @@ struct ea_list *read_nttrans_ea_list(TALLOC_CTX *ctx, const char *pdata, size_t
22 if (next_offset == 0) {
23 break;
24 }
25+
26+ /* Integer wrap protection for the increment. */
27+ if (offset + next_offset < offset) {
28+ break;
29+ }
30+
31 offset += next_offset;
32+
33+ /* Integer wrap protection for while loop. */
34+ if (offset + 4 < offset) {
35+ break;
36+ }
37+
38 }
39
40 return ea_list_head;
41--
421.7.10.4
43
diff --git a/meta-oe/recipes-connectivity/samba/samba_3.6.8.bb b/meta-oe/recipes-connectivity/samba/samba_3.6.8.bb
index a5e7dcd18..331796cb3 100644
--- a/meta-oe/recipes-connectivity/samba/samba_3.6.8.bb
+++ b/meta-oe/recipes-connectivity/samba/samba_3.6.8.bb
@@ -33,6 +33,7 @@ SRC_URI += "\
33 file://samba-3.6.22-CVE-2013-4496.patch;patchdir=.. \ 33 file://samba-3.6.22-CVE-2013-4496.patch;patchdir=.. \
34 file://0001-PIDL-fix-parsing-linemarkers-in-preprocessor-output.patch;patchdir=.. \ 34 file://0001-PIDL-fix-parsing-linemarkers-in-preprocessor-output.patch;patchdir=.. \
35 file://samba-3.6.11-CVE-2013-0213-CVE-2013-0214.patch;patchdir=.. \ 35 file://samba-3.6.11-CVE-2013-0213-CVE-2013-0214.patch;patchdir=.. \
36 file://samba-3.6.16-CVE-2013-4124.patch;patchdir=.. \
36" 37"
37SRC_URI[md5sum] = "fbb245863eeef2fffe172df779a217be" 38SRC_URI[md5sum] = "fbb245863eeef2fffe172df779a217be"
38SRC_URI[sha256sum] = "4f5a171a8d902c6b4f822ed875c51eb8339196d9ccf0ecd7f6521c966b3514de" 39SRC_URI[sha256sum] = "4f5a171a8d902c6b4f822ed875c51eb8339196d9ccf0ecd7f6521c966b3514de"