summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity
diff options
context:
space:
mode:
authorlumag <dbaryshkov@gmail.com>2011-09-05 01:37:03 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-09-06 12:24:38 +0200
commitcffa06f750b720f3e2391b104c4be533fc61feec (patch)
tree938e37fe3d6d2a857302b0396a0207f128236a8a /meta-oe/recipes-connectivity
parentc17fe9bc7ed4096853ba160a67300b3c5e1dd02b (diff)
downloadmeta-openembedded-cffa06f750b720f3e2391b104c4be533fc61feec.tar.gz
openssl: fully fix parallel builds
Add a patch from oe-core to fix parallel builds in openssl 0.9.8m. Then drop PARALLEL_MAKE settings in both of recipes. Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r--meta-oe/recipes-connectivity/openssl/openssl-0.9.8m/parallel-make-fix.patch20
-rw-r--r--meta-oe/recipes-connectivity/openssl/openssl_0.9.8m.bb3
-rw-r--r--meta-oe/recipes-connectivity/openssl/openssl_1.0.0d.bb1
3 files changed, 21 insertions, 3 deletions
diff --git a/meta-oe/recipes-connectivity/openssl/openssl-0.9.8m/parallel-make-fix.patch b/meta-oe/recipes-connectivity/openssl/openssl-0.9.8m/parallel-make-fix.patch
new file mode 100644
index 000000000..82857f574
--- /dev/null
+++ b/meta-oe/recipes-connectivity/openssl/openssl-0.9.8m/parallel-make-fix.patch
@@ -0,0 +1,20 @@
1Upstream-Status: Submitted
2
3fix the parallel build regarding shared libraries.
4
5Signed-off-by: Qing He <qing.he@intel.com>
6
7diff --git a/Makefile.org b/Makefile.org
8index 2fb0309..8bec3d0 100644
9--- a/Makefile.org
10+++ b/Makefile.org
11@@ -352,6 +352,9 @@ all_testapps: build_libs build_testapps
12 build_testapps:
13 @dir=crypto; target=testapps; $(BUILD_ONE_CMD)
14
15+libcrypto.a: build_crypto
16+libssl.a: build_ssl
17+
18 build_shared: $(SHARED_LIBS)
19 libcrypto$(SHLIB_EXT): libcrypto.a $(SHARED_FIPS)
20 @if [ "$(SHLIB_TARGET)" != "" ]; then \
diff --git a/meta-oe/recipes-connectivity/openssl/openssl_0.9.8m.bb b/meta-oe/recipes-connectivity/openssl/openssl_0.9.8m.bb
index a7eb33285..1091bf2ed 100644
--- a/meta-oe/recipes-connectivity/openssl/openssl_0.9.8m.bb
+++ b/meta-oe/recipes-connectivity/openssl/openssl_0.9.8m.bb
@@ -11,6 +11,5 @@ export OE_LDFLAGS="${LDFLAGS}"
11SRC_URI += "file://configure-targets.patch \ 11SRC_URI += "file://configure-targets.patch \
12 file://shared-libs.patch \ 12 file://shared-libs.patch \
13 file://debian.patch \ 13 file://debian.patch \
14 file://parallel-make-fix.patch \
14 file://oe-ldflags.patch" 15 file://oe-ldflags.patch"
15
16PARALLEL_MAKE = ""
diff --git a/meta-oe/recipes-connectivity/openssl/openssl_1.0.0d.bb b/meta-oe/recipes-connectivity/openssl/openssl_1.0.0d.bb
index 89b861599..63b5460de 100644
--- a/meta-oe/recipes-connectivity/openssl/openssl_1.0.0d.bb
+++ b/meta-oe/recipes-connectivity/openssl/openssl_1.0.0d.bb
@@ -41,6 +41,5 @@ PACKAGES += " \
41 ${PN}-engines-dbg \ 41 ${PN}-engines-dbg \
42 " 42 "
43 43
44PARALLEL_MAKE = ""
45FILES_${PN}-engines = "${libdir}/ssl/engines/*.so" 44FILES_${PN}-engines = "${libdir}/ssl/engines/*.so"
46FILES_${PN}-engines-dbg = "${libdir}/ssl/engines/.debug" 45FILES_${PN}-engines-dbg = "${libdir}/ssl/engines/.debug"