summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity
diff options
context:
space:
mode:
authorMariano Lopez <mariano.lopez@linux.intel.com>2015-12-19 20:22:36 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2016-01-04 14:55:18 +0100
commit6bdf80f70b54a5904b48e2346505d82e8c635350 (patch)
treee9331b0dced5fcba68aeb57116acf8963634f4c2 /meta-oe/recipes-connectivity
parent4b358f9475954ca678a2611e9312fb65f534fb5b (diff)
downloadmeta-openembedded-6bdf80f70b54a5904b48e2346505d82e8c635350.tar.gz
hostapd: Fix source and build directory
The current recipe make no difference between the source and the build directory. There are source files outside this directory and isn't possible to patch these files. This changes adds the build directory path to the recipe, now is possible to patch files in other directories, if required. Signed-off-by: Mariano Lopez <mariano.lopez@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r--meta-oe/recipes-connectivity/hostapd/hostapd_2.5.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/meta-oe/recipes-connectivity/hostapd/hostapd_2.5.bb b/meta-oe/recipes-connectivity/hostapd/hostapd_2.5.bb
index d95dbec27..c38e20a72 100644
--- a/meta-oe/recipes-connectivity/hostapd/hostapd_2.5.bb
+++ b/meta-oe/recipes-connectivity/hostapd/hostapd_2.5.bb
@@ -1,7 +1,7 @@
1HOMEPAGE = "http://w1.fi/hostapd/" 1HOMEPAGE = "http://w1.fi/hostapd/"
2SECTION = "kernel/userland" 2SECTION = "kernel/userland"
3LICENSE = "GPLv2 | BSD" 3LICENSE = "GPLv2 | BSD"
4LIC_FILES_CHKSUM = "file://README;md5=4d53178f44d4b38418a4fa8de365e11c" 4LIC_FILES_CHKSUM = "file://${B}/README;md5=4d53178f44d4b38418a4fa8de365e11c"
5DEPENDS = "libnl openssl" 5DEPENDS = "libnl openssl"
6SUMMARY = "User space daemon for extended IEEE 802.11 management" 6SUMMARY = "User space daemon for extended IEEE 802.11 management"
7 7
@@ -18,11 +18,11 @@ SRC_URI = " \
18 file://hostapd.service \ 18 file://hostapd.service \
19" 19"
20 20
21S = "${WORKDIR}/hostapd-${PV}/hostapd" 21S = "${WORKDIR}/hostapd-${PV}"
22 22B = "${WORKDIR}/hostapd-${PV}/hostapd"
23 23
24do_configure() { 24do_configure() {
25 install -m 0644 ${WORKDIR}/defconfig ${S}/.config 25 install -m 0644 ${WORKDIR}/defconfig ${B}/.config
26} 26}
27 27
28do_compile() { 28do_compile() {
@@ -32,9 +32,9 @@ do_compile() {
32 32
33do_install() { 33do_install() {
34 install -d ${D}${sbindir} ${D}${sysconfdir}/init.d ${D}${systemd_unitdir}/system/ 34 install -d ${D}${sbindir} ${D}${sysconfdir}/init.d ${D}${systemd_unitdir}/system/
35 install -m 0644 ${S}/hostapd.conf ${D}${sysconfdir} 35 install -m 0644 ${B}/hostapd.conf ${D}${sysconfdir}
36 install -m 0755 ${S}/hostapd ${D}${sbindir} 36 install -m 0755 ${B}/hostapd ${D}${sbindir}
37 install -m 0755 ${S}/hostapd_cli ${D}${sbindir} 37 install -m 0755 ${B}/hostapd_cli ${D}${sbindir}
38 install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/hostapd 38 install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/hostapd
39 install -m 0644 ${WORKDIR}/hostapd.service ${D}${systemd_unitdir}/system/ 39 install -m 0644 ${WORKDIR}/hostapd.service ${D}${systemd_unitdir}/system/
40 sed -i -e 's,@SBINDIR@,${sbindir},g' -e 's,@SYSCONFDIR@,${sysconfdir},g' ${D}${systemd_unitdir}/system/hostapd.service 40 sed -i -e 's,@SBINDIR@,${sbindir},g' -e 's,@SYSCONFDIR@,${sysconfdir},g' ${D}${systemd_unitdir}/system/hostapd.service