diff options
author | Philip Balister <philip@opensdr.com> | 2012-04-11 23:11:30 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-04-12 09:01:11 +0200 |
commit | 12deef7ad4b2c84db0e2c1b6686994929824c244 (patch) | |
tree | 81d008039ba2255454d43dec333364b84d6f6f8f /meta-oe/recipes-connectivity | |
parent | 8ddf0dc41aade09aeaec02268cf70cc72bc7b43a (diff) | |
download | meta-openembedded-12deef7ad4b2c84db0e2c1b6686994929824c244.tar.gz |
gnuradio : Update to version 3.5.3.
Signed-off-by: Philip Balister <philip@opensdr.com>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r-- | meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb | 79 |
1 files changed, 71 insertions, 8 deletions
diff --git a/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb b/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb index d5e297d1b..ae8ebca8c 100644 --- a/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb +++ b/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb | |||
@@ -1,18 +1,81 @@ | |||
1 | require gnuradio.inc | 1 | DESCRIPTION = "GNU Radio" |
2 | URL = "http://gnuradio.org" | ||
3 | SECTION = "apps" | ||
4 | PRIORITY = "optional" | ||
5 | LICENSE = "GPLv3" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
2 | 7 | ||
3 | PR = "${INC_PR}.0" | 8 | PR = "r0" |
4 | PV = "3.4.0-${PR}+gitr${SRCREV}" | ||
5 | 9 | ||
6 | SRCREV = "62768eedf8f68680ef3a672a27025227e22ccbb0" | 10 | DEPENDS = "uhd gsl fftwf python alsa-lib boost cppunit \ |
11 | swig-native python-numpy python-pygtk orc qt4-x11-free qwt" | ||
12 | |||
13 | inherit distutils-base cmake pkgconfig | ||
14 | |||
15 | export BUILD_SYS | ||
16 | export HOST_SYS="${MULTIMACH_TARGET_SYS}" | ||
17 | |||
18 | RDEPENDS_${PN} = "python-core python-audio python-threading python-codecs \ | ||
19 | python-lang python-textutils python-shell python-pickle \ | ||
20 | python-compiler python-pkgutil python-pydoc python-mmap \ | ||
21 | python-netclient python-difflib \ | ||
22 | python-pprint python-numpy python-pygtk python-lxml \ | ||
23 | " | ||
24 | |||
25 | C_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
26 | |||
27 | #do_configure_append() { | ||
28 | # find ${S} -name Makefile | xargs sed -i s:'-I${STAGING_INCDIR_NATIVE'::g | ||
29 | # find ${S} -name Makefile | xargs sed -i s:'-L${STAGING_LIBDIR_NATIVE'::g | ||
30 | #} | ||
31 | |||
32 | do_configure_prepend() { | ||
33 | ${BUILD_CC} ${S}/gr-vocoder/lib/codec2/generate_codebook.c -o ${S}/gr-vocoder/lib/generate_codebook -lm | ||
34 | echo "ADD_EXECUTABLE(generate_codebook IMPORTED)" >${S}/gr-vocoder/lib/generate_codebook.txt | ||
35 | echo "SET_PROPERTY(TARGET generate_codebook APPEND PROPERTY IMPORTED_CONFIGURATIONS RELEASE)" >>${S}/gr-vocoder/lib/generate_codebook.txt | ||
36 | echo 'SET_TARGET_PROPERTIES(generate_codebook PROPERTIES IMPORTED_LOCATION_RELEASE "${S}/gr-vocoder/lib/generate_codebook")' >>${S}/gr-vocoder/lib/generate_codebook.txt | ||
37 | } | ||
38 | |||
39 | do_compile_prepend() { | ||
40 | cp ${S}/gr-vocoder/lib/codec2/defines.h ${OECMAKE_BUILDPATH}/gr-vocoder/lib/codec2 | ||
41 | } | ||
42 | |||
43 | PACKAGES =+ "\ | ||
44 | ${PN}-examples \ | ||
45 | ${PN}-grc \ | ||
46 | " | ||
47 | |||
48 | FILES_${PN}-grc = "${datadir}/gnuradio/grc" | ||
49 | |||
50 | FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/gnuradio/*" | ||
51 | FILES_${PN} += "${datadir}/gnuradio/*" | ||
52 | # The following needs fixing upstream | ||
53 | FILES_${PN} += "${prefix}/etc/gnuradio/*" | ||
54 | |||
55 | FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/gnuradio/.debug \ | ||
56 | ${PYTHON_SITEPACKAGES_DIR}/gnuradio/*/.debug \ | ||
57 | " | ||
58 | FILES_${PN}-examples = "${datadir}/gnuradio/examples" | ||
59 | |||
60 | PV = "3.5.3" | ||
61 | |||
62 | FILESPATHPKG_prepend = "gnuradio-git:" | ||
63 | |||
64 | SRCREV = "f621a52f779381cfe550b4278b83e701a747944c" | ||
7 | 65 | ||
8 | # Make it easy to test against developer repos and branches | 66 | # Make it easy to test against developer repos and branches |
9 | GIT_REPO = "gnuradio.git" | 67 | GIT_REPO = "gnuradio.git" |
10 | GIT_BRANCH = "next" | 68 | GIT_BRANCH = "master" |
11 | 69 | ||
12 | SRC_URI = "git://gnuradio.org/git/${GIT_REPO};branch=${GIT_BRANCH};protocol=http \ | 70 | SRC_URI = "git://gnuradio.org/git/${GIT_REPO};branch=${GIT_BRANCH};protocol=http \ |
13 | file://0001-volk-Remove-all-traces-of-volk-from-configure-for-OE.patch \ | 71 | " |
14 | file://0001-buildsys-don-t-add-usr-include-and-usr-lib-to-config.patch \ | ||
15 | " | ||
16 | 72 | ||
17 | S="${WORKDIR}/git" | 73 | S="${WORKDIR}/git" |
18 | 74 | ||
75 | OECMAKE_BUILDPATH = "${S}/build" | ||
76 | OECMAKE_SOURCEPATH = "${S}" | ||
77 | |||
78 | EXTRA_OECMAKE = "-DENABLE_GR_ATSC=FALSE -DENABLE_GR_QTGUI=ON -DENABLE_GR_WXGUI=OFF -DENABLE_GR_VIDEO_SDL=OFF -DQT_HEADERS_DIR=${STAGING_INCDIR}/qt4 -DQT_QTCORE_INCLUDE_DIR=${STAGING_INCDIR}/qt4/QtCore -DQT_LIBRARY_DIR=${STAGING_LIBDIR} -DQT_QTCORE_LIBRARY_RELEASE=${STAGING_LIBDIR}/libQtCore.so -DQT_QTGUI_LIBRARY_RELEASE=${STAGING_LIBDIR}/libQtGui.so -DENABLE_GR_FCD=OFF -DIMPORT_EXECUTABLES=${S}/gr-vocoder/lib/generate_codebook.txt" | ||
79 | |||
80 | EXTRA_OEMAKE = "-C ${OECMAKE_BUILDPATH}" | ||
81 | |||