summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2016-12-15 08:04:11 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-12-26 08:23:24 +0100
commite7e2e3cf814cc3688abc9cd026f799b2bd3ea061 (patch)
treef1ae9ccebec51e863ebfc51fc44e6e3600a61946 /meta-oe/recipes-connectivity
parent1e2491d12520d767e0e5687a9b15819fe0b6ff27 (diff)
downloadmeta-openembedded-e7e2e3cf814cc3688abc9cd026f799b2bd3ea061.tar.gz
dibbler: add initial recipe, dibbler 1.0.1
Dibbler is a portable DHCPv6 implementation. http://klub.com.pl/dhcpv6/ Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r--meta-oe/recipes-connectivity/dibbler/dibbler_1.0.1.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/dibbler/dibbler_1.0.1.bb b/meta-oe/recipes-connectivity/dibbler/dibbler_1.0.1.bb
new file mode 100644
index 000000000..41bb78fff
--- /dev/null
+++ b/meta-oe/recipes-connectivity/dibbler/dibbler_1.0.1.bb
@@ -0,0 +1,40 @@
1SUMMARY = "A portable DHCPv6 implementation"
2DESCRIPTION = "Dibbler is a portable DHCPv6 implementation. It supports stateful \
3(i.e. IPv6 address granting and IPv6 prefix delegation) as well as stateless (i.e. \
4option granting) autoconfiguration for IPv6."
5HOMEPAGE = "http://klub.com.pl/dhcpv6"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=7236695bb6d4461c105d685a8b61c4e3 \
8 file://bison++/COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
9
10DEPENDS = "flex-native bison-native"
11
12SRC_URI = "http://klub.com.pl/dhcpv6/dibbler/dibbler-${PV}.tar.gz"
13
14SRC_URI[md5sum] = "93357bea3ec35b0c1d11242055361409"
15SRC_URI[sha256sum] = "27869877e060c039cbc24a5f6a9dd69006bf67de0ffdf29a645a80aef6e476a1"
16
17inherit autotools
18
19PACKAGECONFIG ?= "auth bind-reuse dns-update dst-addr-filter link-state"
20
21PACKAGECONFIG[auth] = "--enable-auth,--disable-auth"
22PACKAGECONFIG[bind-reuse] = "--enable-bind-reuse,--disable-bind-reuse"
23PACKAGECONFIG[debug] = "--enable-debug,--disable-debug"
24PACKAGECONFIG[dns-update] = "--enable-dns-update,--disable-dns-update"
25PACKAGECONFIG[dst-addr-filter] = "--enable-dst-addr-filter,--disable-dst-addr-filter"
26PACKAGECONFIG[link-state] = "--enable-link-state,--disable-link-state"
27PACKAGECONFIG[remote-autoconf] = "--enable-remote-autoconf,--disable-remote-autoconf"
28PACKAGECONFIG[resolvconf] = "--enable-resolvconf,--disable-resolvconf"
29
30EXTRA_OECONF += " \
31 --disable-efence \
32 --with-gtest=no \
33"
34
35PACKAGES =+ "${PN}-client ${PN}-relay ${PN}-requestor ${PN}-server"
36
37FILES_${PN}-client = "${sbindir}/${PN}-client"
38FILES_${PN}-relay = "${sbindir}/${PN}-relay"
39FILES_${PN}-requestor = "${sbindir}/${PN}-requestor"
40FILES_${PN}-server = "${sbindir}/${PN}-server"