diff options
author | Adrian Freihofer <adrian.freihofer@gmail.com> | 2022-03-03 14:06:17 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-03-03 23:07:50 -0800 |
commit | 0d290a5a384b9ab19ed5fffdfac5e14621faa695 (patch) | |
tree | c77249c53701c68d331d6b0e27f91521780ea199 /meta-oe/recipes-connectivity | |
parent | d6a72c62dd1eb9a1b84ff2c1aa6a6c7707955e46 (diff) | |
download | meta-openembedded-0d290a5a384b9ab19ed5fffdfac5e14621faa695.tar.gz |
modemmanager: update 1.16.8 -> 1.18.6
Recipe changes:
* Switch to meson and git. From release notes of ModemManager:
"The next major release will likely be a meson-only one, and will therefore
not be based on a source release tarball any more, but on specific git tags
instead. The tar archive does not even contain the meson.build file."
* Update licenses to -or-later (warning about deprecated licenses)
* Make vala dependecy optional
* Delete redundant package split lines
* add missing dbus dependency
The most important features and changes in this release are the following:
* Data session multiplexing can now be enabled in QMI and MBIM modems, e.g. so
that multiple different APNs can be connected separately over a single
network interface. The multiplexing is disabled by default in this release,
except for cases where it's required (e.g. if non-multiplexed sessions aren't
supported) like IPA based Qualcomm SoCs. Users can request the multiplexing
support explicitly via settings when creating the connection bearer object.
In order to allow easy testing of the multiplexing feature without requiring
any additional change in the stack, a new '--test-multiplex-requested' option
in the daemon allows to switch the default (when not explicitly given by the
user) to attempt to use multiplexing.
It is worth noting that when multiplexing is enabled, the data network
interface used by the modem will be a virtual network interface created in
runtime, and will therefore have a different name than the real network
interface exposed by the modem. If there are additional settings in the
system relying on the data network interface name (e.g. iptables rules), they
may need to be updated.
* The ModemManager daemon can run now in a 'quick suspend/resume' mode, in
which no explicit data disconnection is triggered on suspend, and no explicit
device re-probing from scratch is launched on resume. Instead, the daemon
will try to refresh the state of all interfaces upon suspend, e.g. to see if
the module keeps registered to the same operator, to see if it is still
connected, and so on.
This mode of operation is useful when the WWAN module stays awake while the
host is suspended, and can be enabled with the '--test-quick-suspend-resume'
option in the daemon.
* API:
** New '3gppProfileManager' interface, providing operations on the list of
connection profiles stored in the 3GPP module. This interface is
implemented for all AT, QMI and MBIM protocols.
** New 'DisableFacilityLock()' method in the 3GPP interface, implemented for
QMI and MBIM devices.
** The 'MaxBearers' property is now deprecated, as it didn't provide any
additional information to what 'MaxActiveBearers' already provides.
** New 'MaxActiveMultiplexedBearers' property, listing how many bearers can
be connected at the same time if multiplexing is enabled.
** New settings in the bearer properties, applicable to both the
'Simple.Connect()' and 'Modem.CreateBearer()' methods:
*** 'multiplex': which allows the user to specify whether multiplexing
should be avoided ('none'), whether it should be mandatory
('required') or whether it should be enabled if available or skipped
if unavailable ('requested').
*** 'profile-id': which allows the user to request a connection attempt
with an existing profile stored in the module.
*** 'apn-type': which allows the user to specify the purpose of a given
connection, e.g. the user could create a connection to an APN
providing default internet connectivity and another one to an APN
providing access to the MMS gateway. This setting may or may not be
stored in the module itself, it depends on the type of module.
** New 'Multiplexed' boolean property in the Bearer object, specifying
whether the bearer is connected through a multiplexed interface.
** New 'ConnectionError' property in the bearer object, specifying the last
error reported by the module during a failed connection attempt or during
a network-initiated disconnection.
** Updated the list of enum values in the MMMobileEquipmentError' type,
according to the error codes defined in v17.1.0 of 3GPP TS 27.007.
* Core:
** iconv() features support is detected at runtime, and logged when the
daemon starts.
** Updated the base modem object to allow plugins to specify the types of
data ports they support, based on the specific plugin implementations,
e.g. so that a modem supporting only AT+PPP can ignore NET ports and
vice versa.
** Added support for modems exposing control ports via QRTR channels.
* Modem interface:
** The Dual SIM logic that would iterate over all slots during initialization
is updated, so that we only report the information that we can gather
without any explicit slot change. E.g. with QMI we can know whether there
is a SIM in the non-active slot, and the ICCID of that SIM, but we cannot
know the MCCMNC or the operator name of the SIM unless we change to that
slot. We must not do slot changes arbitrarily like that, and so that logic
is removed, even if we lose some of the information that we were providing
in the interface.
* Location interface:
** The multi-sentence NMEA trace support is updated to include additional
possible trace types in addition to GSV (e.g. ALM, GSV, RTE, SFI) and also
when coming from other constellations, not just GPS.
* SIM:
** New 'PreferredNetworks' property and 'SetPreferredNetworks' method,
implemented using '+CPOL' for generic AT modems and 'NAS Get/Set Preferred
Networks' for QMI modems. Several different modules and plugins (e.g.
Sierra Wireless EM7345, Telit LN930, SIM7070, all Option and Iridium
devices...) have this feature explicitly disabled due to '+CPOL' not
behaving properly (even crashing the module sometimes).
* QMI:
** The logic that decides which data mode (802.3 or raw-ip) is used in
modules managed by the qmi_wwan driver changes in this release. Until now,
if a module reported itself as configured in 802.3 mode on boot, that mode
would be the one used in normal operation. Due to the new multiplexing
feature, this is no longer true, and if possible the daemon will always
try to switch the module to raw-ip, and fallback to 802.3 only if raw-ip
is unsupported.
** Enabled both AT and QMI indications for the messaging and voice interfaces
so that new SMS and call events are reported via both channels. This
solves issues seen in the Pinephone when waking up from suspend.
** Enabled network reject indications.
** If operator name not updated through standard indications, it will be
explicitly queried with 'NAS Get Plmn Name'.
** Added support for transfer-route MT messages.
** Increased the QMI open timeout to 45s, as required by the newest modules.
** Implemented additional logic to read the status of the different facility
locks in the module.
** Updated ICCID reading logic to parse it as hex instead of BCD.
** Improved handling of the MNC PCS digit in the operations involving MCCMNC.
** Automatically run the 'DPM Open Port' logic on IPA based setups to bind
the hardware tx/rx endpoints with the logical ones in the QMI protocol.
** Implemented support for the Voice interface and its operations, not only
standard voice call management, but also support for the supplementary
services. Voice call management will be done completely using QMI, even
if the new call indications are notified via AT URCs.
* MBIM:
** Implemented support for Dual SIM in non-QMI MBIM devices, using the
Microsoft Basic Connect Extensions service.
** Increased the timeout for the MBIM_CID_HOME_PROVIDER query to 30s.
** Updated to load model string using QMI over MBIM if available.
** Increased the MBIM open timeout to 45s, as required by the newest modules.
* SMS:
** Defined a common timeout of 180s for all send operations.
* libmm-glib:
** Updated with new methods and types to handle all the DBus API updates.
** Extended with additional methods in the Location3gpp object to get/set the
full operator MCCMNC string, instead of integers without MNC PCS digit
info.
** Extended the 'ModemLocation' interface with methods to get the signaled
location updates; i.e. without requiring an explicit GetLocation(), and
obviously only supported when location signaling is explicitly enabled.
** Updated the way the internal monitored properties are handled in the
different types, now using some handy helper macros to share the same
logic among all.
* Plugins:
** zte: disabled CIND/CMER support.
** qcom-soc: added support for QRTR+IPA based setups.
** qcom-soc: added support for the WWAN subsystem instead of RPMSG.
** quectel: enabled QGPSXTRA by default when starting the GNSS engine.
** quectel: add support for EM120/160 PCIe modules.
** quectel: added Firehose update method.
** ublox: added additional URAT combinations.
** ublox: flagged UBANDSEL as unsupported in the SARA-R4 and -N4 modules.
** cinterion: added new custom MBIM based modem with shared reset operation.
** cinterion: ignored the MBIM Intel Firmware Update service completely.
** foxconn: added custom carrier config setup for the T77W968 module.
Signed-off-by: Adrian Freihofer <adrian.freihofer@siemens.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity')
4 files changed, 230 insertions, 53 deletions
diff --git a/meta-oe/recipes-connectivity/modemmanager/files/0001-core-switch-bash-shell-scripts-to-use-bin-sh-for-use.patch b/meta-oe/recipes-connectivity/modemmanager/files/0001-core-switch-bash-shell-scripts-to-use-bin-sh-for-use.patch new file mode 100644 index 000000000..7c3e7750a --- /dev/null +++ b/meta-oe/recipes-connectivity/modemmanager/files/0001-core-switch-bash-shell-scripts-to-use-bin-sh-for-use.patch | |||
@@ -0,0 +1,68 @@ | |||
1 | From f7a3292c1c753b29384e216693f51a4213fea7d0 Mon Sep 17 00:00:00 2001 | ||
2 | From: "Bruce A. Johnson" <waterfordtrack@gmail.com> | ||
3 | Date: Wed, 22 Dec 2021 14:24:02 -0500 | ||
4 | Subject: [PATCH 1/2] core: switch bash shell scripts to use /bin/sh for use | ||
5 | w/Busybox. | ||
6 | |||
7 | Fixes https://gitlab.freedesktop.org/mobile-broadband/ModemManager/-/issues/483 | ||
8 | --- | ||
9 | data/fcc-unlock/105b | 2 +- | ||
10 | data/fcc-unlock/1199 | 2 +- | ||
11 | data/fcc-unlock/1eac | 2 +- | ||
12 | test/mmcli-test-sms | 2 +- | ||
13 | tools/tests/test-wrapper.sh.in | 2 +- | ||
14 | 5 files changed, 5 insertions(+), 5 deletions(-) | ||
15 | |||
16 | diff --git a/data/fcc-unlock/105b b/data/fcc-unlock/105b | ||
17 | index 21fe5329..f276050f 100644 | ||
18 | --- a/data/fcc-unlock/105b | ||
19 | +++ b/data/fcc-unlock/105b | ||
20 | @@ -1,4 +1,4 @@ | ||
21 | -#!/bin/bash | ||
22 | +#!/bin/sh | ||
23 | |||
24 | # SPDX-License-Identifier: CC0-1.0 | ||
25 | # 2021 Aleksander Morgado <aleksander@aleksander.es> | ||
26 | diff --git a/data/fcc-unlock/1199 b/data/fcc-unlock/1199 | ||
27 | index 0109c6ab..e1d3804c 100644 | ||
28 | --- a/data/fcc-unlock/1199 | ||
29 | +++ b/data/fcc-unlock/1199 | ||
30 | @@ -1,4 +1,4 @@ | ||
31 | -#!/bin/bash | ||
32 | +#!/bin/sh | ||
33 | |||
34 | # SPDX-License-Identifier: CC0-1.0 | ||
35 | # 2021 Aleksander Morgado <aleksander@aleksander.es> | ||
36 | diff --git a/data/fcc-unlock/1eac b/data/fcc-unlock/1eac | ||
37 | index 1068d9c2..d9342852 100644 | ||
38 | --- a/data/fcc-unlock/1eac | ||
39 | +++ b/data/fcc-unlock/1eac | ||
40 | @@ -1,4 +1,4 @@ | ||
41 | -#!/bin/bash | ||
42 | +#!/bin/sh | ||
43 | |||
44 | # SPDX-License-Identifier: CC0-1.0 | ||
45 | # 2021 Aleksander Morgado <aleksander@aleksander.es> | ||
46 | diff --git a/test/mmcli-test-sms b/test/mmcli-test-sms | ||
47 | index 18e0a7b4..7136ee0d 100755 | ||
48 | --- a/test/mmcli-test-sms | ||
49 | +++ b/test/mmcli-test-sms | ||
50 | @@ -1,4 +1,4 @@ | ||
51 | -#!/bin/bash | ||
52 | +#!/bin/sh | ||
53 | |||
54 | print_usage () { | ||
55 | echo "usage: $0 [MODEM INDEX] [all|ucs2|gsm7|data] [NUMBER]" | ||
56 | diff --git a/tools/tests/test-wrapper.sh.in b/tools/tests/test-wrapper.sh.in | ||
57 | index d64ea4cb..fcdb56de 100644 | ||
58 | --- a/tools/tests/test-wrapper.sh.in | ||
59 | +++ b/tools/tests/test-wrapper.sh.in | ||
60 | @@ -1,4 +1,4 @@ | ||
61 | -#!/bin/bash | ||
62 | +#!/bin/sh | ||
63 | |||
64 | # For debugging behavior of test-modemmanager-service.py, you can modify | ||
65 | # this line to add --log-file option | ||
66 | -- | ||
67 | 2.34.1 | ||
68 | |||
diff --git a/meta-oe/recipes-connectivity/modemmanager/files/0002-fcc-unlock-Make-scripts-POSIX-shell-compatible.patch b/meta-oe/recipes-connectivity/modemmanager/files/0002-fcc-unlock-Make-scripts-POSIX-shell-compatible.patch new file mode 100644 index 000000000..d911d54ce --- /dev/null +++ b/meta-oe/recipes-connectivity/modemmanager/files/0002-fcc-unlock-Make-scripts-POSIX-shell-compatible.patch | |||
@@ -0,0 +1,100 @@ | |||
1 | From ddf634b92bf96b35f521db6da329628b4525c2eb Mon Sep 17 00:00:00 2001 | ||
2 | From: Sven Schwermer <sven.schwermer@disruptive-technologies.com> | ||
3 | Date: Fri, 25 Feb 2022 21:37:13 +0100 | ||
4 | Subject: [PATCH 2/2] fcc-unlock: Make scripts POSIX shell compatible | ||
5 | |||
6 | This allows us to not rely on bash which may not be available on | ||
7 | constrained systems, e.g. Yocto-built embedded systems. The scripts now | ||
8 | pass shellcheck. | ||
9 | |||
10 | Signed-off-by: Sven Schwermer <sven.schwermer@disruptive-technologies.com> | ||
11 | --- | ||
12 | data/fcc-unlock/105b | 8 ++++---- | ||
13 | data/fcc-unlock/1199 | 6 +++--- | ||
14 | data/fcc-unlock/1eac | 8 ++++---- | ||
15 | 3 files changed, 11 insertions(+), 11 deletions(-) | ||
16 | |||
17 | diff --git a/data/fcc-unlock/105b b/data/fcc-unlock/105b | ||
18 | index f276050f..772c90f4 100644 | ||
19 | --- a/data/fcc-unlock/105b | ||
20 | +++ b/data/fcc-unlock/105b | ||
21 | @@ -15,20 +15,20 @@ shift | ||
22 | # second and next arguments are control port names | ||
23 | for PORT in "$@"; do | ||
24 | # match port type in Linux 5.14 and newer | ||
25 | - grep -q MBIM /sys/class/wwan/${PORT}/type 2>/dev/null && { | ||
26 | + grep -q MBIM "/sys/class/wwan/$PORT/type" 2>/dev/null && { | ||
27 | MBIM_PORT=$PORT | ||
28 | break | ||
29 | } | ||
30 | # match port name in Linux 5.13 | ||
31 | - [[ $PORT == *"MBIM"* ]] && { | ||
32 | + echo "$PORT" | grep -q MBIM && { | ||
33 | MBIM_PORT=$PORT | ||
34 | break | ||
35 | } | ||
36 | done | ||
37 | |||
38 | # fail if no MBIM port exposed | ||
39 | -[ -n "${MBIM_PORT}" ] || exit 2 | ||
40 | +[ -n "$MBIM_PORT" ] || exit 2 | ||
41 | |||
42 | # run qmicli operation over MBIM | ||
43 | -qmicli --device-open-proxy --device=/dev/${MBIM_PORT} --dms-foxconn-set-fcc-authentication=0 | ||
44 | +qmicli --device-open-proxy --device="/dev/$MBIM_PORT" --dms-foxconn-set-fcc-authentication=0 | ||
45 | exit $? | ||
46 | diff --git a/data/fcc-unlock/1199 b/data/fcc-unlock/1199 | ||
47 | index e1d3804c..6dbf8d1b 100644 | ||
48 | --- a/data/fcc-unlock/1199 | ||
49 | +++ b/data/fcc-unlock/1199 | ||
50 | @@ -19,15 +19,15 @@ shift | ||
51 | # second and next arguments are control port names | ||
52 | for PORT in "$@"; do | ||
53 | # match port name | ||
54 | - [[ $PORT == *"cdc-wdm"* ]] && { | ||
55 | + echo "$PORT" | grep -q cdc-wdm && { | ||
56 | CDC_WDM_PORT=$PORT | ||
57 | break | ||
58 | } | ||
59 | done | ||
60 | |||
61 | # fail if no cdc-wdm port exposed | ||
62 | -[ -n "${CDC_WDM_PORT}" ] || exit 2 | ||
63 | +[ -n "$CDC_WDM_PORT" ] || exit 2 | ||
64 | |||
65 | # run qmicli operation | ||
66 | -qmicli --device-open-proxy --device=/dev/${CDC_WDM_PORT} --dms-set-fcc-authentication | ||
67 | +qmicli --device-open-proxy --device="/dev/$CDC_WDM_PORT" --dms-set-fcc-authentication | ||
68 | exit $? | ||
69 | diff --git a/data/fcc-unlock/1eac b/data/fcc-unlock/1eac | ||
70 | index d9342852..44ce46d7 100644 | ||
71 | --- a/data/fcc-unlock/1eac | ||
72 | +++ b/data/fcc-unlock/1eac | ||
73 | @@ -15,20 +15,20 @@ shift | ||
74 | # second and next arguments are control port names | ||
75 | for PORT in "$@"; do | ||
76 | # match port type in Linux 5.14 and newer | ||
77 | - grep -q MBIM /sys/class/wwan/${PORT}/type 2>/dev/null && { | ||
78 | + grep -q MBIM "/sys/class/wwan/$PORT/type" 2>/dev/null && { | ||
79 | MBIM_PORT=$PORT | ||
80 | break | ||
81 | } | ||
82 | # match port name in Linux 5.13 | ||
83 | - [[ $PORT == *"MBIM"* ]] && { | ||
84 | + echo "$PORT" | grep -q MBIM && { | ||
85 | MBIM_PORT=$PORT | ||
86 | break | ||
87 | } | ||
88 | done | ||
89 | |||
90 | # fail if no MBIM port exposed | ||
91 | -[ -n "${MBIM_PORT}" ] || exit 2 | ||
92 | +[ -n "$MBIM_PORT" ] || exit 2 | ||
93 | |||
94 | # run mbimcli operation | ||
95 | -mbimcli --device-open-proxy --device=/dev/${MBIM_PORT} --quectel-set-radio-state=on | ||
96 | +mbimcli --device-open-proxy --device="/dev/$MBIM_PORT" --quectel-set-radio-state=on | ||
97 | exit $? | ||
98 | -- | ||
99 | 2.34.1 | ||
100 | |||
diff --git a/meta-oe/recipes-connectivity/modemmanager/modemmanager_1.16.8.bb b/meta-oe/recipes-connectivity/modemmanager/modemmanager_1.16.8.bb deleted file mode 100644 index 5aaa55c7a..000000000 --- a/meta-oe/recipes-connectivity/modemmanager/modemmanager_1.16.8.bb +++ /dev/null | |||
@@ -1,53 +0,0 @@ | |||
1 | SUMMARY = "ModemManager is a daemon controlling broadband devices/connections" | ||
2 | DESCRIPTION = "ModemManager is a DBus-activated daemon which controls mobile broadband (2G/3G/4G) devices and connections" | ||
3 | HOMEPAGE = "http://www.freedesktop.org/wiki/Software/ModemManager/" | ||
4 | LICENSE = "GPL-2.0 & LGPL-2.1" | ||
5 | LIC_FILES_CHKSUM = " \ | ||
6 | file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ | ||
7 | file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \ | ||
8 | " | ||
9 | |||
10 | inherit gnomebase gettext systemd vala gobject-introspection bash-completion | ||
11 | |||
12 | DEPENDS = "glib-2.0 libgudev libxslt-native" | ||
13 | |||
14 | SRC_URI = "http://www.freedesktop.org/software/ModemManager/ModemManager-${PV}.tar.xz" | ||
15 | SRC_URI[sha256sum] = "21fdfaf94171261ad9d99771894f5ade4bc39ef3d1ff1d421054d14713e97880" | ||
16 | S = "${WORKDIR}/ModemManager-${PV}" | ||
17 | |||
18 | PACKAGECONFIG ??= "mbim qmi \ | ||
19 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd polkit', d)} \ | ||
20 | " | ||
21 | |||
22 | PACKAGECONFIG[at] = "--with-at-command-via-dbus" | ||
23 | PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,," | ||
24 | PACKAGECONFIG[polkit] = "--with-polkit=yes,--with-polkit=no,polkit" | ||
25 | # Support WWAN modems and devices which speak the Mobile Interface Broadband Model (MBIM) protocol. | ||
26 | PACKAGECONFIG[mbim] = "--with-mbim,--without-mbim,libmbim" | ||
27 | # Support WWAN modems and devices which speak the Qualcomm MSM Interface (QMI) protocol. | ||
28 | PACKAGECONFIG[qmi] = "--with-qmi,--without-qmi,libqmi" | ||
29 | |||
30 | EXTRA_OECONF = " \ | ||
31 | --with-udev-base-dir=${nonarch_base_libdir}/udev \ | ||
32 | " | ||
33 | |||
34 | FILES:${PN} += " \ | ||
35 | ${datadir}/icons \ | ||
36 | ${datadir}/polkit-1 \ | ||
37 | ${datadir}/dbus-1 \ | ||
38 | ${datadir}/ModemManager \ | ||
39 | ${libdir}/ModemManager \ | ||
40 | ${systemd_unitdir}/system \ | ||
41 | " | ||
42 | |||
43 | FILES:${PN}-dev += " \ | ||
44 | ${libdir}/ModemManager/*.la \ | ||
45 | " | ||
46 | |||
47 | FILES:${PN}-staticdev += " \ | ||
48 | ${libdir}/ModemManager/*.a \ | ||
49 | " | ||
50 | |||
51 | FILES:${PN}-dbg += "${libdir}/ModemManager/.debug" | ||
52 | |||
53 | SYSTEMD_SERVICE:${PN} = "ModemManager.service" | ||
diff --git a/meta-oe/recipes-connectivity/modemmanager/modemmanager_1.18.6.bb b/meta-oe/recipes-connectivity/modemmanager/modemmanager_1.18.6.bb new file mode 100644 index 000000000..14d9942c0 --- /dev/null +++ b/meta-oe/recipes-connectivity/modemmanager/modemmanager_1.18.6.bb | |||
@@ -0,0 +1,62 @@ | |||
1 | SUMMARY = "ModemManager is a daemon controlling broadband devices/connections" | ||
2 | DESCRIPTION = "ModemManager is a DBus-activated daemon which controls mobile broadband (2G/3G/4G) devices and connections" | ||
3 | HOMEPAGE = "http://www.freedesktop.org/wiki/Software/ModemManager/" | ||
4 | LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later" | ||
5 | LIC_FILES_CHKSUM = " \ | ||
6 | file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ | ||
7 | file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \ | ||
8 | " | ||
9 | |||
10 | GNOMEBASEBUILDCLASS = "meson" | ||
11 | inherit gnomebase gettext systemd gobject-introspection bash-completion | ||
12 | |||
13 | DEPENDS = "glib-2.0 libgudev libxslt-native dbus" | ||
14 | |||
15 | SRCREV ?= "a7bcf2036b34d5043dbc33fee7d98bae5859c4d3" | ||
16 | |||
17 | # Patches 0001, 0002 will be in ModemManager > 1.18.6 | ||
18 | SRC_URI = " \ | ||
19 | git://gitlab.freedesktop.org/mobile-broadband/ModemManager.git;protocol=https;branch=mm-1-18 \ | ||
20 | file://0001-core-switch-bash-shell-scripts-to-use-bin-sh-for-use.patch \ | ||
21 | file://0002-fcc-unlock-Make-scripts-POSIX-shell-compatible.patch \ | ||
22 | " | ||
23 | |||
24 | S = "${WORKDIR}/git" | ||
25 | |||
26 | # strict, permissive | ||
27 | MODEMMANAGER_POLKIT_TYPE ??= "permissive" | ||
28 | |||
29 | PACKAGECONFIG ??= "vala mbim qmi \ | ||
30 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd polkit', d)} \ | ||
31 | " | ||
32 | |||
33 | PACKAGECONFIG[at] = "-Dat_command_via_dbus=true" | ||
34 | PACKAGECONFIG[systemd] = " \ | ||
35 | -Dsystemdsystemunitdir=${systemd_unitdir}/system/, \ | ||
36 | -Dsystemdsystemunitdir=no -Dsystemd_journal=false -Dsystemd_suspend_resume=false \ | ||
37 | " | ||
38 | PACKAGECONFIG[polkit] = "-Dpolkit=${MODEMMANAGER_POLKIT_TYPE},-Dpolkit=no,polkit" | ||
39 | # Support WWAN modems and devices which speak the Mobile Interface Broadband Model (MBIM) protocol. | ||
40 | PACKAGECONFIG[mbim] = "-Dmbim=true,-Dmbim=false -Dplugin_dell=disabled -Dplugin_foxconn=disabled,libmbim" | ||
41 | # Support WWAN modems and devices which speak the Qualcomm MSM Interface (QMI) protocol. | ||
42 | PACKAGECONFIG[qmi] = "-Dqmi=true,-Dqmi=false,libqmi" | ||
43 | PACKAGECONFIG[qrtr] = "-Dqrtr=true,-Dqrtr=false,libqrtr-glib" | ||
44 | PACKAGECONFIG[vala] = "-Dvapi=true,-Dvapi=false" | ||
45 | |||
46 | inherit ${@bb.utils.contains('PACKAGECONFIG', 'vala', 'vala', '', d)} | ||
47 | |||
48 | EXTRA_OEMESON = " \ | ||
49 | -Dudevdir=${nonarch_base_libdir}/udev \ | ||
50 | -Dqrtr=false \ | ||
51 | " | ||
52 | |||
53 | FILES:${PN} += " \ | ||
54 | ${datadir}/icons \ | ||
55 | ${datadir}/polkit-1 \ | ||
56 | ${datadir}/dbus-1 \ | ||
57 | ${datadir}/ModemManager \ | ||
58 | ${libdir}/ModemManager \ | ||
59 | ${systemd_unitdir}/system \ | ||
60 | " | ||
61 | |||
62 | SYSTEMD_SERVICE:${PN} = "ModemManager.service" | ||