summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2013-05-22 10:35:37 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-05-28 11:01:09 +0200
commit1441aafec850ac3e493030221fd3ee51b242c459 (patch)
tree6705961998455a114d8fb7524634d961480b51aa /meta-oe/recipes-connectivity
parentdd63dc5afda827649555a126c9225982f370ccb0 (diff)
downloadmeta-openembedded-1441aafec850ac3e493030221fd3ee51b242c459.tar.gz
gnuradio : Update recipe to build for all machines.
Also updated the git repo address after recent changes in hosting. The recipe failed to build for machines without neon as a tune feature. The cmake config options have been changed so that it configures properly now. Also dropped documentation from build to work around a doc generation problem. Test on armv7a, x86, and x86-64. Signed-off-by: Philip Balister <philip@balister.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r--meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb11
1 files changed, 4 insertions, 7 deletions
diff --git a/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb b/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb
index edd4615aa..45f4c772f 100644
--- a/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb
+++ b/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb
@@ -70,7 +70,7 @@ SRCREV = "5f69899e059e9bea58f92af61f70fc3f63825087"
70GIT_REPO = "gnuradio.git" 70GIT_REPO = "gnuradio.git"
71GIT_BRANCH = "master" 71GIT_BRANCH = "master"
72 72
73SRC_URI = "git://gnuradio.org/${GIT_REPO};branch=${GIT_BRANCH};protocol=git \ 73SRC_URI = "git://git.gnuradio.org/${GIT_REPO};branch=${GIT_BRANCH};protocol=git \
74" 74"
75 75
76S="${WORKDIR}/git" 76S="${WORKDIR}/git"
@@ -82,21 +82,18 @@ EXTRA_OECMAKE = "-DENABLE_GR_ATSC=FALSE \
82 -DENABLE_GR_FCD=OFF \ 82 -DENABLE_GR_FCD=OFF \
83 -DENABLE_GR_WXGUI=OFF \ 83 -DENABLE_GR_WXGUI=OFF \
84 -DENABLE_GR_VIDEO_SDL=OFF \ 84 -DENABLE_GR_VIDEO_SDL=OFF \
85 -DENABLE_SPHINX=OFF -DENABLE_DOXYGEN=OFF \
85 -DIMPORT_EXECUTABLES=${S}/gr-vocoder/lib/generate_codebook.txt \ 86 -DIMPORT_EXECUTABLES=${S}/gr-vocoder/lib/generate_codebook.txt \
86 -DQT_HEADERS_DIR=${STAGING_INCDIR}/qt4 \ 87 -DQT_HEADERS_DIR=${STAGING_INCDIR}/qt4 \
87 -DQT_QTCORE_INCLUDE_DIR=${STAGING_INCDIR}/qt4/QtCore \ 88 -DQT_QTCORE_INCLUDE_DIR=${STAGING_INCDIR}/qt4/QtCore \
88 -DQT_LIBRARY_DIR=${STAGING_LIBDIR} \ 89 -DQT_LIBRARY_DIR=${STAGING_LIBDIR} \
89 -DQT_QTCORE_LIBRARY_RELEASE=${STAGING_LIBDIR}/libQtCore.so \ 90 -DQT_QTCORE_LIBRARY_RELEASE=${STAGING_LIBDIR}/libQtCore.so \
90 -DQT_QTGUI_LIBRARY_RELEASE=${STAGING_LIBDIR}/libQtGui.so \ 91 -DQT_QTGUI_LIBRARY_RELEASE=${STAGING_LIBDIR}/libQtGui.so \
92 ${@base_contains('TUNE_FEATURES', 'neon', \
93 '-Dhave_mfpu_neon=1', '-Dhave_mfpu_neon=0', d)} \
91" 94"
92 95
93inherit distutils-base cmake pkgconfig 96inherit distutils-base cmake pkgconfig
94 97
95EXTRA_OEMAKE = "-C ${OECMAKE_BUILDPATH}" 98EXTRA_OEMAKE = "-C ${OECMAKE_BUILDPATH}"
96 99
97# Only builds for machines with neon instructions. Problem is in upstream cmake.
98python () {
99 if not oe.utils.contains ('TUNE_FEATURES', 'neon', True, False, d):
100 raise bb.parse.SkipPackage("'neon' not in TUNE_FEATURES")
101}
102