summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity
diff options
context:
space:
mode:
authorMichael Lippautz <michael.lippautz@gmail.com>2011-04-18 20:12:13 +0200
committerMichael Lippautz <michael.lippautz@gmail.com>2011-04-18 20:59:07 +0200
commit02e3e6814c3c74050c9cdca48523a2496772bc4a (patch)
tree2b3c261f04d03c1260c483b3ceb082f813f374c1 /meta-oe/recipes-connectivity
parentfc04fe74edfe5a681ed1ee5e0458e085573f9177 (diff)
downloadmeta-openembedded-02e3e6814c3c74050c9cdca48523a2496772bc4a.tar.gz
wget: Add version 1.11.4
* Changes from org.oe.dev: ssl autodetection uses staging dirs Signed-off-by: Michael Lippautz <michael.lippautz@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r--meta-oe/recipes-connectivity/wget/wget.inc30
-rw-r--r--meta-oe/recipes-connectivity/wget/wget_1.11.4.bb7
2 files changed, 37 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/wget/wget.inc b/meta-oe/recipes-connectivity/wget/wget.inc
new file mode 100644
index 000000000..8903fee36
--- /dev/null
+++ b/meta-oe/recipes-connectivity/wget/wget.inc
@@ -0,0 +1,30 @@
1DESCRIPTION = "A console URL download utility featuring HTTP, FTP, and more."
2SECTION = "console/network"
3LICENSE = "GPL"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
5INC_PR = "r10"
6
7S = "${WORKDIR}/wget-${PV}"
8
9inherit autotools gettext
10
11EXTRA_OECONF = " \
12 --enable-ipv6
13 --with-libssl-prefix=${STAGING_DIR}${HOST_SYS}"
14
15# The unslung kernel does not support ipv6
16EXTRA_OECONF_unslung = "--without-ssl"
17# SlugOS kernels do not support ipv6. Can be loaded as a module.
18EXTRA_OECONF_slugos = "--without-ssl"
19
20do_install_append () {
21 mv ${D}${bindir}/wget ${D}${bindir}/wget.${PN}
22}
23
24pkg_postinst_${PN} () {
25 update-alternatives --install ${bindir}/wget wget wget.${PN} 100
26}
27
28pkg_prerm_${PN} () {
29 update-alternatives --remove wget wget.${PN}
30}
diff --git a/meta-oe/recipes-connectivity/wget/wget_1.11.4.bb b/meta-oe/recipes-connectivity/wget/wget_1.11.4.bb
new file mode 100644
index 000000000..b9f27f87d
--- /dev/null
+++ b/meta-oe/recipes-connectivity/wget/wget_1.11.4.bb
@@ -0,0 +1,7 @@
1PR="${INC_PR}.0"
2
3SRC_URI = "${GNU_MIRROR}/wget/wget-${PV}.tar.gz"
4SRC_URI[md5sum] = "69e8a7296c0e12c53bd9ffd786462e87"
5SRC_URI[sha256sum] = "7315963b6eefb7530b4a4f63a5d5ccdab30078784cf41ccb5297873f9adea2f3"
6
7require wget.inc