summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2012-11-24 10:43:33 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2013-01-18 10:49:42 +0100
commitd73b0653b94837234e2a3125e2a4cd9ec00f7a0f (patch)
treef558cbc51f6c7dc0647ed7a372560d027eb41935 /meta-oe/recipes-connectivity
parent6bd7221787b977e45470354b1c22b8114981b9d2 (diff)
downloadmeta-openembedded-d73b0653b94837234e2a3125e2a4cd9ec00f7a0f.tar.gz
gnuradio : Update to version 3.6.3.
* Fix packaging issues for the examples package. * Disable build for machines without neon, since cmake detection is broken. Signed-off-by: Philip Balister <philip@balister.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r--meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb22
1 files changed, 11 insertions, 11 deletions
diff --git a/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb b/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb
index aca2f9743..e1a023f54 100644
--- a/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb
+++ b/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb
@@ -4,8 +4,6 @@ SECTION = "apps"
4LICENSE = "GPLv3" 4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" 5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6 6
7PR = "r0"
8
9DEPENDS = "uhd gsl fftwf python alsa-lib boost cppunit \ 7DEPENDS = "uhd gsl fftwf python alsa-lib boost cppunit \
10 swig-native python-numpy python-pygtk orc qt4-x11-free qwt" 8 swig-native python-numpy python-pygtk orc qt4-x11-free qwt"
11 9
@@ -23,11 +21,6 @@ RDEPENDS_${PN} = "python-core python-audio python-threading python-codecs \
23 21
24C_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" 22C_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
25 23
26#do_configure_append() {
27# find ${S} -name Makefile | xargs sed -i s:'-I${STAGING_INCDIR_NATIVE'::g
28# find ${S} -name Makefile | xargs sed -i s:'-L${STAGING_LIBDIR_NATIVE'::g
29#}
30
31do_configure_prepend() { 24do_configure_prepend() {
32 ${BUILD_CC} ${S}/gr-vocoder/lib/codec2/generate_codebook.c -o ${S}/gr-vocoder/lib/generate_codebook -lm 25 ${BUILD_CC} ${S}/gr-vocoder/lib/codec2/generate_codebook.c -o ${S}/gr-vocoder/lib/generate_codebook -lm
33 echo "ADD_EXECUTABLE(generate_codebook IMPORTED)" >${S}/gr-vocoder/lib/generate_codebook.txt 26 echo "ADD_EXECUTABLE(generate_codebook IMPORTED)" >${S}/gr-vocoder/lib/generate_codebook.txt
@@ -39,7 +32,7 @@ do_compile_prepend() {
39 cp ${S}/gr-vocoder/lib/codec2/defines.h ${OECMAKE_BUILDPATH}/gr-vocoder/lib/codec2 32 cp ${S}/gr-vocoder/lib/codec2/defines.h ${OECMAKE_BUILDPATH}/gr-vocoder/lib/codec2
40} 33}
41 34
42PACKAGES =+ "\ 35PACKAGES += " \
43 ${PN}-examples \ 36 ${PN}-examples \
44 ${PN}-grc \ 37 ${PN}-grc \
45" 38"
@@ -53,20 +46,21 @@ FILES_${PN} += "${prefix}/etc/gnuradio/*"
53 46
54FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/gnuradio/.debug \ 47FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/gnuradio/.debug \
55 ${PYTHON_SITEPACKAGES_DIR}/gnuradio/*/.debug \ 48 ${PYTHON_SITEPACKAGES_DIR}/gnuradio/*/.debug \
49 ${datadir}/gnuradio/examples/*/.debug \
56 " 50 "
57FILES_${PN}-examples = "${datadir}/gnuradio/examples" 51FILES_${PN}-examples = "${datadir}/gnuradio/examples"
58 52
59PV = "3.5.3" 53PV = "3.6.3"
60 54
61FILESPATHPKG_prepend = "gnuradio-git:" 55FILESPATHPKG_prepend = "gnuradio-git:"
62 56
63SRCREV = "f621a52f779381cfe550b4278b83e701a747944c" 57SRCREV = "607a6fa3f80e08298ce7b3ee74ffca1590c05164"
64 58
65# Make it easy to test against developer repos and branches 59# Make it easy to test against developer repos and branches
66GIT_REPO = "gnuradio.git" 60GIT_REPO = "gnuradio.git"
67GIT_BRANCH = "master" 61GIT_BRANCH = "master"
68 62
69SRC_URI = "git://gnuradio.org/git/${GIT_REPO};branch=${GIT_BRANCH};protocol=http \ 63SRC_URI = "git://gnuradio.org/${GIT_REPO};branch=${GIT_BRANCH};protocol=git \
70" 64"
71 65
72S="${WORKDIR}/git" 66S="${WORKDIR}/git"
@@ -78,3 +72,9 @@ EXTRA_OECMAKE = "-DENABLE_GR_ATSC=FALSE -DENABLE_GR_QTGUI=ON -DENABLE_GR_WXGUI=O
78 72
79EXTRA_OEMAKE = "-C ${OECMAKE_BUILDPATH}" 73EXTRA_OEMAKE = "-C ${OECMAKE_BUILDPATH}"
80 74
75# Only builds for machines with neon instructions. Problem is in upstream cmake.
76python () {
77 if not oe.utils.contains ('TUNE_FEATURES', 'neon', True, False, d):
78 raise bb.parse.SkipPackage("'neon' not in TUNE_FEATURES")
79}
80