summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/wvdial/wvstreams/argp.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-07-22 09:50:45 -0700
committerArmin Kuster <akuster808@gmail.com>2017-09-13 17:16:28 -0700
commita1e9dfd390b8c2452ecf18a688126350b1891b90 (patch)
tree865ef810c6f8f682325df9016b89960f2444b8ad /meta-oe/recipes-connectivity/wvdial/wvstreams/argp.patch
parent250c476605131f0d85223795f73dcc6599e170ff (diff)
downloadmeta-openembedded-a1e9dfd390b8c2452ecf18a688126350b1891b90.tar.gz
wvstreams: Fix build with musl
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit 68b2dec5d43904c5e76fb54740b1ed84007335bd) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/wvdial/wvstreams/argp.patch')
-rw-r--r--meta-oe/recipes-connectivity/wvdial/wvstreams/argp.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/wvdial/wvstreams/argp.patch b/meta-oe/recipes-connectivity/wvdial/wvstreams/argp.patch
new file mode 100644
index 000000000..e85721363
--- /dev/null
+++ b/meta-oe/recipes-connectivity/wvdial/wvstreams/argp.patch
@@ -0,0 +1,37 @@
1Check for argp_parse in libargp and then in libc before using internal version
2
3Index: wvstreams-4.6.1/configure.ac
4===================================================================
5--- wvstreams-4.6.1.orig/configure.ac
6+++ wvstreams-4.6.1/configure.ac
7@@ -142,20 +142,21 @@ CPPFLAGS="$CPPFLAGS_save"
8 # argp
9 USE_WVSTREAMS_ARGP=0
10 AC_CHECK_HEADERS(argp.h)
11-AC_CHECK_FUNC(argp_parse)
12-if test "$ac_cv_func_argp_parse" != yes \
13- -o "$ac_cv_header_argp_h" != yes ; then
14- (
15- echo
16+AC_SEARCH_LIBS([argp_parse], [argp c], [], [
17+
18+ if test "$ac_cv_func_argp_parse" != yes \
19+ -o "$ac_cv_header_argp_h" != yes ; then
20+ (
21+ echo
22 echo 'configuring argp...'
23 cd argp
24 ./configure --host=$host_cpu-$host_os || exit $?
25 echo 'argp configured.'
26 echo
27- ) || exit $?
28- USE_WVSTREAMS_ARGP=1
29-fi
30-
31+ ) || exit $?
32+ USE_WVSTREAMS_ARGP=1
33+ fi
34+])
35 # Function checks
36 AC_HEADER_DIRENT
37