summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/uhd
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-08-02 18:32:50 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-08-02 21:43:27 +0200
commit4a8dece451c31bce1d6e7add0b5474c388df7749 (patch)
tree269241a5029081df0efe8bab476870b2b9434ec9 /meta-oe/recipes-connectivity/uhd
parent042b5bd5444769108e208d8f9eb3645f414fb42f (diff)
downloadmeta-openembedded-4a8dece451c31bce1d6e7add0b5474c388df7749.tar.gz
uhd: update to 3.2.1
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-connectivity/uhd')
-rw-r--r--meta-oe/recipes-connectivity/uhd/uhd.inc15
-rw-r--r--meta-oe/recipes-connectivity/uhd/uhd/0001-HACK-work-around-Wl-as-needed-problems.patch20
-rw-r--r--meta-oe/recipes-connectivity/uhd/uhd_git.bb5
3 files changed, 29 insertions, 11 deletions
diff --git a/meta-oe/recipes-connectivity/uhd/uhd.inc b/meta-oe/recipes-connectivity/uhd/uhd.inc
index e6a71bc26..b08d1a066 100644
--- a/meta-oe/recipes-connectivity/uhd/uhd.inc
+++ b/meta-oe/recipes-connectivity/uhd/uhd.inc
@@ -3,10 +3,11 @@ HOMEPAGE = "http://www.ettus.com"
3LICENSE = "GPLV3+" 3LICENSE = "GPLV3+"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=51b35d652c070d136bf20244494be2d3" 4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=51b35d652c070d136bf20244494be2d3"
5 5
6DEPENDS = "git-native python-cheetah-native boost libusb1 uhd-firmware" 6DEPENDS = "git-native python-cheetah-native boost libusb1 uhd-firmware orc-native"
7RDEPENDS_${PN} += "uhd-firmware" 7RDEPENDS_${PN} += "uhd-firmware"
8 8
9INC_PR = "r4" 9PE = "1"
10INC_PR = "r0"
10 11
11inherit cmake 12inherit cmake
12 13
@@ -15,14 +16,16 @@ PACKAGES =+ "${PN}-tests ${PN}-examples"
15FILES_${PN} += "${libdir}/libuhd.so" 16FILES_${PN} += "${libdir}/libuhd.so"
16FILES_${PN} += "${datadir}/uhd/utils/*" 17FILES_${PN} += "${datadir}/uhd/utils/*"
17FILES_${PN}-tests += "${datadir}/uhd/tests/*" 18FILES_${PN}-tests += "${datadir}/uhd/tests/*"
18FILES_${PN}-dbg += "${datadir}/uhd/examples/.debug/*" 19FILES_${PN}-dbg += "${datadir}/uhd/examples/.debug \
19FILES_${PN}-dbg += "${datadir}/uhd/utils/.debug/*" 20 ${datadir}/uhd/utils/.debug \
20FILES_${PN}-dbg += "${datadir}/uhd/tests/.debug/*" 21 ${datadir}/uhd/tests/.debug \
22 ${datadir}/uhd/usrp_e_utils/.debug \
23 "
21FILES_${PN}-examples = "${datadir}/uhd/examples/*" 24FILES_${PN}-examples = "${datadir}/uhd/examples/*"
22 25
23OECMAKE_BUILDPATH = "${S}/build" 26OECMAKE_BUILDPATH = "${S}/build"
24OECMAKE_SOURCEPATH = "${S}" 27OECMAKE_SOURCEPATH = "${S}"
25 28
26EXTRA_OECMAKE = "-DENABLE_USRP_E100=TRUE" 29EXTRA_OECMAKE = "-DENABLE_E100=TRUE -DENABLE_USRP_E_UTILS=TRUE"
27 30
28EXTRA_OEMAKE = "-C ${OECMAKE_BUILDPATH}" 31EXTRA_OEMAKE = "-C ${OECMAKE_BUILDPATH}"
diff --git a/meta-oe/recipes-connectivity/uhd/uhd/0001-HACK-work-around-Wl-as-needed-problems.patch b/meta-oe/recipes-connectivity/uhd/uhd/0001-HACK-work-around-Wl-as-needed-problems.patch
index 2bce7c388..eb05cc0a0 100644
--- a/meta-oe/recipes-connectivity/uhd/uhd/0001-HACK-work-around-Wl-as-needed-problems.patch
+++ b/meta-oe/recipes-connectivity/uhd/uhd/0001-HACK-work-around-Wl-as-needed-problems.patch
@@ -1,12 +1,13 @@
1From e5d7ae406cb7770c4fe4886bd162c18bf6ca2904 Mon Sep 17 00:00:00 2001 1From 77be3026cbfe77b3ee1aaa549a27f5ad50320f9d Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net> 2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Fri, 17 Jun 2011 19:44:04 +0200 3Date: Fri, 17 Jun 2011 19:44:04 +0200
4Subject: [PATCH] HACK: work around -Wl,as-needed problems 4Subject: [PATCH] HACK: work around -Wl,as-needed problems
5 5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> 6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7--- 7---
8 host/lib/types/CMakeLists.txt | 2 +- 8 host/lib/types/CMakeLists.txt | 2 +-
9 1 files changed, 1 insertions(+), 1 deletions(-) 9 host/usrp_e_utils/CMakeLists.txt | 2 +-
10 2 files changed, 2 insertions(+), 2 deletions(-)
10 11
11diff --git a/host/lib/types/CMakeLists.txt b/host/lib/types/CMakeLists.txt 12diff --git a/host/lib/types/CMakeLists.txt b/host/lib/types/CMakeLists.txt
12index 957dfd3..3147747 100644 13index 957dfd3..3147747 100644
@@ -21,6 +22,19 @@ index 957dfd3..3147747 100644
21 ELSEIF(HAVE_MACH_ABSOLUTE_TIME) 22 ELSEIF(HAVE_MACH_ABSOLUTE_TIME)
22 MESSAGE(STATUS " High resolution timing supported through mach_absolute_time.") 23 MESSAGE(STATUS " High resolution timing supported through mach_absolute_time.")
23 SET(TIME_SPEC_DEFS HAVE_MACH_ABSOLUTE_TIME) 24 SET(TIME_SPEC_DEFS HAVE_MACH_ABSOLUTE_TIME)
25diff --git a/host/usrp_e_utils/CMakeLists.txt b/host/usrp_e_utils/CMakeLists.txt
26index 9162a20..18414ad 100644
27--- a/host/usrp_e_utils/CMakeLists.txt
28+++ b/host/usrp_e_utils/CMakeLists.txt
29@@ -38,7 +38,7 @@ IF(ENABLE_USRP_E_UTILS)
30 FOREACH(util_source ${usrp_e_utils_sources})
31 GET_FILENAME_COMPONENT(util_name ${util_source} NAME_WE)
32 ADD_EXECUTABLE(${util_name} ${util_source})
33- TARGET_LINK_LIBRARIES(${util_name} ${Boost_LIBRARIES})
34+ TARGET_LINK_LIBRARIES(${util_name} ${Boost_LIBRARIES} -lpthread -lncurses)
35 INSTALL(TARGETS ${util_name} RUNTIME DESTINATION ${PKG_DATA_DIR}/usrp_e_utils)
36 ENDFOREACH(util_source)
37
24-- 38--
251.6.6.1 391.6.6.1
26 40
diff --git a/meta-oe/recipes-connectivity/uhd/uhd_git.bb b/meta-oe/recipes-connectivity/uhd/uhd_git.bb
index ad3385ae4..329a39598 100644
--- a/meta-oe/recipes-connectivity/uhd/uhd_git.bb
+++ b/meta-oe/recipes-connectivity/uhd/uhd_git.bb
@@ -1,9 +1,10 @@
1require uhd.inc 1require uhd.inc
2 2
3PR = "${INC_PR}.4" 3PV = "3.2.1"
4PR = "${INC_PR}.0"
4 5
5SRC_URI = "git://ettus.sourcerepo.com/ettus/uhd.git;protocol=git \ 6SRC_URI = "git://ettus.sourcerepo.com/ettus/uhd.git;protocol=git \
6 file://0001-HACK-work-around-Wl-as-needed-problems.patch;striplevel=2" 7 file://0001-HACK-work-around-Wl-as-needed-problems.patch;striplevel=2"
7S = "${WORKDIR}/git/host" 8S = "${WORKDIR}/git/host"
8 9
9SRCREV = "0aff497dacc9cc4eba5d800cc46343da083cfdf1" 10SRCREV = "fc349d30507620baca935e75e68a9554b40d427c"