diff options
author | Philip Balister <philip@balister.org> | 2016-04-12 18:04:38 -0400 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-05-06 12:38:31 +0200 |
commit | 53adf32f49ce7ef82d9addbbfb9124f714c26494 (patch) | |
tree | 0523031d00ef3d406cfd81414c5f7d5f53774cd5 /meta-oe/recipes-connectivity/thrift | |
parent | f79a851b64ead15476d60012ff657c2329b00220 (diff) | |
download | meta-openembedded-53adf32f49ce7ef82d9addbbfb9124f714c26494.tar.gz |
thrift: Add recipe for Apache Thrift.
* Run tested cpp bindings with GNU Radio Control Port.
* The patch forcible removes Qt5 from configure. The disable is correct,
but doesn't prevent a cmake error looking for qmake during configure.
We do not need Qt5, so remove check. I suspect the issue might be in
Qt5 cmake files.
Signed-off-by: Philip Balister <philip@balister.org>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/thrift')
-rw-r--r-- | meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0001-Forcibly-disable-check-for-Qt5.patch | 27 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/thrift/thrift_0.9.3.bb | 35 |
2 files changed, 62 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0001-Forcibly-disable-check-for-Qt5.patch b/meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0001-Forcibly-disable-check-for-Qt5.patch new file mode 100644 index 000000000..fcc2f0821 --- /dev/null +++ b/meta-oe/recipes-connectivity/thrift/thrift-0.9.3/0001-Forcibly-disable-check-for-Qt5.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | From b3da0d8677b7e8467367a303c18551c56ed20e15 Mon Sep 17 00:00:00 2001 | ||
2 | From: Philip Balister <philip@balister.org> | ||
3 | Date: Tue, 12 Apr 2016 17:30:15 -0400 | ||
4 | Subject: [PATCH] Forcibly disable check for Qt5. | ||
5 | |||
6 | Signed-off-by: Philip Balister <philip@balister.org> | ||
7 | --- | ||
8 | build/cmake/DefineOptions.cmake | 3 --- | ||
9 | 1 file changed, 3 deletions(-) | ||
10 | |||
11 | diff --git a/build/cmake/DefineOptions.cmake b/build/cmake/DefineOptions.cmake | ||
12 | index 62e240f..f8b4493 100644 | ||
13 | --- a/build/cmake/DefineOptions.cmake | ||
14 | +++ b/build/cmake/DefineOptions.cmake | ||
15 | @@ -52,9 +52,6 @@ CMAKE_DEPENDENT_OPTION(WITH_LIBEVENT "Build with libevent support" ON | ||
16 | find_package(Qt4 QUIET COMPONENTS QtCore QtNetwork) | ||
17 | CMAKE_DEPENDENT_OPTION(WITH_QT4 "Build with Qt4 support" ON | ||
18 | "QT4_FOUND" OFF) | ||
19 | -find_package(Qt5 QUIET COMPONENTS Core Network) | ||
20 | -CMAKE_DEPENDENT_OPTION(WITH_QT5 "Build with Qt5 support" ON | ||
21 | - "Qt5_FOUND" OFF) | ||
22 | if(${WITH_QT4} AND ${WITH_QT5} AND ${CMAKE_MAJOR_VERSION} LESS 3) | ||
23 | # cmake < 3.0.0 causes conflict when building both Qt4 and Qt5 | ||
24 | set(WITH_QT4 OFF) | ||
25 | -- | ||
26 | 2.5.5 | ||
27 | |||
diff --git a/meta-oe/recipes-connectivity/thrift/thrift_0.9.3.bb b/meta-oe/recipes-connectivity/thrift/thrift_0.9.3.bb new file mode 100644 index 000000000..b6b73ade5 --- /dev/null +++ b/meta-oe/recipes-connectivity/thrift/thrift_0.9.3.bb | |||
@@ -0,0 +1,35 @@ | |||
1 | SUMMARY = "Apache Thrift" | ||
2 | DESCRIPTION = "A software framework, for scalable cross-language services development" | ||
3 | HOMEPAGE = "https://thrift.apache.org/" | ||
4 | |||
5 | LICENSE = "Apache-2.0" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e4ed21f679b2aafef26eac82ab0c2cbf" | ||
7 | |||
8 | DEPENDS = "thrift-native boost python libevent flex-native bison-native \ | ||
9 | glib-2.0 openssl" | ||
10 | |||
11 | SRC_URI = "git://git-wip-us.apache.org/repos/asf/thrift.git;protocol=https \ | ||
12 | file://0001-Forcibly-disable-check-for-Qt5.patch \ | ||
13 | " | ||
14 | SRCREV = "61b8a29b0704ccd81b520f2300f5d1bb261fea3e" | ||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | BBCLASSEXTEND = "native nativesdk" | ||
18 | |||
19 | inherit pkgconfig cmake pythonnative | ||
20 | |||
21 | export STAGING_INCDIR | ||
22 | export STAGING_LIBDIR | ||
23 | export BUILD_SYS | ||
24 | export HOST_SYS | ||
25 | |||
26 | EXTRA_OECMAKE = "-DWITH_QT4=OFF -DWITH_QT5=OFF" | ||
27 | EXTRA_OECMAKE_class-native = "-DWITH_QT4=OFF -DWITH_QT5=OFF \ | ||
28 | -DBUILD_TESTING=OFF -DBUILD_EXAMPLES=OFF -DWITH_CPP=OFF" | ||
29 | EXTRA_OECMAKE_class-nativesdk = "-DWITH_QT4=OFF -DWITH_QT5=OFF \ | ||
30 | -DBUILD_TESTING=OFF -DBUILD_EXAMPLES=OFF -DWITH_PYTHON=OFF" | ||
31 | |||
32 | do_install_append () { | ||
33 | ln -sf thrift ${D}/${bindir}/thrift-compiler | ||
34 | } | ||
35 | |||