diff options
author | Khem Raj <raj.khem@gmail.com> | 2019-12-19 21:49:16 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-12-20 16:07:50 -0800 |
commit | fe2ee80eec163546fe44d9b08795812f3623843b (patch) | |
tree | 24ce9018f1d6596970f0b4f1a7e595dbf9a0e658 /meta-oe/recipes-connectivity/thrift | |
parent | b822b64aeb4d5c54c1f493cabc9011d741293439 (diff) | |
download | meta-openembedded-fe2ee80eec163546fe44d9b08795812f3623843b.tar.gz |
thrift: Upgrade to 0.13
License-Update: Copyright years changed
Fix build for multilib
Use python3 during build
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/thrift')
-rw-r--r-- | meta-oe/recipes-connectivity/thrift/thrift/0001-DefineInstallationPaths.cmake-Define-libdir-in-terms.patch | 42 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/thrift/thrift_0.13.0.bb (renamed from meta-oe/recipes-connectivity/thrift/thrift_0.12.0.bb) | 13 |
2 files changed, 49 insertions, 6 deletions
diff --git a/meta-oe/recipes-connectivity/thrift/thrift/0001-DefineInstallationPaths.cmake-Define-libdir-in-terms.patch b/meta-oe/recipes-connectivity/thrift/thrift/0001-DefineInstallationPaths.cmake-Define-libdir-in-terms.patch new file mode 100644 index 000000000..485d7a4b0 --- /dev/null +++ b/meta-oe/recipes-connectivity/thrift/thrift/0001-DefineInstallationPaths.cmake-Define-libdir-in-terms.patch | |||
@@ -0,0 +1,42 @@ | |||
1 | From a07e56e1a2e70a9b81eb0a65f345cf45a7a93a81 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 19 Dec 2019 21:56:23 -0800 | ||
4 | Subject: [PATCH] DefineInstallationPaths.cmake: Define libdir in terms of | ||
5 | LIB_SUFFIX | ||
6 | |||
7 | Upstream-Status: Pending | ||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
9 | --- | ||
10 | build/cmake/DefineInstallationPaths.cmake | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | --- a/build/cmake/DefineInstallationPaths.cmake | ||
14 | +++ b/build/cmake/DefineInstallationPaths.cmake | ||
15 | @@ -22,11 +22,11 @@ | ||
16 | set(BIN_INSTALL_DIR "bin" CACHE PATH "The binary install dir (default: bin)") | ||
17 | set(LIB_INSTALL_DIR "lib${LIB_SUFFIX}" CACHE PATH "The library install dir (default: lib${LIB_SUFFIX})") | ||
18 | set(INCLUDE_INSTALL_DIR "include" CACHE PATH "The library install dir (default: include)") | ||
19 | -set(CMAKE_INSTALL_DIR "lib/cmake" CACHE PATH "The subdirectory to install cmake config files (default: cmake)") | ||
20 | -set(PKGCONFIG_INSTALL_DIR "lib/pkgconfig" CACHE PATH "The subdirectory to install pkgconfig config files (default: lib/pkgconfig)") | ||
21 | +set(CMAKE_INSTALL_DIR "lib${LIB_SUFFIX}/cmake" CACHE PATH "The subdirectory to install cmake config files (default: cmake)") | ||
22 | +set(PKGCONFIG_INSTALL_DIR "lib${LIB_SUFFIX}/pkgconfig" CACHE PATH "The subdirectory to install pkgconfig config files (default: lib/pkgconfig)") | ||
23 | set(DOC_INSTALL_DIR "share/doc" CACHE PATH "The subdirectory to install documentation files (default: share/doc)") | ||
24 | set(prefix "${CMAKE_INSTALL_PREFIX}") | ||
25 | set(exec_prefix "${CMAKE_INSTALL_PREFIX}/bin") | ||
26 | -set(libdir "${CMAKE_INSTALL_PREFIX}/lib") | ||
27 | +set(libdir "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}") | ||
28 | set(includedir "${CMAKE_INSTALL_PREFIX}/include") | ||
29 | set(cmakedir "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_DIR}") | ||
30 | --- a/build/cmake/DefineCMakeDefaults.cmake | ||
31 | +++ b/build/cmake/DefineCMakeDefaults.cmake | ||
32 | @@ -44,8 +44,8 @@ include(BuildType) | ||
33 | # top of the build tree rather than in hard-to-find leaf | ||
34 | # directories. This simplifies manual testing and the use of the build | ||
35 | # tree rather than installed thrift libraries. | ||
36 | -set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/lib) | ||
37 | -set(CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/lib) | ||
38 | +set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/lib${LIB_SUFFIX}) | ||
39 | +set(CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/lib${LIB_SUFFIX}) | ||
40 | set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin) | ||
41 | |||
42 | # | ||
diff --git a/meta-oe/recipes-connectivity/thrift/thrift_0.12.0.bb b/meta-oe/recipes-connectivity/thrift/thrift_0.13.0.bb index 1c69951bf..92bcb21bf 100644 --- a/meta-oe/recipes-connectivity/thrift/thrift_0.12.0.bb +++ b/meta-oe/recipes-connectivity/thrift/thrift_0.13.0.bb | |||
@@ -4,18 +4,19 @@ HOMEPAGE = "https://thrift.apache.org/" | |||
4 | 4 | ||
5 | LICENSE = "Apache-2.0" | 5 | LICENSE = "Apache-2.0" |
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=394465e125cffc0f133695ed43f14047 \ | 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=394465e125cffc0f133695ed43f14047 \ |
7 | file://NOTICE;md5=42748ae4646b45fbfa5182807321fb6c" | 7 | file://NOTICE;md5=2659b43daca219f99a2f2626ea128f73" |
8 | 8 | ||
9 | DEPENDS = "thrift-native boost flex-native bison-native openssl" | 9 | DEPENDS = "thrift-native boost flex-native bison-native openssl" |
10 | 10 | ||
11 | SRC_URI = "https://www-eu.apache.org/dist/thrift//${PV}/${BPN}-${PV}.tar.gz" | 11 | SRC_URI = "https://www-eu.apache.org/dist/thrift//${PV}/${BPN}-${PV}.tar.gz \ |
12 | 12 | file://0001-DefineInstallationPaths.cmake-Define-libdir-in-terms.patch \ | |
13 | SRC_URI[md5sum] = "3deebbb4d1ca77dd9c9e009a1ea02183" | 13 | " |
14 | SRC_URI[sha256sum] = "c336099532b765a6815173f62df0ed897528a9d551837d627c1f87fadad90428" | 14 | SRC_URI[md5sum] = "38a27d391a2b03214b444cb13d5664f1" |
15 | SRC_URI[sha256sum] = "7ad348b88033af46ce49148097afe354d513c1fca7c607b59c33ebb6064b5179" | ||
15 | 16 | ||
16 | BBCLASSEXTEND = "native nativesdk" | 17 | BBCLASSEXTEND = "native nativesdk" |
17 | 18 | ||
18 | inherit pkgconfig cmake pythonnative | 19 | inherit pkgconfig cmake python3native |
19 | 20 | ||
20 | export STAGING_INCDIR | 21 | export STAGING_INCDIR |
21 | export STAGING_LIBDIR | 22 | export STAGING_LIBDIR |