summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/telepathy
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2014-12-30 13:53:35 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2015-01-05 13:04:50 +0100
commit15aa69d6795ecb3144ba4f5d79128f6173497709 (patch)
treeb3c989f5f8237aa12e370ab5ea747be0f3c95e01 /meta-oe/recipes-connectivity/telepathy
parentd5cf7d6981b43bb1dd703e6901a8f05a666596eb (diff)
downloadmeta-openembedded-15aa69d6795ecb3144ba4f5d79128f6173497709.tar.gz
telepathy-mission-control: add (moved from oe-core)
Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/telepathy')
-rw-r--r--meta-oe/recipes-connectivity/telepathy/telepathy-mission-control/tmc-Makefile-fix-race.patch76
-rw-r--r--meta-oe/recipes-connectivity/telepathy/telepathy-mission-control_5.16.1.bb51
2 files changed, 127 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/telepathy/telepathy-mission-control/tmc-Makefile-fix-race.patch b/meta-oe/recipes-connectivity/telepathy/telepathy-mission-control/tmc-Makefile-fix-race.patch
new file mode 100644
index 000000000..ece1da6bc
--- /dev/null
+++ b/meta-oe/recipes-connectivity/telepathy/telepathy-mission-control/tmc-Makefile-fix-race.patch
@@ -0,0 +1,76 @@
1From: Robert Yang <liezhi.yang@windriver.com>
2Date: Sun, 22 Sep 2013 23:21:01 -0400
3Subject: [PATCH] src/Makefile.am: fix race issue for _gen/gtypes.h and _gen/gtypes-body.h
4
5There might be an error when parallel build:
6
7[snip]
8Traceback (most recent call last):
9 File "/path/to/tools/glib-gtypes-generator.py", line 304, in <module>
10 GTypesGenerator(dom, argv[1], argv[2])()
11 File "/path/to/tools/glib-gtypes-generator.py", line 295, in __call__
12 file_set_contents(self.output + '.h', ''.join(self.header))
13 File "/path/to/tools/libtpcodegen.py", line 42, in file_set_contents
14 os.rename(filename + '.tmp', filename)
15OSError: [Errno 2] No such file or directory
16[snip]
17
18This is a race issue, the _gen/gtypes.h and _gen/gtypes-body.h may
19write(remove/rename) _gen/gtypes.tmp at the same time, then there would
20be the error.
21
22There was a similar bug in telepathy-glib which was already fixed, we use the
23similar patch to fix it.
24
25Upstream-Status: Pending
26
27Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
28---
29 src/Makefile.am | 18 +++++++++++++++---
30 1 file changed, 15 insertions(+), 3 deletions(-)
31
32diff --git a/src/Makefile.am b/src/Makefile.am
33--- a/src/Makefile.am
34+++ b/src/Makefile.am
35@@ -288,7 +288,11 @@ _gen/interfaces-body.h: _gen/mcd.xml \
36 $(tools_dir)/glib-interfaces-body-generator.xsl \
37 $< > $@
38
39-_gen/gtypes.h _gen/gtypes-body.h: _gen/mcd.xml \
40+# do nothing, output as a side-effect
41+_gen/gtypes.h: _gen/gtypes-body.h
42+ @:
43+
44+_gen/gtypes-body.h: _gen/mcd.xml \
45 $(top_srcdir)/tools/glib-gtypes-generator.py
46 $(AM_V_GEN)$(PYTHON) $(top_srcdir)/tools/glib-gtypes-generator.py \
47 $< _gen/gtypes mc
48@@ -309,7 +313,11 @@ _gen/%.xml: %.xml $(wildcard $(top_srcdir)/xml/*.xml) Makefile.am
49 $(AM_V_GEN)$(XSLTPROC) $(XSLTPROCFLAGS) --xinclude $(tools_dir)/identity.xsl \
50 $< > $@
51
52-_gen/cli-%-body.h _gen/cli-%.h: _gen/%.xml \
53+# do nothing, output as a side-effect
54+_gen/cli-%.h: _gen/cli-%-body.h
55+ @:
56+
57+_gen/cli-%-body.h: _gen/%.xml \
58 $(tools_dir)/glib-client-gen.py Makefile.am
59 $(AM_V_GEN)$(PYTHON) $(tools_dir)/glib-client-gen.py \
60 --group=`echo $* | tr x- x_` \
61@@ -317,7 +325,11 @@ _gen/cli-%-body.h _gen/cli-%.h: _gen/%.xml \
62 --tp-proxy-api=0.7.6 \
63 $< Mc_Cli _gen/cli-$*
64
65-_gen/svc-%.c _gen/svc-%.h: _gen/%.xml \
66+# do nothing, output as a side-effect
67+_gen/svc-%.h: _gen/svc-%.c
68+ @:
69+
70+_gen/svc-%.c: _gen/%.xml \
71 $(tools_dir)/glib-ginterface-gen.py Makefile.am
72 $(AM_V_GEN)$(PYTHON) $(tools_dir)/glib-ginterface-gen.py \
73 --filename=_gen/svc-$* \
74--
751.7.10.4
76
diff --git a/meta-oe/recipes-connectivity/telepathy/telepathy-mission-control_5.16.1.bb b/meta-oe/recipes-connectivity/telepathy/telepathy-mission-control_5.16.1.bb
new file mode 100644
index 000000000..9ae68ddea
--- /dev/null
+++ b/meta-oe/recipes-connectivity/telepathy/telepathy-mission-control_5.16.1.bb
@@ -0,0 +1,51 @@
1SUMMARY = "Central control for Telepathy IM connection managers"
2HOMEPAGE = "http://telepathy.freedesktop.org/wiki/Mission_Control/"
3LICENSE = "LGPLv2.1+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d8045f3b8f929c1cb29a1e3fd737b499 \
5 file://src/request.h;beginline=1;endline=21;md5=f80534d9af1c33291b3b79609f196eb2"
6SECTION = "libs"
7DEPENDS = "libtelepathy dbus-glib gconf libxslt-native"
8
9SRC_URI = "http://telepathy.freedesktop.org/releases/telepathy-mission-control/${BP}.tar.gz \
10 file://tmc-Makefile-fix-race.patch \
11 "
12SRC_URI[md5sum] = "421115a35b9e427807326877f86e7f43"
13SRC_URI[sha256sum] = "14ceb7d53535b43d44b8271ad11319d1d0fe6d193d154636b9e62b42799b9723"
14
15inherit autotools-brokensep pkgconfig pythonnative
16
17PACKAGECONFIG ??= ""
18PACKAGECONFIG[upower] = "--enable-upower,--disable-upower,upower"
19
20# to select connman or nm you need to use "connectivity" and "connman" or "nm", default is to disable both
21PACKAGECONFIG[connectivity] = ",--with-connectivity=no"
22PACKAGECONFIG[connman] = "--with-connectivity=connman,,connman"
23PACKAGECONFIG[nm] = "--with-connectivity=nm,,networkmanager"
24
25PACKAGES =+ " \
26 libmissioncontrol \
27 libmissioncontrol-config \
28 libmissioncontrol-server \
29 libmissioncontrol-dev \
30 libmissioncontrol-config-dev \
31 libmissioncontrol-server-dev \
32 libmissioncontrol-dbg \
33 libmissioncontrol-config-dbg \
34 libmissioncontrol-server-dbg \
35"
36
37FILES_${PN} += "${datadir}/dbus* ${datadir}/glib-2.0/schemas"
38
39FILES_libmissioncontrol = "${libdir}/libmissioncontrol.so.*"
40FILES_libmissioncontrol-config = "${libdir}/libmissioncontrol-config.so.*"
41FILES_libmissioncontrol-server = "${libdir}/libmissioncontrol-server.so.*"
42
43FILES_libmissioncontrol-dev = "${libdir}/libmissioncontrol.* \
44 ${includedir}/libmissioncontrol/ \
45 ${libdir}/pkgconfig/libmissioncontrol.pc"
46FILES_libmissioncontrol-config-dev = "${libdir}/libmissioncontrol-config.*"
47FILES_libmissioncontrol-server-dev = "${libdir}/libmissioncontrol-server.*"
48
49FILES_libmissioncontrol-dbg = "${libdir}/.debug/libmissioncontrol.so.*"
50FILES_libmissioncontrol-config-dbg = "${libdir}/.debug/libmissioncontrol-config.so.*"
51FILES_libmissioncontrol-server-dbg = "${libdir}/.debug/libmissioncontrol-server.so.*"