diff options
author | Ross Burton <ross.burton@intel.com> | 2014-12-30 13:53:34 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-01-05 13:04:50 +0100 |
commit | d5cf7d6981b43bb1dd703e6901a8f05a666596eb (patch) | |
tree | d9f62fced6f85d1bc464e967932fea38b0fc3afa /meta-oe/recipes-connectivity/telepathy/telepathy-python-0.15.19 | |
parent | 6d543b2f512f8c8dfa59eec5797026fabfb55400 (diff) | |
download | meta-openembedded-d5cf7d6981b43bb1dd703e6901a8f05a666596eb.tar.gz |
telepathy-python: add (moved from oe-core)
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/telepathy/telepathy-python-0.15.19')
3 files changed, 95 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/telepathy/telepathy-python-0.15.19/parallel_make.patch b/meta-oe/recipes-connectivity/telepathy/telepathy-python-0.15.19/parallel_make.patch new file mode 100644 index 000000000..248824606 --- /dev/null +++ b/meta-oe/recipes-connectivity/telepathy/telepathy-python-0.15.19/parallel_make.patch | |||
@@ -0,0 +1,43 @@ | |||
1 | Add dependency of __init__.py | ||
2 | |||
3 | Tasks must be done after exec of __init__, which creates the | ||
4 | src/_generated directory that tasks are based on. | ||
5 | |||
6 | Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com> | ||
7 | |||
8 | Upstream-Status: Submitted | ||
9 | (However it seems that this project is out of maintanence.) | ||
10 | |||
11 | diff -ruN telepathy-python-0.15.19-orig/src/Makefile.am telepathy-python-0.15.19/src/Makefile.am | ||
12 | --- telepathy-python-0.15.19-orig/src/Makefile.am 2011-03-10 08:51:49.000000000 +0800 | ||
13 | +++ telepathy-python-0.15.19/src/Makefile.am 2011-03-10 08:54:45.000000000 +0800 | ||
14 | @@ -39,17 +39,17 @@ | ||
15 | XSLTPROC_OPTS = --nonet --novalid --xinclude | ||
16 | tools_dir = $(top_srcdir)/tools | ||
17 | |||
18 | -_generated/interfaces.py: $(tools_dir)/python-interfaces-generator.xsl $(wildcard $(spec_dir)/*.xml) | ||
19 | +_generated/interfaces.py: _generated/__init__.py $(tools_dir)/python-interfaces-generator.xsl $(wildcard $(spec_dir)/*.xml) | ||
20 | $(AM_V_GEN)$(XSLTPROC) $(XSLTPROC_OPTS) -o $@ \ | ||
21 | $(tools_dir)/python-interfaces-generator.xsl \ | ||
22 | $(spec_dir)/all.xml | ||
23 | |||
24 | -_generated/constants.py: $(tools_dir)/python-constants-generator.xsl $(wildcard $(spec_dir)/*.xml) | ||
25 | +_generated/constants.py: _generated/__init__.py $(tools_dir)/python-constants-generator.xsl $(wildcard $(spec_dir)/*.xml) | ||
26 | $(AM_V_GEN)$(XSLTPROC) $(XSLTPROC_OPTS) -o $@ \ | ||
27 | $(tools_dir)/python-constants-generator.xsl \ | ||
28 | $(spec_dir)/all.xml | ||
29 | |||
30 | -_generated/errors.py: $(tools_dir)/python-errors-generator.xsl $(wildcard $(spec_dir)/*.xml) | ||
31 | +_generated/errors.py: _generated/__init__.py $(tools_dir)/python-errors-generator.xsl $(wildcard $(spec_dir)/*.xml) | ||
32 | $(AM_V_GEN)$(XSLTPROC) $(XSLTPROC_OPTS) -o $@ \ | ||
33 | $(tools_dir)/python-errors-generator.xsl \ | ||
34 | $(spec_dir)/all.xml | ||
35 | @@ -58,7 +58,7 @@ | ||
36 | $(AM_V_GEN)$(mkdir_p) $(dir $@) | ||
37 | @echo "# Placeholder for package" > $@ | ||
38 | |||
39 | -_generated/%.py: $(tools_dir)/spec-to-python.xsl $(spec_dir)/%.xml | ||
40 | +_generated/%.py: _generated/__init__.py $(tools_dir)/spec-to-python.xsl $(spec_dir)/%.xml | ||
41 | $(AM_V_GEN)$(XSLTPROC) $(XSLTPROC_OPTS) -o $@ \ | ||
42 | $(tools_dir)/spec-to-python.xsl \ | ||
43 | $(spec_dir)/$*.xml | ||
diff --git a/meta-oe/recipes-connectivity/telepathy/telepathy-python-0.15.19/remove_duplicate_install.patch b/meta-oe/recipes-connectivity/telepathy/telepathy-python-0.15.19/remove_duplicate_install.patch new file mode 100644 index 000000000..df95a4c13 --- /dev/null +++ b/meta-oe/recipes-connectivity/telepathy/telepathy-python-0.15.19/remove_duplicate_install.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | commit f6c67662145de889055a86a6b3b12c70a45fc8d5 | ||
2 | Author: Dongxiao Xu <dongxiao.xu@intel.com> | ||
3 | Date: Wed Sep 7 16:02:20 2011 +0800 | ||
4 | |||
5 | Avoid duplicated installation of errors.py | ||
6 | |||
7 | newer version of autotools don't seem to like listing files to install | ||
8 | twice. Remove one errors.py from the installation list. | ||
9 | |||
10 | Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com> | ||
11 | |||
12 | Upstream-Status: Inappropirate [upstream inactive] | ||
13 | |||
14 | diff --git a/src/Makefile.am b/src/Makefile.am | ||
15 | index 5c27dfe..7536e43 100644 | ||
16 | --- a/src/Makefile.am | ||
17 | +++ b/src/Makefile.am | ||
18 | @@ -11,7 +11,7 @@ telepathy_PYTHON = \ | ||
19 | |||
20 | # telepathy._generated.* auto-generated modules | ||
21 | spec_dir = $(top_srcdir)/spec | ||
22 | -spec_files := $(patsubst $(spec_dir)%.xml,_generated%.py,$(wildcard $(spec_dir)/*.xml)) | ||
23 | +spec_files := $(filter-out _generated/errors.py, $(patsubst $(spec_dir)%.xml,_generated%.py,$(wildcard $(spec_dir)/*.xml))) | ||
24 | |||
25 | BUILT_SOURCES = \ | ||
26 | _generated/interfaces.py \ | ||
diff --git a/meta-oe/recipes-connectivity/telepathy/telepathy-python-0.15.19/telepathy-python_fix_for_automake_1.12.patch b/meta-oe/recipes-connectivity/telepathy/telepathy-python-0.15.19/telepathy-python_fix_for_automake_1.12.patch new file mode 100644 index 000000000..f613fdce4 --- /dev/null +++ b/meta-oe/recipes-connectivity/telepathy/telepathy-python-0.15.19/telepathy-python_fix_for_automake_1.12.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | Upstream-Status: Pending | ||
2 | |||
3 | automake 1.12 has deprecated use of mkdir_p, and it recommends | ||
4 | use of MKDIR_P instead. Changed the code to avoid these kind | ||
5 | of warning-errors. | ||
6 | |||
7 | | make[1]: _generated/: Command not found | ||
8 | | make[1]: *** [_generated/__init__.py] Error 127 | ||
9 | | make[1]: Leaving directory `/srv/home/nitin/builds2/build0/tmp/work/i586-poky-linux/telepathy-python-0.15.19-r4/telepathy-python-0.15.19/src' | ||
10 | | make: *** [all-recursive] Error 1 | ||
11 | |||
12 | Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com> | ||
13 | 2012/07/10 | ||
14 | Index: telepathy-python-0.15.19/src/Makefile.am | ||
15 | =================================================================== | ||
16 | --- telepathy-python-0.15.19.orig/src/Makefile.am | ||
17 | +++ telepathy-python-0.15.19/src/Makefile.am | ||
18 | @@ -55,7 +55,7 @@ _generated/errors.py: _generated/__init_ | ||
19 | $(spec_dir)/all.xml | ||
20 | |||
21 | _generated/__init__.py: | ||
22 | - $(AM_V_GEN)$(mkdir_p) $(dir $@) | ||
23 | + $(AM_V_GEN)$(MKDIR_P) $(dir $@) | ||
24 | @echo "# Placeholder for package" > $@ | ||
25 | |||
26 | _generated/%.py: _generated/__init__.py $(tools_dir)/spec-to-python.xsl $(spec_dir)/%.xml | ||