diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-13 22:49:41 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-15 16:23:17 +0200 |
commit | a45830a39bb47a9eab27980d52966226c9504ea4 (patch) | |
tree | 001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-connectivity/samba/samba.inc | |
parent | 6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff) | |
download | meta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz |
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python
tasks).
* Some recipes were using tabs.
* Some were using 8 spaces.
* Some were using mix or different number of spaces.
* Make them consistently use 4 spaces everywhere.
* Yocto styleguide advises to use tabs (but the only reason to keep
tabs is the need to update a lot of recipes). Lately this advice
was also merged into the styleguide on the OE wiki.
* Using 4 spaces in both types of tasks is better because it's less
error prone when someone is not sure if e.g.
do_generate_toolchain_file() is Python or shell task and also allows
to highlight every tab used in .bb, .inc, .bbappend, .bbclass as
potentially bad (shouldn't be used for indenting of multiline
variable assignments and cannot be used for Python tasks).
* Don't indent closing quote on multiline variables
we're quite inconsistent wheater it's first character on line
under opening quote or under first non-whitespace character in
previous line.
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-connectivity/samba/samba.inc')
-rw-r--r-- | meta-oe/recipes-connectivity/samba/samba.inc | 76 |
1 files changed, 38 insertions, 38 deletions
diff --git a/meta-oe/recipes-connectivity/samba/samba.inc b/meta-oe/recipes-connectivity/samba/samba.inc index 42ddce5a1..0e4877c0c 100644 --- a/meta-oe/recipes-connectivity/samba/samba.inc +++ b/meta-oe/recipes-connectivity/samba/samba.inc | |||
@@ -8,7 +8,7 @@ SRC_URI = "http://samba.org/samba/ftp/stable/samba-${PV}.tar.gz \ | |||
8 | file://init.samba \ | 8 | file://init.samba \ |
9 | file://init.winbind \ | 9 | file://init.winbind \ |
10 | file://tdb.pc \ | 10 | file://tdb.pc \ |
11 | " | 11 | " |
12 | 12 | ||
13 | S = "${WORKDIR}/samba-${PV}/source" | 13 | S = "${WORKDIR}/samba-${PV}/source" |
14 | 14 | ||
@@ -49,51 +49,51 @@ INITSCRIPT_PARAMS = "defaults" | |||
49 | CONFFILES_${PN} = "${sysconfdir}/samba/smb.conf" | 49 | CONFFILES_${PN} = "${sysconfdir}/samba/smb.conf" |
50 | 50 | ||
51 | do_configure_prepend () { | 51 | do_configure_prepend () { |
52 | ./script/mkversion.sh | 52 | ./script/mkversion.sh |
53 | if [ ! -e acinclude.m4 ]; then | 53 | if [ ! -e acinclude.m4 ]; then |
54 | touch aclocal.m4 | 54 | touch aclocal.m4 |
55 | cat aclocal.m4 > acinclude.m4 | 55 | cat aclocal.m4 > acinclude.m4 |
56 | fi | 56 | fi |
57 | } | 57 | } |
58 | 58 | ||
59 | do_compile () { | 59 | do_compile () { |
60 | oe_runmake proto_exists | 60 | oe_runmake proto_exists |
61 | base_do_compile | 61 | base_do_compile |
62 | } | 62 | } |
63 | 63 | ||
64 | do_install_append() { | 64 | do_install_append() { |
65 | install -d ${D}${libdir}/pkgconfig/ | 65 | install -d ${D}${libdir}/pkgconfig/ |
66 | cp ${WORKDIR}/tdb.pc ${D}${libdir}/pkgconfig/ | 66 | cp ${WORKDIR}/tdb.pc ${D}${libdir}/pkgconfig/ |
67 | mv ${D}${libdir}/libsmbclient.so ${D}${libdir}/libsmbclient.so.0 || true | 67 | mv ${D}${libdir}/libsmbclient.so ${D}${libdir}/libsmbclient.so.0 || true |
68 | ln -sf libsmbclient.so.0 ${D}${libdir}/libsmbclient.so | 68 | ln -sf libsmbclient.so.0 ${D}${libdir}/libsmbclient.so |
69 | mkdir -p ${D}${base_sbindir} | 69 | mkdir -p ${D}${base_sbindir} |
70 | rm -f ${D}${bindir}/*.old | 70 | rm -f ${D}${bindir}/*.old |
71 | rm -f ${D}${sbindir}/*.old | 71 | rm -f ${D}${sbindir}/*.old |
72 | [ -f ${D}${sbindir}/mount.cifs ] && mv ${D}${sbindir}/mount.cifs ${D}${base_sbindir}/ | 72 | [ -f ${D}${sbindir}/mount.cifs ] && mv ${D}${sbindir}/mount.cifs ${D}${base_sbindir}/ |
73 | [ -f ${D}${sbindir}/umount.cifs ] && mv ${D}${sbindir}/umount.cifs ${D}${base_sbindir}/ | 73 | [ -f ${D}${sbindir}/umount.cifs ] && mv ${D}${sbindir}/umount.cifs ${D}${base_sbindir}/ |
74 | 74 | ||
75 | # This is needed for < 3.2.4 | 75 | # This is needed for < 3.2.4 |
76 | rm -f ${D}${sbindir}/mount.smbfs ${D}${base_sbindir}/mount.smbfs | 76 | rm -f ${D}${sbindir}/mount.smbfs ${D}${base_sbindir}/mount.smbfs |
77 | if [ -f ${D}${bindir}/smbmount ]; then | 77 | if [ -f ${D}${bindir}/smbmount ]; then |
78 | ln -sf ${bindir}/smbmount ${D}${base_sbindir}/mount.smb | 78 | ln -sf ${bindir}/smbmount ${D}${base_sbindir}/mount.smb |
79 | ln -sf ${bindir}/smbmount ${D}${base_sbindir}/mount.smbfs | 79 | ln -sf ${bindir}/smbmount ${D}${base_sbindir}/mount.smbfs |
80 | fi | 80 | fi |
81 | 81 | ||
82 | install -D -m 755 ${WORKDIR}/init.samba ${D}${sysconfdir}/init.d/samba | 82 | install -D -m 755 ${WORKDIR}/init.samba ${D}${sysconfdir}/init.d/samba |
83 | install -D -m 755 ${WORKDIR}/init.winbind ${D}${sysconfdir}/init.d/winbind | 83 | install -D -m 755 ${WORKDIR}/init.winbind ${D}${sysconfdir}/init.d/winbind |
84 | install -D -m 644 ${WORKDIR}/smb.conf ${D}${sysconfdir}/samba/smb.conf | 84 | install -D -m 644 ${WORKDIR}/smb.conf ${D}${sysconfdir}/samba/smb.conf |
85 | install -D -m 644 ${WORKDIR}/volatiles.03_samba ${D}${sysconfdir}/default/volatiles/volatiles.03_samba | 85 | install -D -m 644 ${WORKDIR}/volatiles.03_samba ${D}${sysconfdir}/default/volatiles/volatiles.03_samba |
86 | install -d ${D}/var/log/samba | 86 | install -d ${D}/var/log/samba |
87 | install -d ${D}/var/spool/samba | 87 | install -d ${D}/var/spool/samba |
88 | 88 | ||
89 | # Install other stuff not installed by "make install" | 89 | # Install other stuff not installed by "make install" |
90 | if [ -d ${WORKDIR}/${PN}-${PV}/nsswitch ]; then | 90 | if [ -d ${WORKDIR}/${PN}-${PV}/nsswitch ]; then |
91 | install -m 0644 ${WORKDIR}/${PN}-${PV}/nsswitch/libnss_winbind.so ${D}${libdir}/libnss_winbind.so.2 | 91 | install -m 0644 ${WORKDIR}/${PN}-${PV}/nsswitch/libnss_winbind.so ${D}${libdir}/libnss_winbind.so.2 |
92 | install -m 0644 ${WORKDIR}/${PN}-${PV}/nsswitch/libnss_wins.so ${D}${libdir}/libnss_wins.so.2 | 92 | install -m 0644 ${WORKDIR}/${PN}-${PV}/nsswitch/libnss_wins.so ${D}${libdir}/libnss_wins.so.2 |
93 | fi | 93 | fi |
94 | 94 | ||
95 | rmdir --ignore-fail-on-non-empty ${D}${base_sbindir} | 95 | rmdir --ignore-fail-on-non-empty ${D}${base_sbindir} |
96 | sed -i -e '1s,#!.*perl,#!${USRBINPATH}/env perl,' ${D}${bindir}/findsmb | 96 | sed -i -e '1s,#!.*perl,#!${USRBINPATH}/env perl,' ${D}${bindir}/findsmb |
97 | } | 97 | } |
98 | 98 | ||
99 | 99 | ||
@@ -102,8 +102,8 @@ pkg_postinst_libnss-winbind () { | |||
102 | # add wins to the list of resolvers | 102 | # add wins to the list of resolvers |
103 | ns=$D${sysconfdir}/nsswitch.conf | 103 | ns=$D${sysconfdir}/nsswitch.conf |
104 | if ! grep "hosts:.*wins" $ns > /dev/null; then | 104 | if ! grep "hosts:.*wins" $ns > /dev/null; then |
105 | hosts="`grep '^hosts:' $ns`" | 105 | hosts="`grep '^hosts:' $ns`" |
106 | hosts=`echo "$hosts" | sed 's/\[/\\\\[/g; s/\]/\\\\]/g'` | 106 | hosts=`echo "$hosts" | sed 's/\[/\\\\[/g; s/\]/\\\\]/g'` |
107 | sed -i "s/$hosts/$hosts wins/" "$ns" | 107 | sed -i "s/$hosts/$hosts wins/" "$ns" |
108 | fi | 108 | fi |
109 | } | 109 | } |