summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/rfkill
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-connectivity/rfkill
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/rfkill')
-rw-r--r--meta-oe/recipes-connectivity/rfkill/rfkill/0001-rfkill-makefile-don-t-use-t-the-OE-install-wrapper-d.patch30
-rw-r--r--meta-oe/recipes-connectivity/rfkill/rfkill/dont.call.git.rev-parse.on.parent.dir.patch31
-rw-r--r--meta-oe/recipes-connectivity/rfkill/rfkill_0.4.bb27
3 files changed, 88 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/rfkill/rfkill/0001-rfkill-makefile-don-t-use-t-the-OE-install-wrapper-d.patch b/meta-oe/recipes-connectivity/rfkill/rfkill/0001-rfkill-makefile-don-t-use-t-the-OE-install-wrapper-d.patch
new file mode 100644
index 000000000..c6f60d0ed
--- /dev/null
+++ b/meta-oe/recipes-connectivity/rfkill/rfkill/0001-rfkill-makefile-don-t-use-t-the-OE-install-wrapper-d.patch
@@ -0,0 +1,30 @@
1From db764080e54f8f998c28ef8dab78da8b8d1d1420 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Fri, 11 Feb 2011 10:35:40 +0100
4Subject: [PATCH] rfkill makefile: don't use -t, the OE install wrapper dislikes it
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7---
8 Makefile | 4 ++--
9 1 files changed, 2 insertions(+), 2 deletions(-)
10
11diff --git a/Makefile b/Makefile
12index 8d6c700..3652690 100644
13--- a/Makefile
14+++ b/Makefile
15@@ -53,10 +53,10 @@ check:
16 install: rfkill rfkill.8.gz
17 @$(NQ) ' INST rfkill'
18 $(Q)$(MKDIR) $(DESTDIR)$(SBINDIR)
19- $(Q)$(INSTALL) -m 755 -t $(DESTDIR)$(SBINDIR) rfkill
20+ $(Q)$(INSTALL) -m 755 rfkill $(DESTDIR)$(SBINDIR)
21 @$(NQ) ' INST rfkill.8'
22 $(Q)$(MKDIR) $(DESTDIR)$(MANDIR)/man8/
23- $(Q)$(INSTALL) -m 644 -t $(DESTDIR)$(MANDIR)/man8/ rfkill.8.gz
24+ $(Q)$(INSTALL) -m 644 rfkill.8.gz $(DESTDIR)$(MANDIR)/man8/
25
26 clean:
27 $(Q)rm -f rfkill *.o *~ *.gz version.c *-stamp
28--
291.6.6.1
30
diff --git a/meta-oe/recipes-connectivity/rfkill/rfkill/dont.call.git.rev-parse.on.parent.dir.patch b/meta-oe/recipes-connectivity/rfkill/rfkill/dont.call.git.rev-parse.on.parent.dir.patch
new file mode 100644
index 000000000..2b8368912
--- /dev/null
+++ b/meta-oe/recipes-connectivity/rfkill/rfkill/dont.call.git.rev-parse.on.parent.dir.patch
@@ -0,0 +1,31 @@
1When WORKDIR is included in some other git checkout, version.sh calls git rev-parse
2and it returns some description from that upper git checkout even when rfkill is
3being built from release tarball.
4
5When returned description doesn't match with expected v0.4, version.sh exits
6without creating version.c
7 # on git builds check that the version number above
8 # is correct...
9 [ "${descr%%-*}" = "v$VERSION" ] || exit 2
10
11and build fails a bit later:
12 | NOTE: make -j 32 -e MAKEFLAGS=
13 | CC rfkill.o
14 | GEN version.c
15 | make: *** [version.c] Error 2
16 | make: *** Waiting for unfinished jobs....
17 | ERROR: oe_runmake failed
18
19Don't try git rev-parse, if there isn't .git in ${S}.
20
21--- a/version.sh 2013-11-15 03:43:12.587744366 -0800
22+++ b/version.sh 2013-11-15 03:42:40.699743320 -0800
23@@ -12,7 +12,7 @@
24
25 if test "x$SUFFIX" != 'x'; then
26 v="$VERSION$SUFFIX"
27-elif head=`git rev-parse --verify HEAD 2>/dev/null`; then
28+elif test -d .git && head=`git rev-parse --verify HEAD 2>/dev/null`; then
29 git update-index --refresh --unmerged > /dev/null
30 descr=$(git describe 2>/dev/null || echo "v$VERSION")
31
diff --git a/meta-oe/recipes-connectivity/rfkill/rfkill_0.4.bb b/meta-oe/recipes-connectivity/rfkill/rfkill_0.4.bb
new file mode 100644
index 000000000..3b2943c99
--- /dev/null
+++ b/meta-oe/recipes-connectivity/rfkill/rfkill_0.4.bb
@@ -0,0 +1,27 @@
1SUMMARY = "rfkill CLI utility"
2HOMEPAGE = "http://linuxwireless.org/en/users/Documentation/rfkill"
3SECTION = "base"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=c6036d0eb7edbfced28c4160e5d3fa94"
6PR = "r1"
7
8SRC_URI = "http://www.kernel.org/pub/software/network/${BPN}/${BP}.tar.bz2 \
9 file://0001-rfkill-makefile-don-t-use-t-the-OE-install-wrapper-d.patch \
10 file://dont.call.git.rev-parse.on.parent.dir.patch"
11
12SRC_URI[md5sum] = "727892c0fb35c80ee3849fbe89b45350"
13SRC_URI[sha256sum] = "ca10e4827a5f0a36e093aee6ad81b5febf81f8097d7d858889ac51ff364168c1"
14
15do_compile() {
16 oe_runmake
17}
18do_install() {
19 oe_runmake DESTDIR=${D} install
20}
21
22inherit update-alternatives
23
24ALTERNATIVE_${PN} = "rfkill"
25ALTERNATIVE_PRIORITY = "60"
26ALTERNATIVE_LINK_NAME[rfkill] = "${sbindir}/rfkill"
27