diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2011-09-19 13:45:18 +0200 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-09-19 14:05:51 +0200 |
commit | c57a75f1b29ee2a07bfb06478d3cca1a7fce34e6 (patch) | |
tree | a72214ed9098cc13e6bb7f23f2a052caa4b2cece /meta-oe/recipes-connectivity/rfkill | |
parent | 26d7f4f7b076eabbdfc3fe07c27ab77cedbf6563 (diff) | |
download | meta-openembedded-c57a75f1b29ee2a07bfb06478d3cca1a7fce34e6.tar.gz |
rfkill 0.4: import from OE .dev
Diffstat (limited to 'meta-oe/recipes-connectivity/rfkill')
-rw-r--r-- | meta-oe/recipes-connectivity/rfkill/rfkill/0001-rfkill-makefile-don-t-use-t-the-OE-install-wrapper-d.patch | 30 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/rfkill/rfkill_0.4.bb | 18 |
2 files changed, 48 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/rfkill/rfkill/0001-rfkill-makefile-don-t-use-t-the-OE-install-wrapper-d.patch b/meta-oe/recipes-connectivity/rfkill/rfkill/0001-rfkill-makefile-don-t-use-t-the-OE-install-wrapper-d.patch new file mode 100644 index 000000000..c6f60d0ed --- /dev/null +++ b/meta-oe/recipes-connectivity/rfkill/rfkill/0001-rfkill-makefile-don-t-use-t-the-OE-install-wrapper-d.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | From db764080e54f8f998c28ef8dab78da8b8d1d1420 Mon Sep 17 00:00:00 2001 | ||
2 | From: Koen Kooi <koen@dominion.thruhere.net> | ||
3 | Date: Fri, 11 Feb 2011 10:35:40 +0100 | ||
4 | Subject: [PATCH] rfkill makefile: don't use -t, the OE install wrapper dislikes it | ||
5 | |||
6 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | ||
7 | --- | ||
8 | Makefile | 4 ++-- | ||
9 | 1 files changed, 2 insertions(+), 2 deletions(-) | ||
10 | |||
11 | diff --git a/Makefile b/Makefile | ||
12 | index 8d6c700..3652690 100644 | ||
13 | --- a/Makefile | ||
14 | +++ b/Makefile | ||
15 | @@ -53,10 +53,10 @@ check: | ||
16 | install: rfkill rfkill.8.gz | ||
17 | @$(NQ) ' INST rfkill' | ||
18 | $(Q)$(MKDIR) $(DESTDIR)$(SBINDIR) | ||
19 | - $(Q)$(INSTALL) -m 755 -t $(DESTDIR)$(SBINDIR) rfkill | ||
20 | + $(Q)$(INSTALL) -m 755 rfkill $(DESTDIR)$(SBINDIR) | ||
21 | @$(NQ) ' INST rfkill.8' | ||
22 | $(Q)$(MKDIR) $(DESTDIR)$(MANDIR)/man8/ | ||
23 | - $(Q)$(INSTALL) -m 644 -t $(DESTDIR)$(MANDIR)/man8/ rfkill.8.gz | ||
24 | + $(Q)$(INSTALL) -m 644 rfkill.8.gz $(DESTDIR)$(MANDIR)/man8/ | ||
25 | |||
26 | clean: | ||
27 | $(Q)rm -f rfkill *.o *~ *.gz version.c *-stamp | ||
28 | -- | ||
29 | 1.6.6.1 | ||
30 | |||
diff --git a/meta-oe/recipes-connectivity/rfkill/rfkill_0.4.bb b/meta-oe/recipes-connectivity/rfkill/rfkill_0.4.bb new file mode 100644 index 000000000..561fdc7a9 --- /dev/null +++ b/meta-oe/recipes-connectivity/rfkill/rfkill_0.4.bb | |||
@@ -0,0 +1,18 @@ | |||
1 | DESCRIPTION = "rfkill CLI utility" | ||
2 | HOMEPAGE = "http://linuxwireless.org/en/users/Documentation/rfkill" | ||
3 | SECTION = "base" | ||
4 | LICENSE = "BSD" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=c6036d0eb7edbfced28c4160e5d3fa94" | ||
6 | |||
7 | SRC_URI = "http://wireless.kernel.org/download/${PN}/${P}.tar.bz2 \ | ||
8 | file://0001-rfkill-makefile-don-t-use-t-the-OE-install-wrapper-d.patch" | ||
9 | |||
10 | SRC_URI[md5sum] = "727892c0fb35c80ee3849fbe89b45350" | ||
11 | SRC_URI[sha256sum] = "ca10e4827a5f0a36e093aee6ad81b5febf81f8097d7d858889ac51ff364168c1" | ||
12 | |||
13 | do_compile() { | ||
14 | oe_runmake | ||
15 | } | ||
16 | do_install() { | ||
17 | oe_runmake DESTDIR=${D} install | ||
18 | } | ||