summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/ptpd
diff options
context:
space:
mode:
authorZhenhua Luo <b19537@freescale.com>2011-12-21 06:01:43 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-12-22 08:49:16 +0100
commitca8183238a6bea0922f8416444741244cc8d14c7 (patch)
treee93ddb77f6eb4a53a06037067b5c9e6abf805926 /meta-oe/recipes-connectivity/ptpd
parent713b8ac8aaae7b6cd2c97801bc8575323846fee7 (diff)
downloadmeta-openembedded-ca8183238a6bea0922f8416444741244cc8d14c7.tar.gz
ptpd: add version 1.0.0
Precision Time Protocol (PTP) as defined by the IEEE 1588 standard. Signed-off-by: Zhenhua Luo <b19537@freescale.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-connectivity/ptpd')
-rw-r--r--meta-oe/recipes-connectivity/ptpd/ptpd-1.0.0/add-limit-h.patch26
-rw-r--r--meta-oe/recipes-connectivity/ptpd/ptpd_1.0.0.bb20
2 files changed, 46 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/ptpd/ptpd-1.0.0/add-limit-h.patch b/meta-oe/recipes-connectivity/ptpd/ptpd-1.0.0/add-limit-h.patch
new file mode 100644
index 000000000..8ed3f2f97
--- /dev/null
+++ b/meta-oe/recipes-connectivity/ptpd/ptpd-1.0.0/add-limit-h.patch
@@ -0,0 +1,26 @@
1ptpd: fix ftbfs by including limits.h so MAX_INT defined
2
3The current recipe for ptpd fails to build with:
4
5| arith.c: In function 'fromInternalTime':
6| arith.c:46: error: 'INT_MAX' undeclared (first use in this function)
7| arith.c:46: error: (Each undeclared identifier is reported only once
8| arith.c:46: error: for each function it appears in.)
9| arith.c: In function 'toInternalTime':
10| arith.c:64: error: 'INT_MAX' undeclared (first use in this function)
11| make: *** [arith.o] Error 1
12| make: *** Waiting for unfinished jobs....
13| FATAL: oe_runmake failed
14
15diff --git a/src/arith.c b/src/arith.c
16--- a/src/arith.c
17+++ b/src/arith.c
18@@ -1,6 +1,7 @@
19 /* arith.c */
20
21 #include "ptpd.h"
22+#include <limits.h>
23
24 /* from annex C of the spec */
25 UInteger32 crc_algorithm(Octet *buf, Integer16 length)
26
diff --git a/meta-oe/recipes-connectivity/ptpd/ptpd_1.0.0.bb b/meta-oe/recipes-connectivity/ptpd/ptpd_1.0.0.bb
new file mode 100644
index 000000000..08e1b6bab
--- /dev/null
+++ b/meta-oe/recipes-connectivity/ptpd/ptpd_1.0.0.bb
@@ -0,0 +1,20 @@
1DESCRIPTION = "Precision Time Protocol (PTP) as defined by the IEEE 1588 standard"
2HOMEPAGE = "http://sourceforge.net/projects/ptpd"
3SECTION = "network"
4LICENSE = "BSD"
5
6LIC_FILES_CHKSUM = "file://../COPYRIGHT;md5=888bd1b2c9c013b93394b8bfb453c417"
7
8SRC_URI = "http://downloads.sourceforge.net/project/ptpd/ptpd/${PV}/ptpd-${PV}.tar.gz \
9 file://add-limit-h.patch;striplevel=2"
10
11SRC_URI[md5sum] = "b112b2bedc7f6e6e11a838608b9e0357"
12SRC_URI[sha256sum] = "8ac1fdcad1e246b0395097dd9af29966c6823533d7e6989aae91506048fb51bc"
13
14S = "${WORKDIR}/ptpd-${PV}/src"
15
16do_install() {
17 install -d ${D}${bindir} ${D}${mandir}/man8
18 install -m 4555 ptpd ${D}${bindir}
19 install -m 644 ptpd.8 ${D}${mandir}/man8
20}