diff options
author | Wang Mingyu <wangmy@cn.fujitsu.com> | 2020-04-26 11:27:25 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-04-26 23:10:57 -0700 |
commit | b0345e3fe439ebfeea84edaf26c19b056d557400 (patch) | |
tree | 87e33875e8dab96a662ba925d647679a8b1679b2 /meta-oe/recipes-connectivity/paho-mqtt-c | |
parent | 1f35a5af9bc2d6fa5b17c243eaf232bf56a79568 (diff) | |
download | meta-openembedded-b0345e3fe439ebfeea84edaf26c19b056d557400.tar.gz |
paho-mqtt-c: upgrade 1.3.1 -> 1.3.2
add patches for resoving compile error with musl:
0001-Fix-bug-of-free-with-musl.patch
Eclipse Public License : update to v 2.0
-License-Update: updated to 2020.
Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/paho-mqtt-c')
-rw-r--r-- | meta-oe/recipes-connectivity/paho-mqtt-c/files/0001-Fix-bug-of-free-with-musl.patch | 39 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/paho-mqtt-c/paho-mqtt-c_1.3.2.bb (renamed from meta-oe/recipes-connectivity/paho-mqtt-c/paho-mqtt-c_1.3.1.bb) | 15 |
2 files changed, 49 insertions, 5 deletions
diff --git a/meta-oe/recipes-connectivity/paho-mqtt-c/files/0001-Fix-bug-of-free-with-musl.patch b/meta-oe/recipes-connectivity/paho-mqtt-c/files/0001-Fix-bug-of-free-with-musl.patch new file mode 100644 index 000000000..12f9e7abc --- /dev/null +++ b/meta-oe/recipes-connectivity/paho-mqtt-c/files/0001-Fix-bug-of-free-with-musl.patch | |||
@@ -0,0 +1,39 @@ | |||
1 | From 96233a8382b9520293a48b08dc3b204a21205800 Mon Sep 17 00:00:00 2001 | ||
2 | From: Wang Mingyu <wangmy@cn.fujitsu.com> | ||
3 | Date: Fri, 24 Apr 2020 00:53:19 +0900 | ||
4 | Subject: [PATCH] Fix bug of free() with musl | ||
5 | |||
6 | This fixes build error with musl C library: | ||
7 | /ubinux-dev/ubinux001/contribution/build/tmp/work/armv7vet2hf-neon-poky-linux-musleabi/paho-mqtt-c/1.3.2-r0/git/src/Heap.h:55:24: | ||
8 | error: expected declaration specifiers or '...' before string constant | ||
9 | 55 | #define free(x) myfree(__FILE__, __LINE__, x) | ||
10 | | ^~~~~~~~ | ||
11 | /ubinux-dev/ubinux001/contribution/build/tmp/work/armv7vet2hf-neon-poky-linux-musleabi/paho-mqtt-c/1.3.2-r0/git/src/Heap.h:55:34: | ||
12 | error: expected declaration specifiers or '...' before numeric constant | ||
13 | 55 | #define free(x) myfree(__FILE__, __LINE__, x) | ||
14 | | ^~~~~~~~ | ||
15 | |||
16 | Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com> | ||
17 | --- | ||
18 | src/MQTTReasonCodes.c | 2 +- | ||
19 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
20 | |||
21 | diff --git a/src/MQTTReasonCodes.c b/src/MQTTReasonCodes.c | ||
22 | index 416eab5..479dbac 100644 | ||
23 | --- a/src/MQTTReasonCodes.c | ||
24 | +++ b/src/MQTTReasonCodes.c | ||
25 | @@ -16,10 +16,10 @@ | ||
26 | |||
27 | #include "MQTTReasonCodes.h" | ||
28 | |||
29 | -#include "Heap.h" | ||
30 | #include "StackTrace.h" | ||
31 | |||
32 | #include <memory.h> | ||
33 | +#include "Heap.h" | ||
34 | |||
35 | #define ARRAY_SIZE(a) (sizeof(a) / sizeof(a[0])) | ||
36 | |||
37 | -- | ||
38 | 2.17.1 | ||
39 | |||
diff --git a/meta-oe/recipes-connectivity/paho-mqtt-c/paho-mqtt-c_1.3.1.bb b/meta-oe/recipes-connectivity/paho-mqtt-c/paho-mqtt-c_1.3.2.bb index fa249677e..fa8c714ce 100644 --- a/meta-oe/recipes-connectivity/paho-mqtt-c/paho-mqtt-c_1.3.1.bb +++ b/meta-oe/recipes-connectivity/paho-mqtt-c/paho-mqtt-c_1.3.2.bb | |||
@@ -6,14 +6,15 @@ LICENSE = "EPL-1.0 | EDL-1.0" | |||
6 | 6 | ||
7 | LIC_FILES_CHKSUM = " \ | 7 | LIC_FILES_CHKSUM = " \ |
8 | file://edl-v10;md5=3adfcc70f5aeb7a44f3f9b495aa1fbf3 \ | 8 | file://edl-v10;md5=3adfcc70f5aeb7a44f3f9b495aa1fbf3 \ |
9 | file://epl-v10;md5=659c8e92a40b6df1d9e3dccf5ae45a08 \ | 9 | file://epl-v20;md5=d9fc0efef5228704e7f5b37f27192723 \ |
10 | file://notice.html;md5=a00d6f9ab542be7babc2d8b80d5d2a4c \ | 10 | file://notice.html;md5=943f861069889acecebf51dfa24478e2 \ |
11 | file://about.html;md5=dcde438d73cf42393da9d40fabc0c9bc \ | 11 | file://about.html;md5=e5662cbb5f8fd5c9faac526e4077898e \ |
12 | " | 12 | " |
13 | 13 | ||
14 | SRC_URI = "git://github.com/eclipse/paho.mqtt.c;protocol=http" | 14 | SRC_URI = "git://github.com/eclipse/paho.mqtt.c;protocol=http \ |
15 | file://0001-Fix-bug-of-free-with-musl.patch" | ||
15 | 16 | ||
16 | SRCREV = "d34c51214f4172f2e12bb17532c9f44f72a57dd4" | 17 | SRCREV = "fbe39064c4416f879308a8a5390b19d544970789" |
17 | 18 | ||
18 | DEPENDS = "openssl" | 19 | DEPENDS = "openssl" |
19 | 20 | ||
@@ -28,3 +29,7 @@ do_install_append() { | |||
28 | } | 29 | } |
29 | 30 | ||
30 | EXTRA_OECMAKE = "-DPAHO_WITH_SSL=ON" | 31 | EXTRA_OECMAKE = "-DPAHO_WITH_SSL=ON" |
32 | |||
33 | do_configure_prepend_libc-musl() { | ||
34 | sed -i -e "s/SET(LIBS_SYSTEM c dl pthread anl rt)/SET(LIBS_SYSTEM c dl pthread rt)/g" ${S}/src/CMakeLists.txt | ||
35 | } | ||