diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-13 22:49:41 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-15 16:23:17 +0200 |
commit | a45830a39bb47a9eab27980d52966226c9504ea4 (patch) | |
tree | 001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-connectivity/networkmanager | |
parent | 6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff) | |
download | meta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz |
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python
tasks).
* Some recipes were using tabs.
* Some were using 8 spaces.
* Some were using mix or different number of spaces.
* Make them consistently use 4 spaces everywhere.
* Yocto styleguide advises to use tabs (but the only reason to keep
tabs is the need to update a lot of recipes). Lately this advice
was also merged into the styleguide on the OE wiki.
* Using 4 spaces in both types of tasks is better because it's less
error prone when someone is not sure if e.g.
do_generate_toolchain_file() is Python or shell task and also allows
to highlight every tab used in .bb, .inc, .bbappend, .bbclass as
potentially bad (shouldn't be used for indenting of multiline
variable assignments and cannot be used for Python tasks).
* Don't indent closing quote on multiline variables
we're quite inconsistent wheater it's first character on line
under opening quote or under first non-whitespace character in
previous line.
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-connectivity/networkmanager')
-rw-r--r-- | meta-oe/recipes-connectivity/networkmanager/networkmanager_0.9.2.0.bb | 52 |
1 files changed, 26 insertions, 26 deletions
diff --git a/meta-oe/recipes-connectivity/networkmanager/networkmanager_0.9.2.0.bb b/meta-oe/recipes-connectivity/networkmanager/networkmanager_0.9.2.0.bb index cc6abd722..e63955d5d 100644 --- a/meta-oe/recipes-connectivity/networkmanager/networkmanager_0.9.2.0.bb +++ b/meta-oe/recipes-connectivity/networkmanager/networkmanager_0.9.2.0.bb | |||
@@ -23,12 +23,12 @@ SRC_URI[sha256sum] = "a178ed2f0b5a1045ec47b217ea531d0feba9208f6bcfe64b701174a5c1 | |||
23 | S = "${WORKDIR}/NetworkManager-${PV}" | 23 | S = "${WORKDIR}/NetworkManager-${PV}" |
24 | 24 | ||
25 | EXTRA_OECONF = " \ | 25 | EXTRA_OECONF = " \ |
26 | --with-distro=debian \ | 26 | --with-distro=debian \ |
27 | --with-crypto=gnutls \ | 27 | --with-crypto=gnutls \ |
28 | --disable-more-warnings \ | 28 | --disable-more-warnings \ |
29 | --with-dhclient=${base_sbindir}/dhclient \ | 29 | --with-dhclient=${base_sbindir}/dhclient \ |
30 | --with-iptables=${sbindir}/iptables \ | 30 | --with-iptables=${sbindir}/iptables \ |
31 | --with-tests \ | 31 | --with-tests \ |
32 | " | 32 | " |
33 | 33 | ||
34 | EXTRA_OECONF += "${@base_contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_unitdir}/system/', '--without-systemdsystemunitdir', d)}" | 34 | EXTRA_OECONF += "${@base_contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_unitdir}/system/', '--without-systemdsystemunitdir', d)}" |
@@ -42,21 +42,21 @@ do_configure_prepend() { | |||
42 | 42 | ||
43 | # Work around dbus permission problems since we lack a proper at_console | 43 | # Work around dbus permission problems since we lack a proper at_console |
44 | do_install_prepend() { | 44 | do_install_prepend() { |
45 | sed -i -e s:deny:allow:g ${S}/src/NetworkManager.conf | 45 | sed -i -e s:deny:allow:g ${S}/src/NetworkManager.conf |
46 | sed -i -e s:deny:allow:g ${S}/callouts/nm-dispatcher.conf | 46 | sed -i -e s:deny:allow:g ${S}/callouts/nm-dispatcher.conf |
47 | } | 47 | } |
48 | 48 | ||
49 | do_install_append () { | 49 | do_install_append () { |
50 | install -d ${D}/etc/dbus-1/event.d | 50 | install -d ${D}/etc/dbus-1/event.d |
51 | # Additional test binaries | 51 | # Additional test binaries |
52 | install -d ${D}/usr/bin | 52 | install -d ${D}/usr/bin |
53 | install -m 0755 ${S}/test/.libs/libnm* ${D}/usr/bin | 53 | install -m 0755 ${S}/test/.libs/libnm* ${D}/usr/bin |
54 | 54 | ||
55 | install -d ${D}/etc/NetworkManager/ | 55 | install -d ${D}/etc/NetworkManager/ |
56 | 56 | ||
57 | # Install an empty VPN folder as nm-connection-editor will happily segfault without it :o. | 57 | # Install an empty VPN folder as nm-connection-editor will happily segfault without it :o. |
58 | # With or without VPN support built in ;). | 58 | # With or without VPN support built in ;). |
59 | install -d ${D}/etc/NetworkManager/VPN | 59 | install -d ${D}/etc/NetworkManager/VPN |
60 | } | 60 | } |
61 | 61 | ||
62 | PACKAGES =+ "libnmutil libnmglib libnmglib-vpn ${PN}-tests" | 62 | PACKAGES =+ "libnmutil libnmglib libnmglib-vpn ${PN}-tests" |
@@ -66,23 +66,23 @@ FILES_libnmglib += "${libdir}/libnm_glib.so.*" | |||
66 | FILES_libnmglib-vpn += "${libdir}/libnm_glib_vpn.so.*" | 66 | FILES_libnmglib-vpn += "${libdir}/libnm_glib_vpn.so.*" |
67 | 67 | ||
68 | FILES_${PN} += " \ | 68 | FILES_${PN} += " \ |
69 | ${libexecdir} \ | 69 | ${libexecdir} \ |
70 | ${libdir}/pppd/*/nm-pppd-plugin.so \ | 70 | ${libdir}/pppd/*/nm-pppd-plugin.so \ |
71 | ${libdir}/NetworkManager/*.so \ | 71 | ${libdir}/NetworkManager/*.so \ |
72 | ${datadir}/polkit-1 \ | 72 | ${datadir}/polkit-1 \ |
73 | ${datadir}/dbus-1 \ | 73 | ${datadir}/dbus-1 \ |
74 | ${base_libdir}/udev/* \ | 74 | ${base_libdir}/udev/* \ |
75 | ${systemd_unitdir}/system/NetworkManager-wait-online.service \ | 75 | ${systemd_unitdir}/system/NetworkManager-wait-online.service \ |
76 | " | 76 | " |
77 | 77 | ||
78 | RRECOMMENDS_${PN} += "iptables" | 78 | RRECOMMENDS_${PN} += "iptables" |
79 | RCONFLICTS_${PN} = "connman" | 79 | RCONFLICTS_${PN} = "connman" |
80 | RDEPENDS_${PN} = "wpa-supplicant dhcp-client \ | 80 | RDEPENDS_${PN} = "wpa-supplicant dhcp-client \ |
81 | ${@base_contains('COMBINED_FEATURES', '3gmodem', 'ppp', '', d)} \ | 81 | ${@base_contains('COMBINED_FEATURES', '3gmodem', 'ppp', '', d)} \ |
82 | " | 82 | " |
83 | 83 | ||
84 | FILES_${PN}-dbg += "${libdir}/NetworkManager/.debug/ \ | 84 | FILES_${PN}-dbg += "${libdir}/NetworkManager/.debug/ \ |
85 | ${libdir}/pppd/*/.debug/ " | 85 | ${libdir}/pppd/*/.debug/ " |
86 | 86 | ||
87 | FILES_${PN}-dev += "${datadir}/NetworkManager/gdb-cmd \ | 87 | FILES_${PN}-dev += "${datadir}/NetworkManager/gdb-cmd \ |
88 | ${libdir}/pppd/*/*.la \ | 88 | ${libdir}/pppd/*/*.la \ |