summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/networkmanager/networkmanager_0.9.8.0.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2013-04-25 16:16:01 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-27 11:49:47 +0200
commit597fe7945b250dd05b3435744c55c4213909a179 (patch)
tree43c129d713f00ab23f7685bc9f6f4071bad896ec /meta-oe/recipes-connectivity/networkmanager/networkmanager_0.9.8.0.bb
parent452d98eb26b798e25be8c49f1a1f798f43da5284 (diff)
downloadmeta-openembedded-597fe7945b250dd05b3435744c55c4213909a179.tar.gz
networkmanager: update to 0.9.8.0
run tested for eth0 / hidden WLAN on overo Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/networkmanager/networkmanager_0.9.8.0.bb')
-rw-r--r--meta-oe/recipes-connectivity/networkmanager/networkmanager_0.9.8.0.bb100
1 files changed, 100 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/networkmanager/networkmanager_0.9.8.0.bb b/meta-oe/recipes-connectivity/networkmanager/networkmanager_0.9.8.0.bb
new file mode 100644
index 000000000..5b53f7f18
--- /dev/null
+++ b/meta-oe/recipes-connectivity/networkmanager/networkmanager_0.9.8.0.bb
@@ -0,0 +1,100 @@
1DESCRIPTION = "NetworkManager"
2SECTION = "net/misc"
3
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=cbbffd568227ada506640fe950a4823b"
6
7DEPENDS = "libnl dbus dbus-glib udev wireless-tools polkit gnutls util-linux ppp"
8DEPENDS += "${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
9
10inherit gnome gettext systemd
11
12SRC_URI = " \
13 ${GNOME_MIRROR}/NetworkManager/${@gnome_verdir("${PV}")}/NetworkManager-${PV}.tar.xz \
14 file://0001-don-t-try-to-run-sbin-dhclient-to-get-the-version-nu.patch \
15 file://0002-NetworkManager.service-remove-reference-to-NetworkMa.patch \
16"
17SRC_URI[md5sum] = "38d28f6bd9220d85dfff47210706195c"
18SRC_URI[sha256sum] = "c366bcded6354d8186ad93c05d26d6a20bc550aa0391f974704e7a60e9f6096b"
19
20
21S = "${WORKDIR}/NetworkManager-${PV}"
22
23EXTRA_OECONF = " \
24 --enable-ifupdown \
25 --disable-ifcfg-rh \
26 --disable-ifnet \
27 --disable-ifcfg-suse \
28 --with-netconfig \
29 --with-crypto=gnutls \
30 --disable-more-warnings \
31 --with-dhclient=${base_sbindir}/dhclient \
32 --with-iptables=${sbindir}/iptables \
33 --with-tests \
34"
35
36EXTRA_OECONF += "${@base_contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_unitdir}/system/', '--without-systemdsystemunitdir', d)}"
37
38# Work around dbus permission problems since we lack a proper at_console
39do_install_prepend() {
40 sed -i 's:deny send_destination:allow send_destination:g' ${S}/src/org.freedesktop.NetworkManager.conf
41 sed -i 's:deny send_destination:allow send_destination:g' ${S}/callouts/nm-dispatcher.conf
42 sed -i 's:deny send_destination:allow send_destination:g' ${S}/callouts/nm-dhcp-client.conf
43 sed -i 's:deny send_destination:allow send_destination:g' ${S}/callouts/nm-avahi-autoipd.conf
44}
45
46do_install_append () {
47 install -d ${D}/etc/dbus-1/event.d
48 # Additional test binaries
49 install -d ${D}/usr/bin
50 install -m 0755 ${S}/test/.libs/libnm* ${D}/usr/bin
51
52 # Install an empty VPN folder as nm-connection-editor will happily segfault without it :o.
53 # With or without VPN support built in ;).
54 install -d ${D}/etc/NetworkManager/VPN
55}
56
57PACKAGES =+ "libnmutil libnmglib libnmglib-vpn ${PN}-tests ${PN}-bash-completion"
58
59FILES_libnmutil += "${libdir}/libnm-util.so.*"
60FILES_libnmglib += "${libdir}/libnm-glib.so.*"
61FILES_libnmglib-vpn += "${libdir}/libnm-glib-vpn.so.*"
62
63FILES_${PN} += " \
64 ${libexecdir} \
65 ${libdir}/pppd/*/nm-pppd-plugin.so \
66 ${libdir}/NetworkManager/*.so \
67 ${datadir}/polkit-1 \
68 ${datadir}/dbus-1 \
69 ${base_libdir}/udev/* \
70 ${systemd_unitdir}/system/NetworkManager-wait-online.service \
71"
72
73RRECOMMENDS_${PN} += "iptables"
74RCONFLICTS_${PN} = "connman"
75RDEPENDS_${PN} = " \
76 wpa-supplicant \
77 dhcp-client \
78 ${@base_contains('COMBINED_FEATURES', '3gmodem', 'ppp', '', d)} \
79"
80
81FILES_${PN}-dbg += " \
82 ${libdir}/NetworkManager/.debug/ \
83 ${libdir}/pppd/*/.debug/ \
84"
85
86FILES_${PN}-dev += " \
87 ${datadir}/NetworkManager/gdb-cmd \
88 ${libdir}/pppd/*/*.la \
89 ${libdir}/NetworkManager/*.la \
90"
91
92FILES_${PN}-tests = " \
93 ${bindir}/nm-tool \
94 ${bindir}/libnm-glib-test \
95 ${bindir}/nm-online \
96"
97
98FILES_${PN}-bash-completion = "${datadir}/bash-completion"
99
100SYSTEMD_SERVICE_${PN} = "NetworkManager.service"