summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/linuxptp
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2014-04-01 00:47:51 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2014-04-20 11:03:24 +0200
commitccb88f65709eb2db27e1f41241707ddd1fccd359 (patch)
tree07ef9ca49c6bc12cf6cd8e25d6fecd9d5109fde9 /meta-oe/recipes-connectivity/linuxptp
parent49cb8758eb9c610364ad4e0f13d31d10fc48899f (diff)
downloadmeta-openembedded-ccb88f65709eb2db27e1f41241707ddd1fccd359.tar.gz
linuxptp: fix and simplify recipe, drop dependency on kernel
* Build script tries to locate the correct /usr/include/linux/net_tstamp.h just to see if it contains definition for HWTSTAMP_TX_ONESTEP_SYNC. But that header file hasn't changed in at least 5 years. The result of the check is to pass additional defines to the build, which can be passed via EXTRA_OEMAKE. * The sed command on makefile wasn't even working, plus there's no AR, prefix is not used and better way is to use EXTRA_CFLAGS and EXTRA_LDFLAGS anyway. * Neither autotools nor pkgconfig are use during the build, don't inherit them. Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/linuxptp')
-rw-r--r--meta-oe/recipes-connectivity/linuxptp/linuxptp_1.4.bb11
1 files changed, 2 insertions, 9 deletions
diff --git a/meta-oe/recipes-connectivity/linuxptp/linuxptp_1.4.bb b/meta-oe/recipes-connectivity/linuxptp/linuxptp_1.4.bb
index c708b13f3..10d674405 100644
--- a/meta-oe/recipes-connectivity/linuxptp/linuxptp_1.4.bb
+++ b/meta-oe/recipes-connectivity/linuxptp/linuxptp_1.4.bb
@@ -2,20 +2,13 @@ DESCRIPTION = "Precision Time Protocol (PTP) according to IEEE standard 1588 for
2LICENSE = "GPLv2" 2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" 3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4 4
5DEPENDS = "virtual/kernel"
6
7SRC_URI = "http://sourceforge.net/projects/linuxptp/files/v${PV}/linuxptp-${PV}.tgz" 5SRC_URI = "http://sourceforge.net/projects/linuxptp/files/v${PV}/linuxptp-${PV}.tgz"
8 6
9SRC_URI[md5sum] = "a37ad2b2ef7d1ebc4d64a66d3fe55cdf" 7SRC_URI[md5sum] = "a37ad2b2ef7d1ebc4d64a66d3fe55cdf"
10SRC_URI[sha256sum] = "6cfd5291fb7394cc9f25458927874a203971b66b76d1c9d6568e007d0cbd81f2" 8SRC_URI[sha256sum] = "6cfd5291fb7394cc9f25458927874a203971b66b76d1c9d6568e007d0cbd81f2"
11 9
12inherit autotools pkgconfig 10EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} ARCH=${TARGET_ARCH} \
13 11 EXTRA_CFLAGS='-D_GNU_SOURCE -DHAVE_CLOCK_ADJTIME -DHAVE_ONESTEP_SYNC'"
14EXTRA_OEMAKE = 'KBUILD_OUTPUT="${STAGING_KERNEL_DIR}" CROSS_COMPILE="${TARGET_PREFIX}"'
15
16do_configure_append () {
17 find ${S} -name makefile | xargs sed -i 's,^\(CC\|CFLAGS\|prefix\|AR\)=,\1 ?=,g'
18}
19 12
20do_install () { 13do_install () {
21 install -d ${D}/${bindir} 14 install -d ${D}/${bindir}