summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/linuxptp
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-connectivity/linuxptp
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/linuxptp')
-rw-r--r--meta-oe/recipes-connectivity/linuxptp/linuxptp/build-Allow-CC-and-prefix-to-be-overriden.patch37
-rw-r--r--meta-oe/recipes-connectivity/linuxptp/linuxptp_1.4.bb20
2 files changed, 57 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/linuxptp/linuxptp/build-Allow-CC-and-prefix-to-be-overriden.patch b/meta-oe/recipes-connectivity/linuxptp/linuxptp/build-Allow-CC-and-prefix-to-be-overriden.patch
new file mode 100644
index 000000000..b1d96ae5a
--- /dev/null
+++ b/meta-oe/recipes-connectivity/linuxptp/linuxptp/build-Allow-CC-and-prefix-to-be-overriden.patch
@@ -0,0 +1,37 @@
1From af485c638c61fa883212ea424e676fbf90bee594 Mon Sep 17 00:00:00 2001
2From: Otavio Salvador <otavio@ossystems.com.br>
3Date: Tue, 1 Jul 2014 17:37:31 -0300
4Subject: [PATCH] build: Allow CC and prefix to be overriden
5
6Upstream-Status: Pending
7
8Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
9---
10 makefile | 4 ++--
11 1 file changed, 2 insertions(+), 2 deletions(-)
12
13diff --git a/makefile b/makefile
14index 22e7d0d..809cc8f 100644
15--- a/makefile
16+++ b/makefile
17@@ -18,7 +18,7 @@
18 KBUILD_OUTPUT =
19
20 DEBUG =
21-CC = $(CROSS_COMPILE)gcc
22+CC ?= $(CROSS_COMPILE)gcc
23 VER = -DVER=$(version)
24 CFLAGS = -Wall $(VER) $(incdefs) $(DEBUG) $(EXTRA_CFLAGS)
25 LDLIBS = -lm -lrt $(EXTRA_LDFLAGS)
26@@ -35,7 +35,7 @@ incdefs := $(shell $(srcdir)/incdefs.sh)
27 version := $(shell $(srcdir)/version.sh $(srcdir))
28 VPATH = $(srcdir)
29
30-prefix = /usr/local
31+prefix ?= /usr/local
32 sbindir = $(prefix)/sbin
33 mandir = $(prefix)/man
34 man8dir = $(mandir)/man8
35--
361.7.10.4
37
diff --git a/meta-oe/recipes-connectivity/linuxptp/linuxptp_1.4.bb b/meta-oe/recipes-connectivity/linuxptp/linuxptp_1.4.bb
new file mode 100644
index 000000000..4ee0c8873
--- /dev/null
+++ b/meta-oe/recipes-connectivity/linuxptp/linuxptp_1.4.bb
@@ -0,0 +1,20 @@
1DESCRIPTION = "Precision Time Protocol (PTP) according to IEEE standard 1588 for Linux"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5SRC_URI = "http://sourceforge.net/projects/linuxptp/files/v${PV}/linuxptp-${PV}.tgz \
6 file://build-Allow-CC-and-prefix-to-be-overriden.patch"
7
8SRC_URI[md5sum] = "a37ad2b2ef7d1ebc4d64a66d3fe55cdf"
9SRC_URI[sha256sum] = "6cfd5291fb7394cc9f25458927874a203971b66b76d1c9d6568e007d0cbd81f2"
10
11EXTRA_OEMAKE = "ARCH=${TARGET_ARCH} \
12 EXTRA_CFLAGS='-D_GNU_SOURCE -DHAVE_CLOCK_ADJTIME -DHAVE_ONESTEP_SYNC ${CFLAGS}'"
13
14do_install () {
15 install -d ${D}/${bindir}
16 install -p ${S}/ptp4l ${D}/${bindir}
17 install -p ${S}/pmc ${D}/${bindir}
18 install -p ${S}/phc2sys ${D}/${bindir}
19 install -p ${S}/hwstamp_ctl ${D}/${bindir}
20}