diff options
author | Michael Lippautz <michael.lippautz@gmail.com> | 2011-04-20 16:57:29 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-04-20 11:12:53 +0200 |
commit | d8c4045ee190066e6fa8490bfddec6c4ca1b8c6a (patch) | |
tree | 14baec5fe345d4837d9d792363220432bfc64c97 /meta-oe/recipes-connectivity/libnet | |
parent | 358c5d0f0f35f87e51d7a2356b161f09824e16a8 (diff) | |
download | meta-openembedded-d8c4045ee190066e6fa8490bfddec6c4ca1b8c6a.tar.gz |
libnet: Clean and upgrade (see below)
* libbnet upstream on packetfactor is dead
using https://github.com/sam-github/libnet instead
* Move to version 1.1.5
* Dropped patches (not needed): support-uclibc, new-autotools
* Added LIC_FILES_CHKSUM
* Removed useless do_install_append, works automatically
* Not building statically anymore
* Should be compatible with old v1.1 versions
Signed-off-by: Michael Lippautz <michael.lippautz@gmail.com>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-connectivity/libnet')
-rw-r--r-- | meta-oe/recipes-connectivity/libnet/libnet-1.1.5/fix-endianess-test.patch | 38 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/libnet/libnet_1.1.5.bb | 24 |
2 files changed, 62 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/libnet/libnet-1.1.5/fix-endianess-test.patch b/meta-oe/recipes-connectivity/libnet/libnet-1.1.5/fix-endianess-test.patch new file mode 100644 index 000000000..4d8697d5f --- /dev/null +++ b/meta-oe/recipes-connectivity/libnet/libnet-1.1.5/fix-endianess-test.patch | |||
@@ -0,0 +1,38 @@ | |||
1 | Use autoconf's endian check instead of the locally defined check | ||
2 | so that we can determine the endianess without having to compile | ||
3 | a program. | ||
4 | |||
5 | Idea from http://www.security-lists.org/lists/libnet/2003/03/00001.html | ||
6 | |||
7 | Also remove the old test from aclocal.m4. | ||
8 | |||
9 | Rebased for libnet-1.1.5 on 2011/04/19. | ||
10 | |||
11 | --- a/configure.in 2010-11-03 00:59:21.000000000 +0100 | ||
12 | +++ b/configure.in 2011-04-19 17:08:47.087712604 +0200 | ||
13 | @@ -6,6 +6,7 @@ | ||
14 | dnl | ||
15 | dnl Process this file with autoconf to produce a configure script. | ||
16 | |||
17 | +AC_PREREQ(2.52) | ||
18 | AC_INIT(libnet, 1.1.5) | ||
19 | AC_MSG_RESULT(beginning autoconfiguration process for libnet-${PACKAGE_VERSION} ...) | ||
20 | AC_CANONICAL_SYSTEM | ||
21 | @@ -39,7 +40,16 @@ | ||
22 | dnl And some custom things | ||
23 | dnl | ||
24 | |||
25 | -AC_LIBNET_ENDIAN_CHECK | ||
26 | +AC_C_BIGENDIAN([ | ||
27 | + AC_DEFINE(LIBNET_BIG_ENDIAN) | ||
28 | + ENDIANESS="LIBNET_BIG_ENDIAN" | ||
29 | + LIBNET_CONFIG_DEFINES="$LIBNET_CONFIG_DEFINES -DLIBNET_BIG_ENDIAN" | ||
30 | +],[ | ||
31 | + AC_DEFINE(LIBNET_LIL_ENDIAN) | ||
32 | + ENDIANESS="LIBNET_LIL_ENDIAN" | ||
33 | + LIBNET_CONFIG_DEFINES="$LIBNET_CONFIG_DEFINES -DLIBNET_LIL_ENDIAN" | ||
34 | +], AC_MSG_WARN(cannot detect endianess. try setting ac_cv_c_bigendian to yes or no)) | ||
35 | + | ||
36 | dnl AC_LBL_LIBRARY_NET | ||
37 | |||
38 | AC_SUBST(ENDIANESS) | ||
diff --git a/meta-oe/recipes-connectivity/libnet/libnet_1.1.5.bb b/meta-oe/recipes-connectivity/libnet/libnet_1.1.5.bb new file mode 100644 index 000000000..ec426a552 --- /dev/null +++ b/meta-oe/recipes-connectivity/libnet/libnet_1.1.5.bb | |||
@@ -0,0 +1,24 @@ | |||
1 | DESCRIPTION = "A packet dissection and creation library" | ||
2 | # libnet at packetfactory.net is dead | ||
3 | HOMEPAGE = "https://github.com/sam-github/libnet" | ||
4 | SECTION = "libs" | ||
5 | LICENSE = "BSD" | ||
6 | LIC_FILES_CHKSUM = "file://README;md5=533bea47338d490e86744c6a0c5692e7" | ||
7 | DEPENDS = "libpcap" | ||
8 | # There are major API changes beween libnet v1.0 and libnet v1.1 | ||
9 | PROVIDES = "libnet-1.1" | ||
10 | PR = "r0" | ||
11 | |||
12 | SRC_URI = "${SOURCEFORGE_MIRROR}/libnet-dev/${PN}-${PV}.tar.gz \ | ||
13 | file://fix-endianess-test.patch" | ||
14 | |||
15 | SRC_URI[md5sum] = "a9bc1d75a610efcfee200d3e28d8eb8f" | ||
16 | SRC_URI[sha256sum] = "75588f8d1232e1df34eccf2dba5e66be197b345a07fae80d8275db994496a20d" | ||
17 | |||
18 | S = "${WORKDIR}/${PN}-${PV}" | ||
19 | |||
20 | inherit autotools binconfig | ||
21 | |||
22 | do_configure_prepend() { | ||
23 | rm -f aclocal.m4 Makefile.am ltmain.sh | ||
24 | } | ||