summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/libimobiledevice
diff options
context:
space:
mode:
authorS. Lockwood-Childs <sjl@vctlabs.com>2015-07-17 17:38:12 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2015-07-30 21:23:42 +0200
commit15f783cc65bdbe1c8a65384fd16b1f31be199754 (patch)
treeb7328248e9584d64ab8dd6c93f05ac758f55a60c /meta-oe/recipes-connectivity/libimobiledevice
parent0b1c142fe30259718e003d2077ddd6c5691b2f49 (diff)
downloadmeta-openembedded-15f783cc65bdbe1c8a65384fd16b1f31be199754.tar.gz
libimobiledevice: remove runtime configure check
configure.ac had a runtime check for large file support that got run on 64-bit architectures, and all runtime checks must go away to be cross-compile safe. Luckily that runtime check was extraneous, so just remove it; standard AC_SYS_LARGEFILE macro should be sufficient for figuring out proper settings to get large file support. Also un-blacklist libimobiledevice, since this problem was the reason for the blacklist. Signed-off-by: S. Lockwood-Childs <sjl@vctlabs.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/libimobiledevice')
-rw-r--r--meta-oe/recipes-connectivity/libimobiledevice/files/configure-fix-largefile.patch38
-rw-r--r--meta-oe/recipes-connectivity/libimobiledevice/libimobiledevice_1.1.4.bb6
2 files changed, 39 insertions, 5 deletions
diff --git a/meta-oe/recipes-connectivity/libimobiledevice/files/configure-fix-largefile.patch b/meta-oe/recipes-connectivity/libimobiledevice/files/configure-fix-largefile.patch
new file mode 100644
index 000000000..679a8b597
--- /dev/null
+++ b/meta-oe/recipes-connectivity/libimobiledevice/files/configure-fix-largefile.patch
@@ -0,0 +1,38 @@
1Fix configure error in large file checks on 64-bit architectures
2
3 configure:17888: checking for native large file support
4 configure:17891: error: in `/home/jenkins/oe/shr-core-branches/shr-core/tmp-eglibc/work/core2-64-oe-linux/libimobiledevice/1.1.4-r0/libimobiledevice-1.1.4':
5 configure:17893: error: cannot run test program while cross compiling
6
7configure.ac was using AC_SYS_LARGEFILE macro as is typical, but then
8there was an extra runtime check added beyond that:
9check if off_t is 8 bytes (64 bits) long.
10If that runtime check passed, _FILE_OFFSET_BITS was defined as 64.
11
12Runtime checks need to go away for cross compiling, and luckily this extra
13check was not serving any useful purpose. Note that off_t was *already*
1464 bits, *without* setting _FILE_OFFSET_BITS, which makes _FILE_OFFSET_BITS
15unneeded for large file support.
16
17If AC_SYS_LARGEFILE macro sets ac_cv_sys_file_offset_bits=no,
18just leave _FILE_OFFSET_BITS undefined!
19
20--- libimobiledevice-1.1.4/configure.ac.old 2015-07-15 01:38:50.900143927 -0700
21+++ libimobiledevice-1.1.4/configure.ac 2015-07-15 01:39:13.300144430 -0700
22@@ -174,16 +174,6 @@
23 if test "$enable_largefile" != no; then
24 if test "$ac_cv_sys_file_offset_bits" != 'no'; then
25 LFS_CFLAGS="$LFS_CFLAGS -D_FILE_OFFSET_BITS=$ac_cv_sys_file_offset_bits"
26- else
27- AC_MSG_CHECKING(for native large file support)
28- AC_RUN_IFELSE([AC_LANG_SOURCE([#include <unistd.h>
29- int main (int argc, char **argv)
30- {
31- exit(!(sizeof(off_t) == 8));
32- }])],
33- [ac_cv_sys_file_offset_bits=64; AC_DEFINE(_FILE_OFFSET_BITS,64)
34- AC_MSG_RESULT(yes)],
35- [AC_MSG_RESULT(no)])
36 fi
37 if test "$ac_cv_sys_large_files" != 'no'; then
38 LFS_CFLAGS="$LFS_CFLAGS -D_LARGE_FILES=1"
diff --git a/meta-oe/recipes-connectivity/libimobiledevice/libimobiledevice_1.1.4.bb b/meta-oe/recipes-connectivity/libimobiledevice/libimobiledevice_1.1.4.bb
index 5256ce0d2..06260f75c 100644
--- a/meta-oe/recipes-connectivity/libimobiledevice/libimobiledevice_1.1.4.bb
+++ b/meta-oe/recipes-connectivity/libimobiledevice/libimobiledevice_1.1.4.bb
@@ -5,17 +5,13 @@ LIC_FILES_CHKSUM = "\
5 file://COPYING.LESSER;md5=6ab17b41640564434dda85c06b7124f7 \ 5 file://COPYING.LESSER;md5=6ab17b41640564434dda85c06b7124f7 \
6" 6"
7 7
8#| configure:17888: checking for native large file support
9#| configure:17891: error: in `/home/jenkins/oe/shr-core-branches/shr-core/tmp-eglibc/work/core2-64-oe-linux/libimobiledevice/1.1.4-r0/libimobiledevice-1.1.4':
10#| configure:17893: error: cannot run test program while cross compiling
11PNBLACKLIST[libimobiledevice] ?= "cannot run test program while cross compiling"
12
13HOMEPAGE ="http://www.libimobiledevice.org/" 8HOMEPAGE ="http://www.libimobiledevice.org/"
14 9
15DEPENDS = "libplist usbmuxd libtasn1 gnutls libgcrypt" 10DEPENDS = "libplist usbmuxd libtasn1 gnutls libgcrypt"
16 11
17SRC_URI = " \ 12SRC_URI = " \
18 http://www.libimobiledevice.org/downloads/libimobiledevice-${PV}.tar.bz2 \ 13 http://www.libimobiledevice.org/downloads/libimobiledevice-${PV}.tar.bz2 \
14 file://configure-fix-largefile.patch \
19" 15"
20 16
21SRC_URI[md5sum] = "3f28cbc6a2e30d34685049c0abde5183" 17SRC_URI[md5sum] = "3f28cbc6a2e30d34685049c0abde5183"