summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/iw
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-07-01 12:08:45 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-07-01 12:08:45 +0200
commitf30f89fb8ac61f80b2200f3ed874919a1f850a3f (patch)
tree03ec3e9a09fa36d04463163fa6b5370404044cba /meta-oe/recipes-connectivity/iw
parent8a917caaa5506fa0f875202243658a1c2fe60c40 (diff)
downloadmeta-openembedded-f30f89fb8ac61f80b2200f3ed874919a1f850a3f.tar.gz
iw: add 0.9.20
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-connectivity/iw')
-rw-r--r--meta-oe/recipes-connectivity/iw/iw/kill-git-version-check.patch26
-rw-r--r--meta-oe/recipes-connectivity/iw/iw_0.9.20.bb26
2 files changed, 52 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/iw/iw/kill-git-version-check.patch b/meta-oe/recipes-connectivity/iw/iw/kill-git-version-check.patch
new file mode 100644
index 000000000..93aad026e
--- /dev/null
+++ b/meta-oe/recipes-connectivity/iw/iw/kill-git-version-check.patch
@@ -0,0 +1,26 @@
1Index: iw-0.9.18/version.sh
2===================================================================
3--- iw-0.9.18.orig/version.sh 2010-09-14 13:50:27.000000000 +0400
4+++ iw-0.9.18/version.sh 2010-09-14 13:50:40.000000000 +0400
5@@ -5,20 +5,6 @@
6
7 echo '#include "iw.h"' > "$OUT"
8
9-if head=`git rev-parse --verify HEAD 2>/dev/null`; then
10- git update-index --refresh --unmerged > /dev/null
11- descr=$(git describe)
12-
13- # on git builds check that the version number above
14- # is correct...
15- [ "${descr%%-*}" = "v$VERSION" ] || exit 2
16-
17- v="${descr#v}"
18- if git diff-index --name-only HEAD | read dummy ; then
19- v="$v"-dirty
20- fi
21-else
22- v="$VERSION"
23-fi
24+v="$VERSION"
25
26 echo "const char iw_version[] = \"$v\";" >> "$OUT"
diff --git a/meta-oe/recipes-connectivity/iw/iw_0.9.20.bb b/meta-oe/recipes-connectivity/iw/iw_0.9.20.bb
new file mode 100644
index 000000000..3e1b09b38
--- /dev/null
+++ b/meta-oe/recipes-connectivity/iw/iw_0.9.20.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "nl80211 based CLI configuration utility for wireless devices"
2HOMEPAGE = "http://linuxwireless.org/en/users/Documentation/iw"
3SECTION = "base"
4PRIORITY = "optional"
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://COPYING;md5=878618a5c4af25e9b93ef0be1a93f774"
7
8DEPENDS = "libnl pkgconfig"
9
10SRC_URI = " \
11 http://wireless.kernel.org/download/iw/${P}.tar.bz2 \
12 file://kill-git-version-check.patch \
13 "
14
15SRC_URI[md5sum] = "1055799b544b3e08169d155bb6c21bb0"
16SRC_URI[sha256sum] = "2d665fbfbe4fd6a40159fb821518fc5337da37448416405b936a393a14cbc7d3"
17
18CFLAGS += "-DCONFIG_LIBNL20"
19
20do_compile() {
21 oe_runmake
22}
23
24do_install() {
25 oe_runmake DESTDIR=${D} install
26}