diff options
author | Peter Kjellerstedt <pkj@axis.com> | 2024-05-30 01:13:47 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-05-30 08:42:03 -0700 |
commit | ad437d52372e6a5aa3631434a79d9a8605ee7ba9 (patch) | |
tree | 483708a84d251c9a38beba50958508276d9ea39c /meta-oe/recipes-connectivity/hostapd | |
parent | 5cf3766cf6395d4bfa5de20cf7427950ca498eaa (diff) | |
download | meta-openembedded-ad437d52372e6a5aa3631434a79d9a8605ee7ba9.tar.gz |
hostapd: Support running "devtool modify hostapd"
For "devtool modify" to work correctly, ${B} needs to match ${S}.
Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/hostapd')
-rw-r--r-- | meta-oe/recipes-connectivity/hostapd/hostapd_2.10.bb | 13 |
1 files changed, 5 insertions, 8 deletions
diff --git a/meta-oe/recipes-connectivity/hostapd/hostapd_2.10.bb b/meta-oe/recipes-connectivity/hostapd/hostapd_2.10.bb index e547462bb..6eca853e4 100644 --- a/meta-oe/recipes-connectivity/hostapd/hostapd_2.10.bb +++ b/meta-oe/recipes-connectivity/hostapd/hostapd_2.10.bb | |||
@@ -16,9 +16,6 @@ SRC_URI = " \ | |||
16 | 16 | ||
17 | SRC_URI[sha256sum] = "206e7c799b678572c2e3d12030238784bc4a9f82323b0156b4c9466f1498915d" | 17 | SRC_URI[sha256sum] = "206e7c799b678572c2e3d12030238784bc4a9f82323b0156b4c9466f1498915d" |
18 | 18 | ||
19 | S = "${WORKDIR}/hostapd-${PV}" | ||
20 | B = "${WORKDIR}/hostapd-${PV}/hostapd" | ||
21 | |||
22 | inherit update-rc.d systemd pkgconfig features_check | 19 | inherit update-rc.d systemd pkgconfig features_check |
23 | 20 | ||
24 | CONFLICT_DISTRO_FEATURES = "openssl-no-weak-ciphers" | 21 | CONFLICT_DISTRO_FEATURES = "openssl-no-weak-ciphers" |
@@ -29,20 +26,20 @@ SYSTEMD_SERVICE:${PN} = "hostapd.service" | |||
29 | SYSTEMD_AUTO_ENABLE:${PN} = "disable" | 26 | SYSTEMD_AUTO_ENABLE:${PN} = "disable" |
30 | 27 | ||
31 | do_configure:append() { | 28 | do_configure:append() { |
32 | install -m 0644 ${UNPACKDIR}/defconfig ${B}/.config | 29 | install -m 0644 ${UNPACKDIR}/defconfig ${B}/hostapd/.config |
33 | } | 30 | } |
34 | 31 | ||
35 | do_compile() { | 32 | do_compile() { |
36 | export CFLAGS="-MMD -O2 -Wall -g" | 33 | export CFLAGS="-MMD -O2 -Wall -g" |
37 | export EXTRA_CFLAGS="${CFLAGS}" | 34 | export EXTRA_CFLAGS="${CFLAGS}" |
38 | make V=1 | 35 | make -C hostapd V=1 |
39 | } | 36 | } |
40 | 37 | ||
41 | do_install() { | 38 | do_install() { |
42 | install -d ${D}${sbindir} ${D}${sysconfdir}/init.d ${D}${systemd_unitdir}/system/ | 39 | install -d ${D}${sbindir} ${D}${sysconfdir}/init.d ${D}${systemd_unitdir}/system/ |
43 | install -m 0644 ${B}/hostapd.conf ${D}${sysconfdir} | 40 | install -m 0644 ${B}/hostapd/hostapd.conf ${D}${sysconfdir} |
44 | install -m 0755 ${B}/hostapd ${D}${sbindir} | 41 | install -m 0755 ${B}/hostapd/hostapd ${D}${sbindir} |
45 | install -m 0755 ${B}/hostapd_cli ${D}${sbindir} | 42 | install -m 0755 ${B}/hostapd/hostapd_cli ${D}${sbindir} |
46 | install -m 755 ${UNPACKDIR}/init ${D}${sysconfdir}/init.d/hostapd | 43 | install -m 755 ${UNPACKDIR}/init ${D}${sysconfdir}/init.d/hostapd |
47 | install -m 0644 ${UNPACKDIR}/hostapd.service ${D}${systemd_unitdir}/system/ | 44 | install -m 0644 ${UNPACKDIR}/hostapd.service ${D}${systemd_unitdir}/system/ |
48 | sed -i -e 's,@SBINDIR@,${sbindir},g' -e 's,@SYSCONFDIR@,${sysconfdir},g' ${D}${systemd_unitdir}/system/hostapd.service | 45 | sed -i -e 's,@SBINDIR@,${sbindir},g' -e 's,@SYSCONFDIR@,${sysconfdir},g' ${D}${systemd_unitdir}/system/hostapd.service |