summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/gateone
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-11-02 10:01:17 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-11-02 12:59:52 +0100
commite2b5b7e2464c4ffe4b3c11a222d0760baad809dd (patch)
treee383877067757ff7e4f3a245e5502fa17d6a262b /meta-oe/recipes-connectivity/gateone
parent409d1973152d4b75146d0ff58b1857a12e500cf7 (diff)
downloadmeta-openembedded-e2b5b7e2464c4ffe4b3c11a222d0760baad809dd.tar.gz
gateone: add git version
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-connectivity/gateone')
-rw-r--r--meta-oe/recipes-connectivity/gateone/gateone_git.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/gateone/gateone_git.bb b/meta-oe/recipes-connectivity/gateone/gateone_git.bb
new file mode 100644
index 000000000..65e719025
--- /dev/null
+++ b/meta-oe/recipes-connectivity/gateone/gateone_git.bb
@@ -0,0 +1,37 @@
1DESCRIPTION = "HTML5 (plugin-free) web-based terminal emulator and SSH client"
2LICENSE = "AGPLv3"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=07d5a2790569bd3e3b422b69ccd43bec"
4
5PR = "r3"
6
7PV = "0.9"
8SRCREV = "3a10118f10aeea457be0cbea89a5e1e642fbf59f"
9SRC_URI = "git://github.com/liftoff/GateOne.git"
10
11S = "${WORKDIR}/git"
12
13inherit distutils
14
15do_configure_prepend() {
16 sed -i -e s:/opt:${D}${localstatedir}/lib: setup.py
17}
18
19FILES_${PN} = "${localstatedir}/lib/"
20RDEPENDS_${PN} = "python-tornado \
21 python-datetime \
22 python-shell \
23 python-subprocess \
24 python-terminal \
25 python-io \
26 python-compression \
27 python-syslog \
28 python-misc \
29 python-crypt \
30 python-netclient \
31 python-email \
32 python-html \
33 python-textutils \
34 python-pyopenssl \
35 findutils \
36 python-simplejson \
37 "