summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/gateone/gateone_git.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-11-10 15:01:18 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-11-10 15:02:04 +0100
commit681b30a6ed830e47c8b77cc9a72cdc82c4ec2190 (patch)
treecb85e1ec21ef4ac653afa7327a27de4858fc6199 /meta-oe/recipes-connectivity/gateone/gateone_git.bb
parent1e93fb3cb6d716ad811bd26154fdcec42195c360 (diff)
downloadmeta-openembedded-681b30a6ed830e47c8b77cc9a72cdc82c4ec2190.tar.gz
gateone: add avahi and systemd support
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-connectivity/gateone/gateone_git.bb')
-rw-r--r--meta-oe/recipes-connectivity/gateone/gateone_git.bb22
1 files changed, 17 insertions, 5 deletions
diff --git a/meta-oe/recipes-connectivity/gateone/gateone_git.bb b/meta-oe/recipes-connectivity/gateone/gateone_git.bb
index fdccadd55..1b87a029b 100644
--- a/meta-oe/recipes-connectivity/gateone/gateone_git.bb
+++ b/meta-oe/recipes-connectivity/gateone/gateone_git.bb
@@ -2,15 +2,18 @@ DESCRIPTION = "HTML5 (plugin-free) web-based terminal emulator and SSH client"
2LICENSE = "AGPLv3" 2LICENSE = "AGPLv3"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=07d5a2790569bd3e3b422b69ccd43bec" 3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=07d5a2790569bd3e3b422b69ccd43bec"
4 4
5PR = "r5" 5PR = "r6"
6 6
7PV = "0.9" 7PV = "0.9"
8SRCREV = "031a85e8e24ae499e41e15b5077c33a4bd647bd3" 8SRCREV = "13836e34b70998cf59e3e5d8e2b9c90a60c26cc9"
9SRC_URI = "git://github.com/liftoff/GateOne.git" 9SRC_URI = "git://github.com/liftoff/GateOne.git \
10 file://gateone-avahi.service \
11 file://gateone.service \
12 "
10 13
11S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
12 15
13inherit distutils 16inherit distutils systemd
14 17
15do_configure_prepend() { 18do_configure_prepend() {
16 sed -i -e s:/opt:${D}${localstatedir}/lib: setup.py 19 sed -i -e s:/opt:${D}${localstatedir}/lib: setup.py
@@ -18,9 +21,18 @@ do_configure_prepend() {
18 21
19do_install_append() { 22do_install_append() {
20 install -d ${D}${localstatedir}/log/${BPN} 23 install -d ${D}${localstatedir}/log/${BPN}
24
25 install -m 0755 -d ${D}${base_libdir}/systemd/system
26 install -m 0644 ${WORKDIR}/gateone.service ${D}${base_libdir}/systemd/system/
27
28 install -m 0755 -d ${D}${sysconfdir}/avahi/services/
29 install -m 0644 ${WORKDIR}/gateone-avahi.service ${D}${sysconfdir}/avahi/services/
21} 30}
22 31
23FILES_${PN} = "${localstatedir}" 32SYSTEMD_PACKAGES = "${PN}"
33SYSTEMD_SERVICE = "gateone.service"
34
35FILES_${PN} = "${localstatedir} ${base_libdir} ${sysconfdir}"
24RDEPENDS_${PN} = "python-tornado \ 36RDEPENDS_${PN} = "python-tornado \
25 python-datetime \ 37 python-datetime \
26 python-shell \ 38 python-shell \