summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb')
-rw-r--r--meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb44
1 files changed, 22 insertions, 22 deletions
diff --git a/meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb b/meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb
index 3a2da3edc..095a77c1c 100644
--- a/meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb
+++ b/meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb
@@ -6,9 +6,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=a17cb0a873d252440acfdf9b3d0e7fbf"
6HOMEPAGE = "http://www.gammu.org/" 6HOMEPAGE = "http://www.gammu.org/"
7 7
8SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${PN}/${PV}/${PN}-${PV}.tar.bz2 \ 8SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${PN}/${PV}/${PN}-${PV}.tar.bz2 \
9 file://gammurc \ 9 file://gammurc \
10 file://gammu-smsdrc \ 10 file://gammu-smsdrc \
11 " 11"
12 12
13SRC_URI[md5sum] = "8ea16c6b3cc48097a8e62311fe0e25b9" 13SRC_URI[md5sum] = "8ea16c6b3cc48097a8e62311fe0e25b9"
14SRC_URI[sha256sum] = "de67caa102aa4c8fbed5300e5a0262e40411c4cc79f4379a8d34eed797968fc3" 14SRC_URI[sha256sum] = "de67caa102aa4c8fbed5300e5a0262e40411c4cc79f4379a8d34eed797968fc3"
@@ -16,34 +16,34 @@ SRC_URI[sha256sum] = "de67caa102aa4c8fbed5300e5a0262e40411c4cc79f4379a8d34eed797
16inherit distutils cmake gettext 16inherit distutils cmake gettext
17 17
18do_install_append() { 18do_install_append() {
19 # these files seem to only be used by symbian and trigger QA warnings 19 # these files seem to only be used by symbian and trigger QA warnings
20 rm -rf ${D}/usr/share/gammu 20 rm -rf ${D}/usr/share/gammu
21 #install default configuration files 21 #install default configuration files
22 install -d ${D}${sysconfdir} 22 install -d ${D}${sysconfdir}
23 install -m 0644 ${WORKDIR}/gammurc ${D}${sysconfdir}/gammurc 23 install -m 0644 ${WORKDIR}/gammurc ${D}${sysconfdir}/gammurc
24 install -m 0644 ${WORKDIR}/gammu-smsdrc ${D}${sysconfdir}/gammu-smsdrc 24 install -m 0644 ${WORKDIR}/gammu-smsdrc ${D}${sysconfdir}/gammu-smsdrc
25} 25}
26 26
27EXTRA_OECONF = " \ 27EXTRA_OECONF = " \
28 --enable-shared \ 28 --enable-shared \
29 --enable-backup \ 29 --enable-backup \
30 --enable-protection \ 30 --enable-protection \
31 " 31"
32 32
33EXTRA_OECMAKE = " \ 33EXTRA_OECMAKE = " \
34 -DWITH_CURL=OFF \ 34 -DWITH_CURL=OFF \
35 -DWITH_BLUETOOTH=OFF \ 35 -DWITH_BLUETOOTH=OFF \
36 -DWITH_NOKIA_SUPPORT=OFF \ 36 -DWITH_NOKIA_SUPPORT=OFF \
37 -DWITH_IRDA=OFF \ 37 -DWITH_IRDA=OFF \
38 -DWITH_PYTHON=OFF \ 38 -DWITH_PYTHON=OFF \
39 -DWITH_MySQL=ON \ 39 -DWITH_MySQL=ON \
40 -DWITH_Postgres=OFF \ 40 -DWITH_Postgres=OFF \
41 " 41"
42 42
43PACKAGES =+ "${PN}-smsd libgammu libgsmsd python-${PN}" 43PACKAGES =+ "${PN}-smsd libgammu libgsmsd python-${PN}"
44 44
45FILES_${PN} = "${bindir}/gammu ${bindir}/jadmaker ${sysconfdir}/bash_completion.d/gammu \ 45FILES_${PN} = "${bindir}/gammu ${bindir}/jadmaker ${sysconfdir}/bash_completion.d/gammu \
46 ${bindir}/gammu-detect ${sysconfdir}/gammurc" 46 ${bindir}/gammu-detect ${sysconfdir}/gammurc"
47CONFFILES_${PN} = "${sysconfdir}/gammurc" 47CONFFILES_${PN} = "${sysconfdir}/gammurc"
48FILES_${PN}-smsd = "${bindir}/gammu-smsd* ${sysconfdir}/gammu-smsdrc" 48FILES_${PN}-smsd = "${bindir}/gammu-smsd* ${sysconfdir}/gammu-smsdrc"
49CONFFILES_${PN}-smsd = "${sysconfdir}/gammu-smsdrc" 49CONFFILES_${PN}-smsd = "${sysconfdir}/gammu-smsdrc"