summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/cherokee
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2012-03-09 10:13:52 +0000
committerKhem Raj <raj.khem@gmail.com>2012-03-11 10:10:38 -0700
commit0c7d54b58efb6fc21077dc9cf8aca361f8e24746 (patch)
tree191473b8b182d1359c34c1bbf8ceba6bd4a19eef /meta-oe/recipes-connectivity/cherokee
parent2f7c7f82c8c46cee222dea4208de7652e6fceb5c (diff)
downloadmeta-openembedded-0c7d54b58efb6fc21077dc9cf8aca361f8e24746.tar.gz
cherokee: complete systemd native support
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/cherokee')
-rw-r--r--meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb11
1 files changed, 5 insertions, 6 deletions
diff --git a/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb b/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb
index 93bb1913e..0080195de 100644
--- a/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb
+++ b/meta-oe/recipes-connectivity/cherokee/cherokee_1.2.98.bb
@@ -5,7 +5,7 @@ SECTION = "network"
5LICENSE = "GPLv2" 5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" 6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
7 7
8PR = "r1" 8PR = "r3"
9 9
10DEPENDS = "libpcre openssl mysql5 ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" 10DEPENDS = "libpcre openssl mysql5 ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
11 11
@@ -15,7 +15,7 @@ SRC_URI = "http://www.cherokee-project.com/download/1.2/${PV}/cherokee-${PV}.tar
15SRC_URI[md5sum] = "21b01e7d45c0e82ecc0c4257a9c27feb" 15SRC_URI[md5sum] = "21b01e7d45c0e82ecc0c4257a9c27feb"
16SRC_URI[sha256sum] = "042b5687b1a3db3ca818167548ce5d32c35e227c6640732dcb622a6f4a078b7d" 16SRC_URI[sha256sum] = "042b5687b1a3db3ca818167548ce5d32c35e227c6640732dcb622a6f4a078b7d"
17 17
18inherit autotools pkgconfig binconfig update-rc.d 18inherit autotools pkgconfig binconfig update-rc.d systemd
19 19
20EXTRA_OECONF = "--disable-static \ 20EXTRA_OECONF = "--disable-static \
21 --disable-nls \ 21 --disable-nls \
@@ -26,9 +26,6 @@ do_install_append () {
26 install -m 0755 -d ${D}${sysconfdir}/init.d 26 install -m 0755 -d ${D}${sysconfdir}/init.d
27 install -m 755 ${WORKDIR}/cherokee.init ${D}${sysconfdir}/init.d/cherokee 27 install -m 755 ${WORKDIR}/cherokee.init ${D}${sysconfdir}/init.d/cherokee
28 28
29 install -d ${D}${base_libdir}/systemd/system
30 install -m 0644 ${WORKDIR}/*.service ${D}${base_libdir}/systemd/system/
31
32 # clean up .la files for plugins 29 # clean up .la files for plugins
33 rm -f ${D}${libdir}/cherokee/*.la 30 rm -f ${D}${libdir}/cherokee/*.la
34} 31}
@@ -36,7 +33,6 @@ do_install_append () {
36# Put -dev near the front so we can move the .la files into it with a wildcard 33# Put -dev near the front so we can move the .la files into it with a wildcard
37PACKAGES =+ "libcherokee-server libcherokee-client libcherokee-base cget" 34PACKAGES =+ "libcherokee-server libcherokee-client libcherokee-base cget"
38 35
39FILES_${PN} += "${base_libdir}/systemd"
40FILES_cget = "${bindir}/cget" 36FILES_cget = "${bindir}/cget"
41FILES_libcherokee-server = "${libdir}/libcherokee-server${SOLIBS}" 37FILES_libcherokee-server = "${libdir}/libcherokee-server${SOLIBS}"
42FILES_libcherokee-client = "${libdir}/libcherokee-client${SOLIBS}" 38FILES_libcherokee-client = "${libdir}/libcherokee-client${SOLIBS}"
@@ -49,3 +45,6 @@ CONFFILES_${PN} = " \
49 45
50INITSCRIPT_NAME = "cherokee" 46INITSCRIPT_NAME = "cherokee"
51INITSCRIPT_PARAMS = "defaults 91 91" 47INITSCRIPT_PARAMS = "defaults 91 91"
48
49SYSTEMD_PACKAGES = "${PN}-systemd"
50SYSTEMD_SERVICE = "cherokee.service"