summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-bsp
diff options
context:
space:
mode:
authorChaitanya Vadrevu <chaitanya.vadrevu@ni.com>2023-08-15 14:16:05 -0500
committerKhem Raj <raj.khem@gmail.com>2023-08-15 14:24:44 -0700
commitc9b486869af00b4bbab710e6aff22ea3097015d6 (patch)
tree230e5c53327f4ba2ad3468b88c97fb61548ca353 /meta-oe/recipes-bsp
parent331fd95146b5517b1f35f972ee4cd7d91129d8ff (diff)
downloadmeta-openembedded-c9b486869af00b4bbab710e6aff22ea3097015d6.tar.gz
bolt: Add recipe
bolt is used for managing thunderbolt devices. Signed-off-by: Chaitanya Vadrevu <chaitanya.vadrevu@ni.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-bsp')
-rw-r--r--meta-oe/recipes-bsp/bolt/bolt_0.9.5.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-oe/recipes-bsp/bolt/bolt_0.9.5.bb b/meta-oe/recipes-bsp/bolt/bolt_0.9.5.bb
new file mode 100644
index 000000000..b6ad6337c
--- /dev/null
+++ b/meta-oe/recipes-bsp/bolt/bolt_0.9.5.bb
@@ -0,0 +1,19 @@
1SUMMARY = "Thunderbolt user-space management tool"
2DESCRIPTION = "Userspace system daemon to enable security levels for Thunderbolt on GNU/Linux"
3HOMEPAGE = "https://gitlab.freedesktop.org/bolt/bolt"
4LICENSE = "LGPL-2.1-only"
5LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
6
7DEPENDS = "udev polkit dbus"
8REQUIRED_DISTRO_FEATURES = "polkit"
9
10SRC_URI = "git://gitlab.freedesktop.org/bolt/bolt.git;protocol=https;branch=master"
11SRCREV = "5a8a5866a847561566499847d46a97c612b4e6dd"
12
13S = "${WORKDIR}/git"
14
15inherit cmake pkgconfig meson features_check
16
17FILES:${PN} += "${datadir}/dbus-1/* \
18 ${datadir}/polkit-1/* \
19 "