diff options
author | Hongxu Jia <hongxu.jia@windriver.com> | 2018-09-18 00:05:23 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-09-18 20:17:02 -0700 |
commit | a0a1a4fc2174349bc768d32af59872cb7ab90b97 (patch) | |
tree | 9c0e4878c218e80f1b81f5f415c68107b5c885fc /meta-oe/recipes-bsp | |
parent | 7b5d3449943be29b9db0a674e3d52fe65841ee68 (diff) | |
download | meta-openembedded-a0a1a4fc2174349bc768d32af59872cb7ab90b97.tar.gz |
lmsensors: split one dpg package
Multiple -dbg packages per recipe is not encouraged, and only one is
recommended and the code only works properly in some cases for one.
Add RPROVIDES_${PN}-dbg to be compatiable with previous dbg packages
requiring.
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-bsp')
-rw-r--r-- | meta-oe/recipes-bsp/lm_sensors/lmsensors_3.4.0.bb | 15 |
1 files changed, 7 insertions, 8 deletions
diff --git a/meta-oe/recipes-bsp/lm_sensors/lmsensors_3.4.0.bb b/meta-oe/recipes-bsp/lm_sensors/lmsensors_3.4.0.bb index f2354690b..ffab5d6bf 100644 --- a/meta-oe/recipes-bsp/lm_sensors/lmsensors_3.4.0.bb +++ b/meta-oe/recipes-bsp/lm_sensors/lmsensors_3.4.0.bb | |||
@@ -76,14 +76,16 @@ do_install() { | |||
76 | fi | 76 | fi |
77 | } | 77 | } |
78 | 78 | ||
79 | RPROVIDES_${PN}-dbg += "${PN}-libsensors-dbg ${PN}-sensors-dbg ${PN}-sensord-dbg ${PN}-isatools-dbg" | ||
80 | |||
79 | # libsensors packages | 81 | # libsensors packages |
80 | PACKAGES =+ "${PN}-libsensors ${PN}-libsensors-dbg ${PN}-libsensors-dev ${PN}-libsensors-staticdev ${PN}-libsensors-doc" | 82 | PACKAGES =+ "${PN}-libsensors ${PN}-libsensors-dev ${PN}-libsensors-staticdev ${PN}-libsensors-doc" |
81 | 83 | ||
82 | # sensors command packages | 84 | # sensors command packages |
83 | PACKAGES =+ "${PN}-sensors ${PN}-sensors-dbg ${PN}-sensors-doc" | 85 | PACKAGES =+ "${PN}-sensors ${PN}-sensors-doc" |
84 | 86 | ||
85 | # sensord logging daemon | 87 | # sensord logging daemon |
86 | PACKAGES =+ "${PN}-sensord ${PN}-sensord-dbg ${PN}-sensord-doc" | 88 | PACKAGES =+ "${PN}-sensord ${PN}-sensord-doc" |
87 | 89 | ||
88 | # fancontrol script | 90 | # fancontrol script |
89 | PACKAGES =+ "${PN}-fancontrol ${PN}-fancontrol-doc" | 91 | PACKAGES =+ "${PN}-fancontrol ${PN}-fancontrol-doc" |
@@ -98,11 +100,11 @@ PACKAGES =+ "${PN}-sensorsconfconvert ${PN}-sensorsconfconvert-doc" | |||
98 | PACKAGES =+ "${PN}-pwmconfig ${PN}-pwmconfig-doc" | 100 | PACKAGES =+ "${PN}-pwmconfig ${PN}-pwmconfig-doc" |
99 | 101 | ||
100 | # isadump and isaset helper program | 102 | # isadump and isaset helper program |
101 | PACKAGES =+ "${PN}-isatools ${PN}-isatools-dbg ${PN}-isatools-doc" | 103 | PACKAGES =+ "${PN}-isatools ${PN}-isatools-doc" |
104 | |||
102 | 105 | ||
103 | # libsensors files | 106 | # libsensors files |
104 | FILES_${PN}-libsensors = "${libdir}/libsensors.so.* ${sysconfdir}/sensors3.conf ${sysconfdir}/sensors.d" | 107 | FILES_${PN}-libsensors = "${libdir}/libsensors.so.* ${sysconfdir}/sensors3.conf ${sysconfdir}/sensors.d" |
105 | FILES_${PN}-libsensors-dbg = "${libdir}/.debug ${prefix}/src/debug" | ||
106 | FILES_${PN}-libsensors-dev = "${libdir}/libsensors.so ${includedir}" | 108 | FILES_${PN}-libsensors-dev = "${libdir}/libsensors.so ${includedir}" |
107 | FILES_${PN}-libsensors-staticdev = "${libdir}/libsensors.a" | 109 | FILES_${PN}-libsensors-staticdev = "${libdir}/libsensors.a" |
108 | FILES_${PN}-libsensors-doc = "${mandir}/man3" | 110 | FILES_${PN}-libsensors-doc = "${mandir}/man3" |
@@ -110,13 +112,11 @@ RRECOMMENDS_${PN}-libsensors = "lmsensors-config-libsensors" | |||
110 | 112 | ||
111 | # sensors command files | 113 | # sensors command files |
112 | FILES_${PN}-sensors = "${bindir}/sensors" | 114 | FILES_${PN}-sensors = "${bindir}/sensors" |
113 | FILES_${PN}-sensors-dbg = "${bindir}/.debug/sensors" | ||
114 | FILES_${PN}-sensors-doc = "${mandir}/man1 ${mandir}/man5" | 115 | FILES_${PN}-sensors-doc = "${mandir}/man1 ${mandir}/man5" |
115 | RDEPENDS_${PN}-sensors = "${PN}-libsensors" | 116 | RDEPENDS_${PN}-sensors = "${PN}-libsensors" |
116 | 117 | ||
117 | # sensord logging daemon | 118 | # sensord logging daemon |
118 | FILES_${PN}-sensord = "${sbindir}/sensord ${sysconfdir}/init.d/sensord ${systemd_unitdir}/system/sensord.service" | 119 | FILES_${PN}-sensord = "${sbindir}/sensord ${sysconfdir}/init.d/sensord ${systemd_unitdir}/system/sensord.service" |
119 | FILES_${PN}-sensord-dbg = "${bindir}/.debug/sensord" | ||
120 | FILES_${PN}-sensord-doc = "${mandir}/man8/sensord.8" | 120 | FILES_${PN}-sensord-doc = "${mandir}/man8/sensord.8" |
121 | RDEPENDS_${PN}-sensord = "${PN}-sensors rrdtool" | 121 | RDEPENDS_${PN}-sensord = "${PN}-sensors rrdtool" |
122 | RRECOMMENDS_${PN}-sensord = "lmsensors-config-sensord" | 122 | RRECOMMENDS_${PN}-sensord = "lmsensors-config-sensord" |
@@ -144,5 +144,4 @@ RDEPENDS_${PN}-pwmconfig = "${PN}-fancontrol" | |||
144 | 144 | ||
145 | # isadump and isaset helper program files | 145 | # isadump and isaset helper program files |
146 | FILES_${PN}-isatools = "${sbindir}/isa*" | 146 | FILES_${PN}-isatools = "${sbindir}/isa*" |
147 | FILES_${PN}-isatools-dbg = "${sbindir}/.debug/isa*" | ||
148 | FILES_${PN}-isatools-doc = "${mandir}/man8/isa*" | 147 | FILES_${PN}-isatools-doc = "${mandir}/man8/isa*" |