summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-bsp
diff options
context:
space:
mode:
authorRobert Joslyn <robert.joslyn@redrectangle.org>2019-06-02 21:10:44 -0700
committerKhem Raj <raj.khem@gmail.com>2019-06-15 16:45:33 -0700
commit29fbbc4a87e284acdc5b19f031965fc1c0159d74 (patch)
treec3d1ce1baa13d56f75a8314257177f24c52a9b97 /meta-oe/recipes-bsp
parent1ce71d6ec31195280073adec0e400dda7c0dd8a7 (diff)
downloadmeta-openembedded-29fbbc4a87e284acdc5b19f031965fc1c0159d74.tar.gz
lmsensors: Update to 3.5.0
* Switch to git rather than using inconsistent GitHub archive tarballs. * Dependency on libsysfs was removed in 3.0.1 * Remove upstreamed patch fixing musl support and refresh remaining patches * Remove unnecessary conditional on systemd. The update-rc.d and systemd classes handle placement of these files properly. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-bsp')
-rw-r--r--meta-oe/recipes-bsp/lm_sensors/lmsensors/0001-lmsensors-sensors-detect-print-a-special-message-whe.patch12
-rw-r--r--meta-oe/recipes-bsp/lm_sensors/lmsensors/0001-prog-Do-not-limit-sys-io.h-header-include-to-just-gl.patch88
-rw-r--r--meta-oe/recipes-bsp/lm_sensors/lmsensors/0002-lm-sensors-fix-sensors-detect-can-t-read-the-cpu-inf.patch (renamed from meta-oe/recipes-bsp/lm_sensors/lmsensors/0001-lm-sensors-fix-sensors-detect-can-t-read-the-cpu-inf.patch)16
-rw-r--r--meta-oe/recipes-bsp/lm_sensors/lmsensors_3.5.0.bb (renamed from meta-oe/recipes-bsp/lm_sensors/lmsensors_3.4.0.bb)47
4 files changed, 33 insertions, 130 deletions
diff --git a/meta-oe/recipes-bsp/lm_sensors/lmsensors/0001-lmsensors-sensors-detect-print-a-special-message-whe.patch b/meta-oe/recipes-bsp/lm_sensors/lmsensors/0001-lmsensors-sensors-detect-print-a-special-message-whe.patch
index abf6e752a..337fb11dd 100644
--- a/meta-oe/recipes-bsp/lm_sensors/lmsensors/0001-lmsensors-sensors-detect-print-a-special-message-whe.patch
+++ b/meta-oe/recipes-bsp/lm_sensors/lmsensors/0001-lmsensors-sensors-detect-print-a-special-message-whe.patch
@@ -1,8 +1,8 @@
1From c4428260e7685ebaf5c26c6ecaae5a56849853e8 Mon Sep 17 00:00:00 2001 1From 05a4d54e2adc4caed507baca529089ec01f48340 Mon Sep 17 00:00:00 2001
2From: Li Zhou <li.zhou@windriver.com> 2From: Li Zhou <li.zhou@windriver.com>
3Date: Tue, 6 Sep 2016 14:04:29 +0800 3Date: Tue, 6 Sep 2016 14:04:29 +0800
4Subject: [PATCH] lmsensors: sensors-detect: print a special message when there 4Subject: [PATCH 1/2] lmsensors: sensors-detect: print a special message when
5 isn't enough cpu info 5 there isn't enough cpu info
6 6
7When running sensors-detect, if there isn't enough information in 7When running sensors-detect, if there isn't enough information in
8/proc/cpuinfo for this arch (e.g. ppc64), "Use of uninitialized value 8/proc/cpuinfo for this arch (e.g. ppc64), "Use of uninitialized value
@@ -18,10 +18,10 @@ Signed-off-by: Li Zhou <li.zhou@windriver.com>
18 1 file changed, 6 insertions(+), 1 deletion(-) 18 1 file changed, 6 insertions(+), 1 deletion(-)
19 19
20diff --git a/prog/detect/sensors-detect b/prog/detect/sensors-detect 20diff --git a/prog/detect/sensors-detect b/prog/detect/sensors-detect
21index 3c2b44f..5f62405 100755 21index 0b3b0ff2..68594cd7 100755
22--- a/prog/detect/sensors-detect 22--- a/prog/detect/sensors-detect
23+++ b/prog/detect/sensors-detect 23+++ b/prog/detect/sensors-detect
24@@ -2864,7 +2864,12 @@ sub initialize_cpu_list 24@@ -3119,7 +3119,12 @@ sub initialize_cpu_list
25 sub print_cpu_info 25 sub print_cpu_info
26 { 26 {
27 my $cpu = $cpu[0]; 27 my $cpu = $cpu[0];
@@ -36,5 +36,5 @@ index 3c2b44f..5f62405 100755
36 36
37 # @i2c_adapters is a list of references to hashes, one hash per I2C/SMBus 37 # @i2c_adapters is a list of references to hashes, one hash per I2C/SMBus
38-- 38--
391.9.1 392.21.0
40 40
diff --git a/meta-oe/recipes-bsp/lm_sensors/lmsensors/0001-prog-Do-not-limit-sys-io.h-header-include-to-just-gl.patch b/meta-oe/recipes-bsp/lm_sensors/lmsensors/0001-prog-Do-not-limit-sys-io.h-header-include-to-just-gl.patch
deleted file mode 100644
index fb3878dc3..000000000
--- a/meta-oe/recipes-bsp/lm_sensors/lmsensors/0001-prog-Do-not-limit-sys-io.h-header-include-to-just-gl.patch
+++ /dev/null
@@ -1,88 +0,0 @@
1From 727524453f115ddc05109e9bbb3d0e60a7db9185 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 16 Jul 2017 15:05:50 -0700
4Subject: [PATCH] prog: Do not limit sys/io.h header include to just glibc
5
6musl provides it too.
7
8Signed-off-by: Khem Raj <raj.khem@gmail.com>
9---
10 prog/dump/isadump.c | 6 ------
11 prog/dump/isaset.c | 6 ------
12 prog/dump/superio.c | 5 -----
13 prog/dump/util.c | 5 -----
14 4 files changed, 22 deletions(-)
15
16diff --git a/prog/dump/isadump.c b/prog/dump/isadump.c
17index e0e6f00..8794537 100644
18--- a/prog/dump/isadump.c
19+++ b/prog/dump/isadump.c
20@@ -36,13 +36,7 @@
21 #include "util.h"
22 #include "superio.h"
23
24-
25-/* To keep glibc2 happy */
26-#if defined(__GLIBC__) && __GLIBC__ == 2 && __GLIBC_MINOR__ >= 0
27 #include <sys/io.h>
28-#else
29-#include <asm/io.h>
30-#endif
31
32 #ifdef __powerpc__
33 unsigned long isa_io_base = 0; /* XXX for now */
34diff --git a/prog/dump/isaset.c b/prog/dump/isaset.c
35index e743755..85a4f64 100644
36--- a/prog/dump/isaset.c
37+++ b/prog/dump/isaset.c
38@@ -32,13 +32,7 @@
39 #include <string.h>
40 #include "util.h"
41
42-
43-/* To keep glibc2 happy */
44-#if defined(__GLIBC__) && __GLIBC__ == 2 && __GLIBC_MINOR__ >= 0
45 #include <sys/io.h>
46-#else
47-#include <asm/io.h>
48-#endif
49
50 #ifdef __powerpc__
51 unsigned long isa_io_base = 0; /* XXX for now */
52diff --git a/prog/dump/superio.c b/prog/dump/superio.c
53index 64ef27b..906fe55 100644
54--- a/prog/dump/superio.c
55+++ b/prog/dump/superio.c
56@@ -20,12 +20,7 @@
57 */
58
59 #include <stdlib.h>
60-
61-#if defined(__GLIBC__) && __GLIBC__ == 2 && __GLIBC_MINOR__ >= 0
62 #include <sys/io.h>
63-#else
64-#include <asm/io.h>
65-#endif
66
67 #include "superio.h"
68
69diff --git a/prog/dump/util.c b/prog/dump/util.c
70index 874c1b9..197fa64 100644
71--- a/prog/dump/util.c
72+++ b/prog/dump/util.c
73@@ -11,12 +11,7 @@
74 #include <stdio.h>
75 #include "util.h"
76
77-/* To keep glibc2 happy */
78-#if defined(__GLIBC__) && __GLIBC__ == 2 && __GLIBC_MINOR__ >= 0
79 #include <sys/io.h>
80-#else
81-#include <asm/io.h>
82-#endif
83
84 /* Return 1 if we should continue, 0 if we should abort */
85 int user_ack(int def)
86--
872.13.3
88
diff --git a/meta-oe/recipes-bsp/lm_sensors/lmsensors/0001-lm-sensors-fix-sensors-detect-can-t-read-the-cpu-inf.patch b/meta-oe/recipes-bsp/lm_sensors/lmsensors/0002-lm-sensors-fix-sensors-detect-can-t-read-the-cpu-inf.patch
index 2d5709f3f..68f51f5a6 100644
--- a/meta-oe/recipes-bsp/lm_sensors/lmsensors/0001-lm-sensors-fix-sensors-detect-can-t-read-the-cpu-inf.patch
+++ b/meta-oe/recipes-bsp/lm_sensors/lmsensors/0002-lm-sensors-fix-sensors-detect-can-t-read-the-cpu-inf.patch
@@ -1,8 +1,8 @@
1From dd9b40c54f160a44f1d78e5946d4cd00a8852802 Mon Sep 17 00:00:00 2001 1From 26742544bc9f136093b6be78259f4a891870aa3c Mon Sep 17 00:00:00 2001
2From: Dengke Du <dengke.du@windriver.com> 2From: Dengke Du <dengke.du@windriver.com>
3Date: Wed, 21 Sep 2016 03:17:32 -0400 3Date: Wed, 21 Sep 2016 03:17:32 -0400
4Subject: [PATCH] lm-sensors: fix sensors-detect can't read the cpu information 4Subject: [PATCH 2/2] lm-sensors: fix sensors-detect can't read the cpu
5 on fsl-t4xxx 5 information on fsl-t4xxx
6 6
7This is because two reasons: 7This is because two reasons:
8 8
@@ -28,10 +28,10 @@ Signed-off-by: Dengke Du <dengke.du@windriver.com>
28 1 file changed, 10 insertions(+), 1 deletion(-) 28 1 file changed, 10 insertions(+), 1 deletion(-)
29 29
30diff --git a/prog/detect/sensors-detect b/prog/detect/sensors-detect 30diff --git a/prog/detect/sensors-detect b/prog/detect/sensors-detect
31index 5f62405..ae4def1 100755 31index 68594cd7..efe2c1af 100755
32--- a/prog/detect/sensors-detect 32--- a/prog/detect/sensors-detect
33+++ b/prog/detect/sensors-detect 33+++ b/prog/detect/sensors-detect
34@@ -2833,6 +2833,7 @@ sub kernel_version_at_least 34@@ -3088,6 +3088,7 @@ sub kernel_version_at_least
35 # model name and stepping, directly taken from /proc/cpuinfo. 35 # model name and stepping, directly taken from /proc/cpuinfo.
36 use vars qw(@cpu); 36 use vars qw(@cpu);
37 37
@@ -39,7 +39,7 @@ index 5f62405..ae4def1 100755
39 sub initialize_cpu_list 39 sub initialize_cpu_list
40 { 40 {
41 local $_; 41 local $_;
42@@ -2848,7 +2849,7 @@ sub initialize_cpu_list 42@@ -3103,7 +3104,7 @@ sub initialize_cpu_list
43 }; 43 };
44 next; 44 next;
45 } 45 }
@@ -48,7 +48,7 @@ index 5f62405..ae4def1 100755
48 my $k = $1; 48 my $k = $1;
49 my $v = $2; 49 my $v = $2;
50 $v =~ s/\s+/ /g; # Merge multiple spaces 50 $v =~ s/\s+/ /g; # Merge multiple spaces
51@@ -2861,12 +2862,20 @@ sub initialize_cpu_list 51@@ -3116,12 +3117,20 @@ sub initialize_cpu_list
52 push @cpu, $entry if scalar keys(%{$entry}); # Last entry 52 push @cpu, $entry if scalar keys(%{$entry}); # Last entry
53 } 53 }
54 54
@@ -70,5 +70,5 @@ index 5f62405..ae4def1 100755
70 print "# Processor: There isn't enough cpu info for this arch!!!\n"; 70 print "# Processor: There isn't enough cpu info for this arch!!!\n";
71 } 71 }
72-- 72--
732.8.1 732.21.0
74 74
diff --git a/meta-oe/recipes-bsp/lm_sensors/lmsensors_3.4.0.bb b/meta-oe/recipes-bsp/lm_sensors/lmsensors_3.5.0.bb
index 4dbef73b9..c8e4565c1 100644
--- a/meta-oe/recipes-bsp/lm_sensors/lmsensors_3.4.0.bb
+++ b/meta-oe/recipes-bsp/lm_sensors/lmsensors_3.5.0.bb
@@ -1,29 +1,23 @@
1SUMMARY = "lm_sensors" 1SUMMARY = "Hardware health monitoring applications"
2DESCRIPTION = "Hardware health monitoring applications" 2HOMEPAGE = "https://hwmon.wiki.kernel.org/"
3HOMEPAGE = "http://www.lm-sensors.org/"
4LICENSE = "GPLv2+ & LGPLv2.1+" 3LICENSE = "GPLv2+ & LGPLv2.1+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \ 4LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
6 file://COPYING.LGPL;md5=4fbd65380cdd255951079008b364516c" 5 file://COPYING.LGPL;md5=4fbd65380cdd255951079008b364516c"
7 6
8DEPENDS = "sysfsutils virtual/libiconv bison-native flex-native rrdtool" 7DEPENDS = " \
8 bison-native \
9 flex-native \
10 rrdtool \
11 virtual/libiconv \
12"
9 13
10SRC_URI = "https://github.com/groeck/lm-sensors/archive/V3-4-0.tar.gz \ 14SRC_URI = "git://github.com/lm-sensors/lm-sensors.git;protocol=https \
11 file://fancontrol.init \ 15 file://fancontrol.init \
12 file://sensord.init \ 16 file://sensord.init \
13 file://0001-lmsensors-sensors-detect-print-a-special-message-whe.patch \ 17 file://0001-lmsensors-sensors-detect-print-a-special-message-whe.patch \
14 file://0001-prog-Do-not-limit-sys-io.h-header-include-to-just-gl.patch \ 18 file://0002-lm-sensors-fix-sensors-detect-can-t-read-the-cpu-inf.patch \
15 file://0001-lm-sensors-fix-sensors-detect-can-t-read-the-cpu-inf.patch \
16" 19"
17SRC_URI[md5sum] = "1e9f117cbfa11be1955adc96df71eadb" 20SRCREV = "e8afbda10fba571c816abddcb5c8180afc435bba"
18SRC_URI[sha256sum] = "e334c1c2b06f7290e3e66bdae330a5d36054701ffd47a5dde7a06f9a7402cb4e"
19
20# It is using '-' but not '.' as delimiter for the version in the releases page,
21# which causes the version comparison unmatched.
22#UPSTREAM_CHECK_URI = "https://github.com/groeck/lm-sensors/releases"
23
24RECIPE_UPSTREAM_VERSION = "3.4.0"
25RECIPE_UPSTREAM_DATE = "Jun 25, 2015"
26CHECK_DATE = "May 28, 2018"
27 21
28inherit update-rc.d systemd 22inherit update-rc.d systemd
29 23
@@ -39,7 +33,7 @@ SYSTEMD_PACKAGES = "${PN}-sensord"
39SYSTEMD_SERVICE_${PN}-sensord = "sensord.service lm_sensors.service fancontrol.service" 33SYSTEMD_SERVICE_${PN}-sensord = "sensord.service lm_sensors.service fancontrol.service"
40SYSTEMD_AUTO_ENABLE = "disable" 34SYSTEMD_AUTO_ENABLE = "disable"
41 35
42S = "${WORKDIR}/lm-sensors-3-4-0" 36S = "${WORKDIR}/git"
43 37
44EXTRA_OEMAKE = 'EXLDFLAGS="${LDFLAGS}" \ 38EXTRA_OEMAKE = 'EXLDFLAGS="${LDFLAGS}" \
45 MACHINE=${TARGET_ARCH} PREFIX=${prefix} MANDIR=${mandir} \ 39 MACHINE=${TARGET_ARCH} PREFIX=${prefix} MANDIR=${mandir} \
@@ -61,20 +55,17 @@ do_install() {
61 install -m 0644 ${S}/prog/sensord/sensord.8 ${D}${mandir}/man8 55 install -m 0644 ${S}/prog/sensord/sensord.8 ${D}${mandir}/man8
62 56
63 # Install directory 57 # Install directory
64 install -d ${D}${sysconfdir}/init.d 58 install -d ${D}${INIT_D_DIR}
65 59
66 # Install fancontrol init script 60 # Install fancontrol init script
67 install -m 0755 ${WORKDIR}/fancontrol.init \ 61 install -m 0755 ${WORKDIR}/fancontrol.init ${D}${INIT_D_DIR}/fancontrol
68 ${D}${sysconfdir}/init.d/fancontrol
69 62
70 # Install sensord init script 63 # Install sensord init script
71 install -m 0755 ${WORKDIR}/sensord.init ${D}${sysconfdir}/init.d/sensord 64 install -m 0755 ${WORKDIR}/sensord.init ${D}${INIT_D_DIR}/sensord
72 65
73 # Insall sensord service script 66 # Insall sensord service script
74 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then 67 install -d ${D}${systemd_system_unitdir}
75 install -d ${D}${systemd_unitdir}/system 68 install -m 0644 ${S}/prog/init/*.service ${D}${systemd_system_unitdir}
76 install -m 0644 ${S}/prog/init/*.service ${D}${systemd_unitdir}/system
77 fi
78} 69}
79 70
80RPROVIDES_${PN}-dbg += "${PN}-libsensors-dbg ${PN}-sensors-dbg ${PN}-sensord-dbg ${PN}-isatools-dbg" 71RPROVIDES_${PN}-dbg += "${PN}-libsensors-dbg ${PN}-sensors-dbg ${PN}-sensord-dbg ${PN}-isatools-dbg"
@@ -117,13 +108,13 @@ FILES_${PN}-sensors-doc = "${mandir}/man1 ${mandir}/man5"
117RDEPENDS_${PN}-sensors = "${PN}-libsensors" 108RDEPENDS_${PN}-sensors = "${PN}-libsensors"
118 109
119# sensord logging daemon 110# sensord logging daemon
120FILES_${PN}-sensord = "${sbindir}/sensord ${sysconfdir}/init.d/sensord ${systemd_unitdir}/system/sensord.service" 111FILES_${PN}-sensord = "${sbindir}/sensord ${INIT_D_DIR}/sensord ${systemd_system_unitdir}/sensord.service"
121FILES_${PN}-sensord-doc = "${mandir}/man8/sensord.8" 112FILES_${PN}-sensord-doc = "${mandir}/man8/sensord.8"
122RDEPENDS_${PN}-sensord = "${PN}-sensors rrdtool" 113RDEPENDS_${PN}-sensord = "${PN}-sensors rrdtool"
123RRECOMMENDS_${PN}-sensord = "lmsensors-config-sensord" 114RRECOMMENDS_${PN}-sensord = "lmsensors-config-sensord"
124 115
125# fancontrol script files 116# fancontrol script files
126FILES_${PN}-fancontrol = "${sbindir}/fancontrol ${sysconfdir}/init.d/fancontrol" 117FILES_${PN}-fancontrol = "${sbindir}/fancontrol ${INIT_D_DIR}/fancontrol"
127FILES_${PN}-fancontrol-doc = "${mandir}/man8/fancontrol.8" 118FILES_${PN}-fancontrol-doc = "${mandir}/man8/fancontrol.8"
128RDEPENDS_${PN}-fancontrol = "bash" 119RDEPENDS_${PN}-fancontrol = "bash"
129RRECOMMENDS_${PN}-fancontrol = "lmsensors-config-fancontrol" 120RRECOMMENDS_${PN}-fancontrol = "lmsensors-config-fancontrol"