summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-bsp/ledmon
diff options
context:
space:
mode:
authoralperak <alperyasinak1@gmail.com>2023-11-18 12:52:25 +0300
committerKhem Raj <raj.khem@gmail.com>2023-11-18 08:45:56 -0800
commitf13feb0adfe150c922756eef366a69ccb1f1c49f (patch)
tree81616644bf4e3a0cc2a26d0dc3f59b189e68fe68 /meta-oe/recipes-bsp/ledmon
parent1ae1a7cd36240b259ea56b25a7d8a86d8dcae5a0 (diff)
downloadmeta-openembedded-f13feb0adfe150c922756eef366a69ccb1f1c49f.tar.gz
ledmon: upgrade 0.93 -> 0.97
* Added 0001-fix-build-with-clang.patch to fix build error caused by missing 'value' initializer * License changed GPL-2.0-only -> LGPL-2.0-only - LIC_FILES_CHKSUM changed COPYING -> COPYING.LIB for LGPL-2.0-only - Changed license headers in required source files. - Changed copyright years to 2022 in modified files. * 0001-Don-t-build-with-Werror-to-fix-compile-error.patch removed because fixed in the new version. * libpci was added as depends following this error -> configure: error: Package requirements (libpci) were not met: No package 'libpci' found * pkgconfig added as inherit following this error -> PKG_PROG_PKG_CONFIG: command not found Changelog: It can be followed here: https://github.com/intel/ledmon/releases Signed-off-by: alperak <alperyasinak1@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-bsp/ledmon')
-rw-r--r--meta-oe/recipes-bsp/ledmon/ledmon/0001-Don-t-build-with-Werror-to-fix-compile-error.patch30
-rw-r--r--meta-oe/recipes-bsp/ledmon/ledmon/0001-fix-build-with-clang.patch90
-rw-r--r--meta-oe/recipes-bsp/ledmon/ledmon_0.97.bb (renamed from meta-oe/recipes-bsp/ledmon/ledmon_git.bb)18
3 files changed, 98 insertions, 40 deletions
diff --git a/meta-oe/recipes-bsp/ledmon/ledmon/0001-Don-t-build-with-Werror-to-fix-compile-error.patch b/meta-oe/recipes-bsp/ledmon/ledmon/0001-Don-t-build-with-Werror-to-fix-compile-error.patch
deleted file mode 100644
index 09f4993a2..000000000
--- a/meta-oe/recipes-bsp/ledmon/ledmon/0001-Don-t-build-with-Werror-to-fix-compile-error.patch
+++ /dev/null
@@ -1,30 +0,0 @@
1Subject: [PATCH] Don't build with -Werror to fix compile error.
2
3| 550 | _dump_sgpio_amd(&amd_reg->amd);
4| | ^~~~~~~~~~~~~
5| amd_sgpio.c: In function '_write_amd_register':
6| amd_sgpio.c:558:18: error: taking address of packed member of 'struct amd_register' may result in an unaligned pointer value [-Werror=address-of-packed-member]
7
8Upstream-Status: Submitted
9https://github.com/intel/ledmon/pull/48/commits
10
11Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>
12---
13 configure.ac | 1 -
14 1 file changed, 1 deletion(-)
15
16diff --git a/configure.ac b/configure.ac
17index 7bc20f8..7e01bd5 100644
18--- a/configure.ac
19+++ b/configure.ac
20@@ -22,7 +22,6 @@ AX_AM_CFLAGS_ADD([-Werror=format-truncation=1])
21 AX_AM_CFLAGS_ADD([-Werror=shift-negative-value])
22 AX_AM_CFLAGS_ADD([-Werror=alloca])
23 AX_AM_CFLAGS_ADD([-Werror=missing-field-initializers])
24-AX_AM_CFLAGS_ADD([-Werror])
25 AX_AM_CFLAGS_ADD([-Werror=format-signedness])
26
27 AC_SUBST([AM_CFLAGS])
28--
292.7.4
30
diff --git a/meta-oe/recipes-bsp/ledmon/ledmon/0001-fix-build-with-clang.patch b/meta-oe/recipes-bsp/ledmon/ledmon/0001-fix-build-with-clang.patch
new file mode 100644
index 000000000..f1e1d6f78
--- /dev/null
+++ b/meta-oe/recipes-bsp/ledmon/ledmon/0001-fix-build-with-clang.patch
@@ -0,0 +1,90 @@
1From 28fd86fb4e18af181174176530a80672de4449d2 Mon Sep 17 00:00:00 2001
2From: alperak <alperyasinak1@gmail.com>
3Date: Sat, 18 Nov 2023 12:27:17 +0300
4Subject: [PATCH] fix build with clang
5
6struct ibpi2value is a structure which contains 2 unsigned integers. In
7a number of cases the code was not initializing a value for the last value
8in the pair in struct ibpi2value ibpi_to_attention. This was raised when
9using clang compiler.
10
11vmdssd.c:49:27: error: missing field 'value' initializer
12[-Werror,-Wmissing-field-initializers]
13 {LED_IBPI_PATTERN_UNKNOWN}
14
15dellssd.c:74:27: error: missing field 'value' initializer
16[-Werror,-Wmissing-field-initializers]
17 {LED_IBPI_PATTERN_UNKNOWN}
18
19amd_ipmi.c:57:27: error: missing field 'value'
20initializer [-Werror,-Wmissing-field-initializers]
21 {LED_IBPI_PATTERN_UNKNOWN}
22
23npem.c:76:27: error: missing field 'value'
24initializer [-Werror,-Wmissing-field-initializers]
25 {LED_IBPI_PATTERN_UNKNOWN}
26
27Upstream-Status: Submitted [https://github.com/intel/ledmon/pull/179]
28Signed-off-by: alperak <alperyasinak1@gmail.com>
29---
30 src/amd_ipmi.c | 2 +-
31 src/dellssd.c | 2 +-
32 src/npem.c | 2 +-
33 src/vmdssd.c | 2 +-
34 4 files changed, 4 insertions(+), 4 deletions(-)
35
36diff --git a/src/amd_ipmi.c b/src/amd_ipmi.c
37index 726f77d..ad36e9e 100644
38--- a/src/amd_ipmi.c
39+++ b/src/amd_ipmi.c
40@@ -53,7 +53,7 @@ const struct ibpi2value ibpi2amd_ipmi[] = {
41 {IBPI_PATTERN_FAILED_ARRAY, 0x45},
42 {IBPI_PATTERN_REBUILD, 0x46},
43 {IBPI_PATTERN_HOTSPARE, 0x47},
44- {IBPI_PATTERN_UNKNOWN}
45+ {IBPI_PATTERN_UNKNOWN, 0}
46 };
47
48 #define MG9098_CHIP_ID_REG 0x63
49diff --git a/src/dellssd.c b/src/dellssd.c
50index 3c10ec7..7f02ea1 100644
51--- a/src/dellssd.c
52+++ b/src/dellssd.c
53@@ -71,7 +71,7 @@ static const struct ibpi2value ibpi2ssd[] = {
54 {IBPI_PATTERN_FAILED_DRIVE, BP_FAULT | BP_ONLINE},
55 {IBPI_PATTERN_LOCATE, BP_IDENTIFY | BP_ONLINE},
56 {IBPI_PATTERN_LOCATE_OFF, BP_ONLINE},
57- {IBPI_PATTERN_UNKNOWN}
58+ {IBPI_PATTERN_UNKNOWN, 0}
59 };
60
61 #define DELL_OEM_NETFN 0x30
62diff --git a/src/npem.c b/src/npem.c
63index c21276d..3499169 100644
64--- a/src/npem.c
65+++ b/src/npem.c
66@@ -72,7 +72,7 @@ const struct ibpi2value ibpi_to_npem_capability[] = {
67 {IBPI_PATTERN_FAILED_DRIVE, PCI_NPEM_FAIL_CAP},
68 {IBPI_PATTERN_LOCATE, PCI_NPEM_LOCATE_CAP},
69 {IBPI_PATTERN_LOCATE_OFF, PCI_NPEM_OK_CAP},
70- {IBPI_PATTERN_UNKNOWN}
71+ {IBPI_PATTERN_UNKNOWN, 0}
72 };
73
74 static struct pci_access *get_pci_access()
75diff --git a/src/vmdssd.c b/src/vmdssd.c
76index 51af591..9c63d90 100644
77--- a/src/vmdssd.c
78+++ b/src/vmdssd.c
79@@ -45,7 +45,7 @@ struct ibpi2value ibpi_to_attention[] = {
80 {IBPI_PATTERN_REBUILD, ATTENTION_REBUILD},
81 {IBPI_PATTERN_LOCATE_OFF, ATTENTION_OFF},
82 {IBPI_PATTERN_ONESHOT_NORMAL, ATTENTION_OFF},
83- {IBPI_PATTERN_UNKNOWN}
84+ {IBPI_PATTERN_UNKNOWN, 0}
85 };
86
87 #define SYSFS_PCIEHP "/sys/module/pciehp"
88--
892.25.1
90
diff --git a/meta-oe/recipes-bsp/ledmon/ledmon_git.bb b/meta-oe/recipes-bsp/ledmon/ledmon_0.97.bb
index dbfd1e7bc..d431fd9a8 100644
--- a/meta-oe/recipes-bsp/ledmon/ledmon_git.bb
+++ b/meta-oe/recipes-bsp/ledmon/ledmon_0.97.bb
@@ -5,28 +5,26 @@ DESCRIPTION = "The utilities are designed primarily to be used on storage server
5" 5"
6HOMEPAGE = "https://github.com/intel/ledmon" 6HOMEPAGE = "https://github.com/intel/ledmon"
7 7
8LICENSE = "GPL-2.0-only" 8LICENSE = "LGPL-2.0-only"
9LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \ 9LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
10"
11 10
12DEPENDS = "sg3-utils udev" 11DEPENDS = "sg3-utils udev pciutils"
13 12
14inherit autotools systemd 13inherit autotools systemd pkgconfig
15 14
16SYSTEMD_SERVICE:${PN} = "ledmon.service" 15SYSTEMD_SERVICE:${PN} = "ledmon.service"
17 16
18# 0.93
19SRC_URI = "git://github.com/intel/ledmon;branch=master;protocol=https \ 17SRC_URI = "git://github.com/intel/ledmon;branch=master;protocol=https \
20 file://0002-include-sys-select.h-and-sys-types.h.patch \ 18 file://0002-include-sys-select.h-and-sys-types.h.patch \
21 file://0001-Don-t-build-with-Werror-to-fix-compile-error.patch \ 19 file://0001-fix-build-with-clang.patch"
22 "
23 20
24SRCREV = "1d72f9cb5c9163b2ecdf19709935720e65f5b90e" 21SRCREV = "b0edae14e8660b80ffe0384354038a9f62e2978d"
25 22
26COMPATIBLE_HOST = "(i.86|x86_64).*-linux" 23COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
27COMPATIBLE_HOST:libc-musl = "null" 24COMPATIBLE_HOST:libc-musl = "null"
28 25
29S = "${WORKDIR}/git" 26S = "${WORKDIR}/git"
27
30EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}' CFLAGS='${CFLAGS}'" 28EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}' CFLAGS='${CFLAGS}'"
31 29
32# The ledmon sources include headers in ${S}/config to build but not in CFLAGS. 30# The ledmon sources include headers in ${S}/config to build but not in CFLAGS.