summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-bsp/ledmon/ledmon_git.bb
diff options
context:
space:
mode:
authorLiwei Song <liwei.song@windriver.com>2019-04-08 04:26:20 -0400
committerKhem Raj <raj.khem@gmail.com>2019-04-09 21:33:39 -0700
commita12a37659db90a5534349f81fbe3744431f75b1d (patch)
treeb907dc1f24005d6b651937907ebf1bb59d36f12e /meta-oe/recipes-bsp/ledmon/ledmon_git.bb
parentd219ba7a28e0f906df7ff5de20d8185fce31ed67 (diff)
downloadmeta-openembedded-a12a37659db90a5534349f81fbe3744431f75b1d.tar.gz
ledmon: control hard disk led for RAID arrays
Enable LED support for Intel Virtual RAID On CPU. Fix build with musl Signed-off-by: Liwei Song <liwei.song@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-bsp/ledmon/ledmon_git.bb')
-rw-r--r--meta-oe/recipes-bsp/ledmon/ledmon_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-oe/recipes-bsp/ledmon/ledmon_git.bb b/meta-oe/recipes-bsp/ledmon/ledmon_git.bb
new file mode 100644
index 000000000..4376ad394
--- /dev/null
+++ b/meta-oe/recipes-bsp/ledmon/ledmon_git.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Intel(R) Enclosure LED Utilities"
2
3DESCRIPTION = "The utilities are designed primarily to be used on storage servers \
4 utilizing MD devices (aka Linux Software RAID) for RAID arrays.\
5"
6HOMEPAGE = "https://github.com/intel/ledmon"
7
8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
10"
11
12DEPENDS = "sg3-utils udev"
13
14inherit systemd
15
16SYSTEMD_SERVICE_${PN} = "ledmon.service"
17
18SRC_URI = "git://github.com/intel/ledmon;branch=master \
19 file://0001-use-atexit-insead-of-on_exit-for-musl-compatibility.patch \
20 file://0002-include-sys-select.h-and-sys-types.h.patch \
21 "
22
23SRCREV = "ad1304ca1363d727425a1f23703c523e21feae4f"
24
25COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
26
27S = "${WORKDIR}/git"
28EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}' CFLAGS='${CFLAGS}'"
29
30do_install_append() {
31 install -d ${D}/${systemd_unitdir}/system
32 oe_runmake DESTDIR=${D} install
33 oe_runmake DESTDIR=${D}${systemd_unitdir}/system install-systemd
34}