summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-bsp/fwupd
diff options
context:
space:
mode:
authorMarkus Volk <f_l_k@t-online.de>2023-02-13 10:25:57 +0100
committerKhem Raj <raj.khem@gmail.com>2023-02-13 14:35:35 -0800
commit4c1f83d2724dd87af4bbaf1b322dbcf106654a16 (patch)
tree00583f2c24952606248efb9b5b5313ef33e5bc17 /meta-oe/recipes-bsp/fwupd
parent1f2825ed40b2a943b8397eac15beb84bb7e50e51 (diff)
downloadmeta-openembedded-4c1f83d2724dd87af4bbaf1b322dbcf106654a16.tar.gz
fwupd: fix polkit rules.d permissions
This fixes: Error: Transaction test error: file /usr/share/polkit-1/rules.d conflicts between attempted installs of fwupd-1.8.9-r0.intel_corei7_64 and polkit-122-r0.corei7_64 file /usr/share/polkit-1/rules.d conflicts between attempted installs of flatpak-1.15.1-r0.corei7_64 and fwupd-1.8.9-r0.intel_corei7_64 Signed-off-by: Markus Volk <f_l_k@t-online.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-bsp/fwupd')
-rw-r--r--meta-oe/recipes-bsp/fwupd/fwupd_1.8.9.bb13
1 files changed, 12 insertions, 1 deletions
diff --git a/meta-oe/recipes-bsp/fwupd/fwupd_1.8.9.bb b/meta-oe/recipes-bsp/fwupd/fwupd_1.8.9.bb
index 0f889ca8f..14d83ec52 100644
--- a/meta-oe/recipes-bsp/fwupd/fwupd_1.8.9.bb
+++ b/meta-oe/recipes-bsp/fwupd/fwupd_1.8.9.bb
@@ -13,7 +13,7 @@ UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/releases"
13# Machine-specific as we examine MACHINE_FEATURES to decide whether to build the UEFI plugins 13# Machine-specific as we examine MACHINE_FEATURES to decide whether to build the UEFI plugins
14PACKAGE_ARCH = "${MACHINE_ARCH}" 14PACKAGE_ARCH = "${MACHINE_ARCH}"
15 15
16inherit meson vala gobject-introspection systemd bash-completion pkgconfig gi-docgen ptest manpages 16inherit meson vala gobject-introspection systemd bash-completion pkgconfig gi-docgen ptest manpages useradd
17 17
18GIDOCGEN_MESON_OPTION = 'docs' 18GIDOCGEN_MESON_OPTION = 'docs'
19GIDOCGEN_MESON_ENABLE_FLAG = 'docgen' 19GIDOCGEN_MESON_ENABLE_FLAG = 'docgen'
@@ -115,6 +115,17 @@ DISABLE_NON_X86:x86 = ""
115DISABLE_NON_X86:x86-64 = "" 115DISABLE_NON_X86:x86-64 = ""
116PACKAGECONFIG:remove = "${DISABLE_NON_X86}" 116PACKAGECONFIG:remove = "${DISABLE_NON_X86}"
117 117
118USERADD_PACKAGES = "${PN}"
119USERADD_PARAM:${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/polkit-1 --shell /bin/nologin polkitd"
120
121do_install:append() {
122 if ${@bb.utils.contains('PACKAGECONFIG', 'polkit', 'true', 'false', d)}; then
123 #Fix up permissions on polkit rules.d to work with rpm4 constraints
124 chmod 700 ${D}/${datadir}/polkit-1/rules.d
125 chown polkitd:root ${D}/${datadir}/polkit-1/rules.d
126 fi
127}
128
118FILES:${PN} += "${libdir}/fwupd-plugins-* \ 129FILES:${PN} += "${libdir}/fwupd-plugins-* \
119 ${libdir}/fwupd-${PV} \ 130 ${libdir}/fwupd-${PV} \
120 ${systemd_unitdir} \ 131 ${systemd_unitdir} \