summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorChunrong Guo <B40290@freescale.com>2014-06-18 11:12:15 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-22 00:01:47 +0200
commitfca32c0fcec0b9690f665cb5b764b4e5f5bfbf25 (patch)
tree10f58423c58d14e89b7a3e79bdb39d8dfacaddd7 /meta-oe/recipes-benchmark
parent27981cbef19db115fa81704468721580dedfb1fd (diff)
downloadmeta-openembedded-fca32c0fcec0b9690f665cb5b764b4e5f5bfbf25.tar.gz
libhugetlbfs: arm 32bit support
Signed-off-by: Chunrong Guo <B40290@freescale.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/files/arm32-support.patch29
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb3
2 files changed, 31 insertions, 1 deletions
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/files/arm32-support.patch b/meta-oe/recipes-benchmark/libhugetlbfs/files/arm32-support.patch
new file mode 100644
index 000000000..96f162dd9
--- /dev/null
+++ b/meta-oe/recipes-benchmark/libhugetlbfs/files/arm32-support.patch
@@ -0,0 +1,29 @@
1Upstream-Status: Submitted
2
3This patch adds support for arm32.
4
5Signed-off-by: Chunrong Guo <B40290@freescale.com>
6
7--- a/Makefileold 2014-06-17 21:55:23.131058918 -0500
8+++ b/Makefile 2014-06-17 21:56:08.726098531 -0500
9@@ -59,6 +59,12 @@
10 TMPLIB32 = lib
11 CPPFLAGS += -DPPC_NO_SEGMENTS
12 else
13+ifeq ($(ARCH),arm)
14+CC32 = $(CC)
15+TMPLIB32 = lib
16+ELF32 += armelf_linux_eabi
17+CUSTOM_LDSCRIPTS = no
18+else
19 ifeq ($(ARCH),armv7l)
20 CC32 = $(CC)
21 TMPLIB32 = lib
22@@ -116,6 +122,7 @@
23 endif
24 endif
25 endif
26+endif
27
28 ifdef CC32
29 OBJDIRS += obj32
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
index 5645add6b..879f2a067 100644
--- a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
+++ b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
@@ -14,11 +14,12 @@ SRC_URI = "git://git.code.sf.net/p/libhugetlbfs/code \
14 file://0001-aarch64-fix-cross-compilation.patch \ 14 file://0001-aarch64-fix-cross-compilation.patch \
15 file://0001-aarch64-fix-page-size-not-properly-computed.patch \ 15 file://0001-aarch64-fix-page-size-not-properly-computed.patch \
16 file://0001-replace-lib-lib64-hardcoded-values-by-LIBDIR32-LIBDI.patch \ 16 file://0001-replace-lib-lib64-hardcoded-values-by-LIBDIR32-LIBDI.patch \
17 file://arm32-support.patch \
17" 18"
18 19
19S = "${WORKDIR}/git" 20S = "${WORKDIR}/git"
20 21
21COMPATIBLE_HOST = "(x86_64|powerpc|powerpc64|aarch64).*-linux*" 22COMPATIBLE_HOST = "(x86_64|powerpc|powerpc64|aarch64|arm).*-linux*"
22 23
23LIBARGS = "LIB32=${baselib} LIB64=${baselib}" 24LIBARGS = "LIB32=${baselib} LIB64=${baselib}"
24EXTRA_OEMAKE = "'ARCH=${TARGET_ARCH}' 'OPT=${CFLAGS}' 'CC=${CC}' ${LIBARGS} V=1" 25EXTRA_OEMAKE = "'ARCH=${TARGET_ARCH}' 'OPT=${CFLAGS}' 'CC=${CC}' ${LIBARGS} V=1"