summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorchase maupin <chase.maupin@ti.com>2012-02-29 12:46:59 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-02-29 14:52:45 +0100
commitf742316e223b911c005fb85f7defd8ae891e34e2 (patch)
treecde05e38cd040cf39747faed71e5458632dd8f63 /meta-oe/recipes-benchmark
parent4c9740b5a893255326efa62fb8dd60153f88da2d (diff)
downloadmeta-openembedded-f742316e223b911c005fb85f7defd8ae891e34e2.tar.gz
nbench-byte-2.3.3: import recipe from oe-classic
* Import the nbench-byte recipe from the oe-classic git repo at git://git.openembedded.org/openembedded commit id: * 6fe7cef27069415f2eba36bc640cf59013d4979b * Update LICENSE checksums * Tested on an AM335x EVM which is the same processor as the beaglebone. * Original Author: * Marcin Juszkiewicz <marcin@juszkiewicz.com.pl> * Modifications by: * Koen Kooi <koen@openembedded.org> * Martin Jansa <Martin.Jansa@gmail.com> * Chris Larson <chris_larson@mentor.com> Signed-off-by: Chase Maupin <Chase.Maupin@ti.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/nbench-byte/nbench-byte/nbench_32bits.patch46
-rw-r--r--meta-oe/recipes-benchmark/nbench-byte/nbench-byte_2.2.3.bb24
2 files changed, 70 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/nbench-byte/nbench-byte/nbench_32bits.patch b/meta-oe/recipes-benchmark/nbench-byte/nbench-byte/nbench_32bits.patch
new file mode 100644
index 000000000..1b8a4dc08
--- /dev/null
+++ b/meta-oe/recipes-benchmark/nbench-byte/nbench-byte/nbench_32bits.patch
@@ -0,0 +1,46 @@
1From 81f4043a6787060029ef20eed21cdcf3e50337df Mon Sep 17 00:00:00 2001
2From: Chase Maupin <Chase.Maupin@ti.com>
3Date: Tue, 28 Feb 2012 14:58:35 -0600
4Subject: [PATCH] nbench: modify Makefile for 32bit
5
6* Patch taken from OE classic git repository as of commit id
7 ad42bf9065928b2902d7d9534709d3ccea7ec956 and was added by:
8 * Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
9* Notes from original patch were:
10
11BYTE Magazine's native benchmarks (also called BYTEmark) designed to
12expose the capabilities of a system's CPU, FPU and memory system.
13
14http://www.tux.org/~mayer/linux/
15
16Recipe from old Atmel overlay.
17
18Upstream-Status: Inappropriate [no upstream]
19
20Signed-off-by: Chase Maupin <chase.maupin@ti.com>
21---
22 Makefile | 8 ++------
23 1 files changed, 2 insertions(+), 6 deletions(-)
24
25diff --git a/Makefile b/Makefile
26index 5045c77..915866d 100644
27--- a/Makefile
28+++ b/Makefile
29@@ -119,12 +119,8 @@ emfloat.o: emfloat.h emfloat.c nmglobal.h pointer.h Makefile
30 $(CC) $(MACHINE) $(DEFINES) $(CFLAGS)\
31 -c emfloat.c
32
33-pointer.h: pointer Makefile
34- $(CC) $(MACHINE) $(DEFINES) $(CFLAGS)\
35- -o pointer pointer.c
36- rm -f pointer.h
37- if [ "4" = `./pointer` ] ; then touch pointer.h ;\
38- else echo "#define LONG64" >pointer.h ; fi
39+pointer.h: Makefile
40+ touch pointer.h ;
41
42 misc.o: misc.h misc.c Makefile
43 $(CC) $(MACHINE) $(DEFINES) $(CFLAGS)\
44--
451.7.0.4
46
diff --git a/meta-oe/recipes-benchmark/nbench-byte/nbench-byte_2.2.3.bb b/meta-oe/recipes-benchmark/nbench-byte/nbench-byte_2.2.3.bb
new file mode 100644
index 000000000..8dd289bc6
--- /dev/null
+++ b/meta-oe/recipes-benchmark/nbench-byte/nbench-byte_2.2.3.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "BYTE Magazine's native benchmarks (also called BYTEmark) \
2designed to expose the capabilities of a system's CPU, FPU, \
3and memory system."
4HOMEPAGE = "http://www.tux.org/~mayer/linux/"
5LICENSE = "freely distributable"
6LIC_FILES_CHKSUM = "file://README;beginline=57;endline=66;md5=020ef579f8fa5746b7e307a54707834f"
7SECTION = "console/utils"
8
9SRC_URI = "http://www.tux.org/~mayer/linux/${PN}-${PV}.tar.gz \
10 file://nbench_32bits.patch"
11
12SRC_URI[md5sum] = "285dfab361080759d477ea1fe7d3093a"
13SRC_URI[sha256sum] = "723dd073f80e9969639eb577d2af4b540fc29716b6eafdac488d8f5aed9101ac"
14
15TARGET_CC_ARCH += "${CFLAGS} ${LDFLAGS}"
16do_compile() {
17 oe_runmake
18}
19
20do_install () {
21 install -d ${D}${bindir}
22 install -m 0644 NNET.DAT ${D}${bindir}/
23 install -m 0755 nbench ${D}${bindir}/
24}