diff options
author | Mingli Yu <Mingli.Yu@windriver.com> | 2018-08-21 15:57:39 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-08-21 10:35:32 -0700 |
commit | 739349da0826221f98648b64b693f9ae33e7d4ea (patch) | |
tree | 31f6371d941a6d65a182fa3769eb4101bc362744 /meta-oe/recipes-benchmark | |
parent | feafef878a573ad11e14084dc21b9f44f5b199ab (diff) | |
download | meta-openembedded-739349da0826221f98648b64b693f9ae33e7d4ea.tar.gz |
fio: disable compiler optimizations
Pass parameter "--disable-optimizations" to
configure script to disable compiler optimizations
to fix below issue:
$ gdb /usr/bin/fio
(gdb) r -h
Starting program: /usr/bin/fio -h
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
Program received signal SIGILL, Illegal instruction.
0x0000000000407220 in prio_tree_init () at lib/prio_tree.c:61
61 index_bits_to_maxindex[i] = (1UL << (i + 1)) - 1;
(gdb) bt
#0 0x0000000000407220 in prio_tree_init () at lib/prio_tree.c:61
#1 0x0000000000482208 in __libc_csu_init (argc=argc@entry=2,
argv=argv@entry=0x7fffffffecc8, envp=0x7fffffffece0)
at /usr/src/debug/glibc/2.26-r0/git/csu/elf-init.c:88
#2 0x00000031c742095e in __libc_start_main (main=0x407700 <main>, argc=2,
argv=0x7fffffffecc8, init=0x4821b6 <__libc_csu_init>,
fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffffffecb8)
at /usr/src/debug/glibc/2.26-r0/git/csu/libc-start.c:264
#3 0x00000000004077ea in _start () at ../sysdeps/x86_64/start.S:120
Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r-- | meta-oe/recipes-benchmark/fio/fio_3.8.bb | 1 |
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/fio/fio_3.8.bb b/meta-oe/recipes-benchmark/fio/fio_3.8.bb index eb517c3f7..5bc48b052 100644 --- a/meta-oe/recipes-benchmark/fio/fio_3.8.bb +++ b/meta-oe/recipes-benchmark/fio/fio_3.8.bb | |||
@@ -32,6 +32,7 @@ S = "${WORKDIR}/git" | |||
32 | DISABLE_STATIC = "" | 32 | DISABLE_STATIC = "" |
33 | 33 | ||
34 | EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}'" | 34 | EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}'" |
35 | EXTRA_OECONF = "--disable-optimizations" | ||
35 | 36 | ||
36 | do_configure() { | 37 | do_configure() { |
37 | ./configure ${EXTRA_OECONF} | 38 | ./configure ${EXTRA_OECONF} |