summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorAnders Roxell <anders.roxell@linaro.org>2018-10-19 16:54:16 +0200
committerKhem Raj <raj.khem@gmail.com>2018-10-19 11:03:19 -0700
commit8a824ee1f40e4995f7a8634f7cbbd3a38841131f (patch)
tree386744c46926ad59657f60064ae27e6b0dbd7f5e /meta-oe/recipes-benchmark
parentfe774606426f6f3399774401d81f894534679f53 (diff)
downloadmeta-openembedded-8a824ee1f40e4995f7a8634f7cbbd3a38841131f.tar.gz
add a storage I/O benchmark test suite
Signed-off-by: Anders Roxell <anders.roxell@linaro.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/s-suite/s-suite_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/s-suite/s-suite_git.bb b/meta-oe/recipes-benchmark/s-suite/s-suite_git.bb
new file mode 100644
index 000000000..77d172814
--- /dev/null
+++ b/meta-oe/recipes-benchmark/s-suite/s-suite_git.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Small collection of benchmarks for storage I/O"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b529aaa6a0c50f15d29f89609b5c22f3"
4
5SRCREV = "79698f645bfb28d0d966484ddad3a1efb562246d"
6PV = "0.0+git${SRCPV}"
7SRC_URI = "git://github.com/Algodev-github/S.git;protocol=https;branch=master"
8
9S = "${WORKDIR}/git"
10
11# installing in /opt/S-suite since the package has
12# dependencies to the directory structure.
13do_install() {
14 install -d ${D}/opt/S-suite
15 for i in $(find ${S}/* -type d); do
16 install -d ${D}/opt/S-suite/$(basename $i)
17 install -m0755 -p ${S}/$(basename $i)/* ${D}/opt/S-suite/$(basename $i)
18 done
19
20 install -m0755 ${S}/config_params.sh ${D}/opt/S-suite
21 install -m0755 ${S}/def_config_params.sh ${D}/opt/S-suite
22}
23
24RDEPENDS_${PN} = "bash bc coreutils gawk g++ gcc fio libaio libaio-dev sysstat"
25
26FILES_${PN} = "/opt/S-suite/"
27
28# added to INSANE_SKIP since s-suite have an runtime
29# dependency (RDEPENDS) on libaio-dev.
30INSANE_SKIP_${PN} += "dev-deps"