diff options
author | Noor Ahsan <noor_ahsan@mentor.com> | 2011-08-30 21:08:32 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-09-01 13:05:42 +0200 |
commit | 0c5db4e86d35f0fdd1e2077ece2f7f8af86e85bb (patch) | |
tree | 71da1ac15b40a2a032431b20f90dfb1fcaf18317 /meta-oe/recipes-benchmark | |
parent | 2917b4f41c2731c91fa55057ca5172f1915ccddb (diff) | |
download | meta-openembedded-0c5db4e86d35f0fdd1e2077ece2f7f8af86e85bb.tar.gz |
bonnie++: Add version 1.03c (initial recipe)
* Imported from oe.dev commit id 44985d56bc556786812a0a02d6219afd31a7381d.
* Merge .bb and .inc file.
Signed-off-by: Noor Ahsan <noor_ahsan@mentor.com>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r-- | meta-oe/recipes-benchmark/bonnie/bonnie++_1.03c.bb | 32 | ||||
-rw-r--r-- | meta-oe/recipes-benchmark/bonnie/files/gcc-4.3-fixes.patch | 19 |
2 files changed, 51 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/bonnie/bonnie++_1.03c.bb b/meta-oe/recipes-benchmark/bonnie/bonnie++_1.03c.bb new file mode 100644 index 000000000..7a6b798bd --- /dev/null +++ b/meta-oe/recipes-benchmark/bonnie/bonnie++_1.03c.bb | |||
@@ -0,0 +1,32 @@ | |||
1 | DESCRIPTION = "Tests large file IO and creation/deletion of small files." | ||
2 | HOMEPAGE = "http://www.coker.com.au/bonnie++/" | ||
3 | LICENSE = "GPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://copyright.txt;md5=cd4dde95a6b9d122f0a9150ae9cc3ee0" | ||
5 | |||
6 | SRC_URI = "http://www.coker.com.au/bonnie++/bonnie++-${PV}.tgz \ | ||
7 | file://gcc-4.3-fixes.patch \ | ||
8 | " | ||
9 | SRC_URI[md5sum] = "77a1ba78f37bdd7f024b67e1e36ad151" | ||
10 | SRC_URI[sha256sum] = "c674f1182f4c20f1e6d038feceb0a6617fc3e7658dfbbac89396043b49612a26" | ||
11 | |||
12 | inherit autotools | ||
13 | |||
14 | SCRIPTS = "bon_csv2html bon_csv2txt" | ||
15 | EXES = "bonnie++ zcav" | ||
16 | |||
17 | TARGET_CC_ARCH += "${LDFLAGS}" | ||
18 | |||
19 | do_install () { | ||
20 | install -d ${D}/bin | ||
21 | install -d ${D}/sbin | ||
22 | install -m 0755 ${EXES} ${D}/sbin | ||
23 | install -m 0755 ${SCRIPTS} ${D}/bin | ||
24 | } | ||
25 | |||
26 | PACKAGES =+ "bonnie-scripts" | ||
27 | |||
28 | FILES_${PN} = "${base_sbindir}" | ||
29 | FILES_bonnie-scripts = "${base_bindir}" | ||
30 | |||
31 | |||
32 | |||
diff --git a/meta-oe/recipes-benchmark/bonnie/files/gcc-4.3-fixes.patch b/meta-oe/recipes-benchmark/bonnie/files/gcc-4.3-fixes.patch new file mode 100644 index 000000000..67f1b7494 --- /dev/null +++ b/meta-oe/recipes-benchmark/bonnie/files/gcc-4.3-fixes.patch | |||
@@ -0,0 +1,19 @@ | |||
1 | Includes string.h to one of the source file. | ||
2 | |||
3 | Upstream-Status: Inappropriate [not author.] | ||
4 | --- | ||
5 | zcav.cpp | 1 + | ||
6 | 1 file changed, 1 insertion(+) | ||
7 | |||
8 | Index: bonnie++-1.03a/zcav.cpp | ||
9 | =================================================================== | ||
10 | --- bonnie++-1.03a.orig/zcav.cpp | ||
11 | +++ bonnie++-1.03a/zcav.cpp | ||
12 | @@ -15,6 +15,7 @@ using namespace std; | ||
13 | #else | ||
14 | #include <vector.h> | ||
15 | #endif | ||
16 | +#include <string.h> | ||
17 | |||
18 | // Read the specified number of megabytes of data from the fd and return the | ||
19 | // amount of time elapsed in seconds. | ||