diff options
author | Neena Busireddy <neenareddy.busireddy@nxp.com> | 2016-05-02 14:22:34 -0500 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-05-06 12:40:25 +0200 |
commit | c7265a61d78f643b9370762036e87a4408c05a1e (patch) | |
tree | cf0e6ffdbf6b49bdb52405d76bfd190e6e25f313 /meta-oe/recipes-benchmark | |
parent | f4ee5549c3d5f063efab8d1732998ac162b94aa5 (diff) | |
download | meta-openembedded-c7265a61d78f643b9370762036e87a4408c05a1e.tar.gz |
glmark2: wl_surface should be destoryed after destroying wl_window
If wl_surface is destroyed while work thread is still running,
segmentation fault occurs.
Signed-off-by: Neena Busireddy <neenareddy.busireddy@nxp.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r-- | meta-oe/recipes-benchmark/glmark2/files/0001-Fix-wl_surface-should-be-destoryed-after-the-wl_wind.patch | 34 | ||||
-rw-r--r-- | meta-oe/recipes-benchmark/glmark2/glmark2_git.bb | 3 |
2 files changed, 36 insertions, 1 deletions
diff --git a/meta-oe/recipes-benchmark/glmark2/files/0001-Fix-wl_surface-should-be-destoryed-after-the-wl_wind.patch b/meta-oe/recipes-benchmark/glmark2/files/0001-Fix-wl_surface-should-be-destoryed-after-the-wl_wind.patch new file mode 100644 index 000000000..439508102 --- /dev/null +++ b/meta-oe/recipes-benchmark/glmark2/files/0001-Fix-wl_surface-should-be-destoryed-after-the-wl_wind.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From 9c74ec83e2929b1d5ab65d5137b6ba42edeb332d Mon Sep 17 00:00:00 2001 | ||
2 | From: Yong Gan <b45748@freescale.com> | ||
3 | Date: Tue, 27 Oct 2015 18:15:20 +0800 | ||
4 | Subject: [PATCH] Fix: wl_surface should be destoryed after the wl_window | ||
5 | destroyed. | ||
6 | |||
7 | Upstream-Status: Submitted [https://github.com/glmark2/glmark2/issues/12] | ||
8 | |||
9 | Signed-off-by: Yong Gan <b45748@freescale.com> | ||
10 | |||
11 | --- | ||
12 | src/native-state-wayland.cpp | 4 ++-- | ||
13 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
14 | |||
15 | diff --git a/src/native-state-wayland.cpp b/src/native-state-wayland.cpp | ||
16 | index 41fc743..cdcdf34 100644 | ||
17 | --- a/src/native-state-wayland.cpp | ||
18 | +++ b/src/native-state-wayland.cpp | ||
19 | @@ -56,10 +56,10 @@ NativeStateWayland::~NativeStateWayland() | ||
20 | wl_shell_surface_destroy(window_->shell_surface); | ||
21 | if (window_->opaque_reqion) | ||
22 | wl_region_destroy(window_->opaque_reqion); | ||
23 | - if (window_->surface) | ||
24 | - wl_surface_destroy(window_->surface); | ||
25 | if (window_->native) | ||
26 | wl_egl_window_destroy(window_->native); | ||
27 | + if (window_->surface) | ||
28 | + wl_surface_destroy(window_->surface); | ||
29 | delete window_; | ||
30 | } | ||
31 | |||
32 | -- | ||
33 | 1.9.1 | ||
34 | |||
diff --git a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb index 98ce3773f..e29921b52 100644 --- a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb +++ b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb | |||
@@ -13,7 +13,8 @@ DEPENDS = "libpng12 jpeg" | |||
13 | PV = "2014.03+${SRCPV}" | 13 | PV = "2014.03+${SRCPV}" |
14 | 14 | ||
15 | SRC_URI = "git://github.com/glmark2/glmark2.git;protocol=https \ | 15 | SRC_URI = "git://github.com/glmark2/glmark2.git;protocol=https \ |
16 | file://build-Check-packages-to-be-used-by-the-enabled-flavo.patch" | 16 | file://build-Check-packages-to-be-used-by-the-enabled-flavo.patch \ |
17 | file://0001-Fix-wl_surface-should-be-destoryed-after-the-wl_wind.patch" | ||
17 | SRCREV = "fa71af2dfab711fac87b9504b6fc9862f44bf72a" | 18 | SRCREV = "fa71af2dfab711fac87b9504b6fc9862f44bf72a" |
18 | 19 | ||
19 | S = "${WORKDIR}/git" | 20 | S = "${WORKDIR}/git" |