diff options
author | Andreas Müller <schnitzeltony@googlemail.com> | 2016-11-08 00:49:56 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-11-22 13:38:30 +0100 |
commit | 913d1ea5d1b6684f24566acf96b4930b678daf97 (patch) | |
tree | 5a1faf170dab761568547d1633648ae0a44155e0 /meta-oe/recipes-benchmark | |
parent | 06a1221a310364550e3662b16c2a3c5a2ca297a2 (diff) | |
download | meta-openembedded-913d1ea5d1b6684f24566acf96b4930b678daf97.tar.gz |
glmark: update to latest sources
With mesa 13.0.0 glmark-es2 crashed at the terrain part. This bug was fixed in
the latest commit. See further details at [1].
[1] https://github.com/glmark2/glmark2/issues/25
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
4 files changed, 10 insertions, 98 deletions
diff --git a/meta-oe/recipes-benchmark/glmark2/files/Fix-build-error-due-missing-space-before-macro.patch b/meta-oe/recipes-benchmark/glmark2/files/Fix-build-error-due-missing-space-before-macro.patch deleted file mode 100644 index 00eb2ed73..000000000 --- a/meta-oe/recipes-benchmark/glmark2/files/Fix-build-error-due-missing-space-before-macro.patch +++ /dev/null | |||
@@ -1,27 +0,0 @@ | |||
1 | From 3fb9b6aeed2e2758239e59ba9ba1ca98535fe510 Mon Sep 17 00:00:00 2001 | ||
2 | From: Otavio Salvador <otavio@ossystems.com.br> | ||
3 | Date: Fri, 19 Aug 2016 15:08:44 +0000 | ||
4 | Subject: [PATCH] Fix build error due missing space before macro | ||
5 | Organization: O.S. Systems Software LTDA. | ||
6 | |||
7 | Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> | ||
8 | --- | ||
9 | src/native-state-x11.cpp | 2 +- | ||
10 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
11 | |||
12 | diff --git a/src/native-state-x11.cpp b/src/native-state-x11.cpp | ||
13 | index 3b66b77..3c1703b 100644 | ||
14 | --- a/src/native-state-x11.cpp | ||
15 | +++ b/src/native-state-x11.cpp | ||
16 | @@ -60,7 +60,7 @@ NativeStateX11::display() | ||
17 | bool | ||
18 | NativeStateX11::create_window(WindowProperties const& properties) | ||
19 | { | ||
20 | - static const char *win_name("glmark2 "GLMARK_VERSION); | ||
21 | + static const char *win_name("glmark2 " GLMARK_VERSION); | ||
22 | |||
23 | if (!xdpy_) { | ||
24 | Log::error("Error: X11 Display has not been initialized!\n"); | ||
25 | -- | ||
26 | 2.1.4 | ||
27 | |||
diff --git a/meta-oe/recipes-benchmark/glmark2/files/Fix-deprecated-declarations.patch b/meta-oe/recipes-benchmark/glmark2/files/Fix-deprecated-declarations.patch deleted file mode 100644 index 7a25de790..000000000 --- a/meta-oe/recipes-benchmark/glmark2/files/Fix-deprecated-declarations.patch +++ /dev/null | |||
@@ -1,61 +0,0 @@ | |||
1 | Index: git/src/image-reader.cpp | ||
2 | =================================================================== | ||
3 | --- git.orig/src/image-reader.cpp 2016-07-29 16:17:51.000000000 -0500 | ||
4 | +++ git/src/image-reader.cpp 2016-07-29 16:18:43.000000000 -0500 | ||
5 | @@ -120,7 +120,7 @@ | ||
6 | |||
7 | Log::debug("Reading PNG file %s\n", filename.c_str()); | ||
8 | |||
9 | - const std::auto_ptr<std::istream> is_ptr(Util::get_resource(filename)); | ||
10 | + const std::unique_ptr<std::istream> is_ptr(Util::get_resource(filename)); | ||
11 | if (!(*is_ptr)) { | ||
12 | Log::error("Cannot open file %s!\n", filename.c_str()); | ||
13 | return false; | ||
14 | Index: git/src/libmatrix/shader-source.cc | ||
15 | =================================================================== | ||
16 | --- git.orig/src/libmatrix/shader-source.cc 2016-07-29 16:18:14.000000000 -0500 | ||
17 | +++ git/src/libmatrix/shader-source.cc 2016-07-29 16:18:43.000000000 -0500 | ||
18 | @@ -34,7 +34,7 @@ | ||
19 | bool | ||
20 | ShaderSource::load_file(const std::string& filename, std::string& str) | ||
21 | { | ||
22 | - std::auto_ptr<std::istream> is_ptr(Util::get_resource(filename)); | ||
23 | + std::unique_ptr<std::istream> is_ptr(Util::get_resource(filename)); | ||
24 | std::istream& inputFile(*is_ptr); | ||
25 | |||
26 | if (!inputFile) | ||
27 | Index: git/src/model.cpp | ||
28 | =================================================================== | ||
29 | --- git.orig/src/model.cpp 2016-07-29 16:18:00.000000000 -0500 | ||
30 | +++ git/src/model.cpp 2016-07-29 16:18:43.000000000 -0500 | ||
31 | @@ -361,7 +361,7 @@ | ||
32 | |||
33 | Log::debug("Loading model from 3ds file '%s'\n", filename.c_str()); | ||
34 | |||
35 | - const std::auto_ptr<std::istream> input_file_ptr(Util::get_resource(filename)); | ||
36 | + const std::unique_ptr<std::istream> input_file_ptr(Util::get_resource(filename)); | ||
37 | std::istream& input_file(*input_file_ptr); | ||
38 | |||
39 | if (!input_file) { | ||
40 | @@ -681,7 +681,7 @@ | ||
41 | { | ||
42 | Log::debug("Loading model from obj file '%s'\n", filename.c_str()); | ||
43 | |||
44 | - const std::auto_ptr<std::istream> input_file_ptr(Util::get_resource(filename)); | ||
45 | + const std::unique_ptr<std::istream> input_file_ptr(Util::get_resource(filename)); | ||
46 | std::istream& inputFile(*input_file_ptr); | ||
47 | if (!inputFile) | ||
48 | { | ||
49 | Index: git/src/scene-jellyfish.cpp | ||
50 | =================================================================== | ||
51 | --- git.orig/src/scene-jellyfish.cpp 2016-07-29 16:18:08.000000000 -0500 | ||
52 | +++ git/src/scene-jellyfish.cpp 2016-07-29 16:18:43.000000000 -0500 | ||
53 | @@ -272,7 +272,7 @@ | ||
54 | { | ||
55 | Log::debug("Loading model from file '%s'\n", filename.c_str()); | ||
56 | |||
57 | - const std::auto_ptr<std::istream> input_file_ptr(Util::get_resource(filename)); | ||
58 | + const std::unique_ptr<std::istream> input_file_ptr(Util::get_resource(filename)); | ||
59 | std::istream& inputFile(*input_file_ptr); | ||
60 | if (!inputFile) | ||
61 | { | ||
diff --git a/meta-oe/recipes-benchmark/glmark2/files/build-Check-packages-to-be-used-by-the-enabled-flavo.patch b/meta-oe/recipes-benchmark/glmark2/files/build-Check-packages-to-be-used-by-the-enabled-flavo.patch index ff13329ae..72b8debe5 100644 --- a/meta-oe/recipes-benchmark/glmark2/files/build-Check-packages-to-be-used-by-the-enabled-flavo.patch +++ b/meta-oe/recipes-benchmark/glmark2/files/build-Check-packages-to-be-used-by-the-enabled-flavo.patch | |||
@@ -18,9 +18,9 @@ index cab62a3..e7eaed0 100644 | |||
18 | --- a/wscript | 18 | --- a/wscript |
19 | +++ b/wscript | 19 | +++ b/wscript |
20 | @@ -121,13 +121,17 @@ def configure(ctx): | 20 | @@ -121,13 +121,17 @@ def configure(ctx): |
21 | ('mirclient','mirclient', '0.13', list_contains(Options.options.flavors, 'mir')), | 21 | ('mirclient','mirclient', '0.13', list_contains(ctx.options.flavors, 'mir')), |
22 | ('wayland-client','wayland-client', None, list_contains(Options.options.flavors, 'wayland')), | 22 | ('wayland-client','wayland-client', None, list_contains(ctx.options.flavors, 'wayland')), |
23 | ('wayland-egl','wayland-egl', None, list_contains(Options.options.flavors, 'wayland'))] | 23 | ('wayland-egl','wayland-egl', None, list_contains(ctx.options.flavors, 'wayland'))] |
24 | - for (pkg, uselib, atleast, mandatory) in opt_pkgs: | 24 | - for (pkg, uselib, atleast, mandatory) in opt_pkgs: |
25 | + for (pkg, uselib, atleast, check) in opt_pkgs: | 25 | + for (pkg, uselib, atleast, check) in opt_pkgs: |
26 | + # Check packages required by the flavors | 26 | + # Check packages required by the flavors |
diff --git a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb index a2558a72a..e8ccf3799 100644 --- a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb +++ b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb | |||
@@ -12,13 +12,13 @@ DEPENDS = "libpng12 jpeg" | |||
12 | 12 | ||
13 | PV = "2014.03+${SRCPV}" | 13 | PV = "2014.03+${SRCPV}" |
14 | 14 | ||
15 | SRC_URI = "git://github.com/glmark2/glmark2.git;protocol=https \ | 15 | SRC_URI = " \ |
16 | file://build-Check-packages-to-be-used-by-the-enabled-flavo.patch \ | 16 | git://github.com/glmark2/glmark2.git;protocol=https \ |
17 | file://0001-Fix-wl_surface-should-be-destoryed-after-the-wl_wind.patch \ | 17 | file://build-Check-packages-to-be-used-by-the-enabled-flavo.patch \ |
18 | file://Fix-build-error-due-missing-space-before-macro.patch \ | 18 | file://0001-Fix-wl_surface-should-be-destoryed-after-the-wl_wind.patch \ |
19 | file://Fix-configure-for-sqrt-check.patch \ | 19 | file://Fix-configure-for-sqrt-check.patch \ |
20 | file://Fix-deprecated-declarations.patch" | 20 | " |
21 | SRCREV = "fa71af2dfab711fac87b9504b6fc9862f44bf72a" | 21 | SRCREV = "f413c5b423250b4fde8f95639ad368d5b02c5b9b" |
22 | 22 | ||
23 | S = "${WORKDIR}/git" | 23 | S = "${WORKDIR}/git" |
24 | 24 | ||